summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-08-01 00:53:38 -0400
committerDavid Seifert <soap@gentoo.org>2017-08-13 13:06:06 +0200
commitf9f037be81b3eefde94e3bf71e9c97fd997da5c1 (patch)
tree6b3a86cab020ea5972e40cff794f3dc25cce7f5f
parentgames-strategy/ja2-stracciatella: Fix building with GCC-6 (diff)
downloadgentoo-f9f037be81b3eefde94e3bf71e9c97fd997da5c1.tar.gz
gentoo-f9f037be81b3eefde94e3bf71e9c97fd997da5c1.tar.bz2
gentoo-f9f037be81b3eefde94e3bf71e9c97fd997da5c1.zip
media-sound/audacious: Fix building with -Werror=terminate using GCC-6
Bug: https://bugs.gentoo.org/show_bug.cgi?id=600882 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/5264
-rw-r--r--media-sound/audacious/audacious-3.7.1-r1.ebuild4
-rw-r--r--media-sound/audacious/files/audacious-3.7.1-c++11-throw-in-dtors.patch39
2 files changed, 43 insertions, 0 deletions
diff --git a/media-sound/audacious/audacious-3.7.1-r1.ebuild b/media-sound/audacious/audacious-3.7.1-r1.ebuild
index 800ba90ecbcc..808810c14cbc 100644
--- a/media-sound/audacious/audacious-3.7.1-r1.ebuild
+++ b/media-sound/audacious/audacious-3.7.1-r1.ebuild
@@ -48,6 +48,10 @@ src_unpack() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-c++11-throw-in-dtors.patch
+}
+
src_configure() {
if use gtk ;then
gtk="--enable-gtk"
diff --git a/media-sound/audacious/files/audacious-3.7.1-c++11-throw-in-dtors.patch b/media-sound/audacious/files/audacious-3.7.1-c++11-throw-in-dtors.patch
new file mode 100644
index 000000000000..309dbc0319f2
--- /dev/null
+++ b/media-sound/audacious/files/audacious-3.7.1-c++11-throw-in-dtors.patch
@@ -0,0 +1,39 @@
+Bug: https://bugs.gentoo.org/600882
+Upstream commit: https://github.com/audacious-media-player/audacious/commit/1cf1a81a16cc70b2d9c78994ad98e26db99943ed
+
+From 1cf1a81a16cc70b2d9c78994ad98e26db99943ed Mon Sep 17 00:00:00 2001
+From: John Lindgren <john.lindgren@aol.com>
+Date: Sun, 8 May 2016 22:39:00 -0400
+Subject: [PATCH] Fix compiler warning.
+
+---
+ src/libaudcore/objects.h | 2 +-
+ src/libaudcore/stringbuf.cc | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/libaudcore/objects.h b/src/libaudcore/objects.h
+index fd57f5e15..4b98cc624 100644
+--- a/src/libaudcore/objects.h
++++ b/src/libaudcore/objects.h
+@@ -250,7 +250,7 @@ class StringBuf
+ }
+
+ // only allowed for top (or null) string
+- ~StringBuf ();
++ ~StringBuf () noexcept (false);
+
+ // only allowed for top (or null) string
+ void resize (int size);
+diff --git a/src/libaudcore/stringbuf.cc b/src/libaudcore/stringbuf.cc
+index 041b1e9de..fc646f6ab 100644
+--- a/src/libaudcore/stringbuf.cc
++++ b/src/libaudcore/stringbuf.cc
+@@ -139,7 +139,7 @@ EXPORT void StringBuf::resize (int len)
+ }
+ }
+
+-EXPORT StringBuf::~StringBuf ()
++EXPORT StringBuf::~StringBuf () noexcept (false)
+ {
+ if (m_data)
+ {