summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 14:04:41 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:06:53 +0000
commitfa21a7c55550423ce58d13fe5ca82cd79d4c3005 (patch)
treec958dadae4091fc5de025674ffd62a87911129a6
parentlxqt-base/lxqt-openssh-askpass: version bump to 1.0.0 (diff)
downloadgentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.tar.gz
gentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.tar.bz2
gentoo-fa21a7c55550423ce58d13fe5ca82cd79d4c3005.zip
lxqt-base/lxqt-admin: version bump to 1.0.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--lxqt-base/lxqt-admin/Manifest1
-rw-r--r--lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-admin/Manifest b/lxqt-base/lxqt-admin/Manifest
index 5178d4bd80f9..a3b98f3ee584 100644
--- a/lxqt-base/lxqt-admin/Manifest
+++ b/lxqt-base/lxqt-admin/Manifest
@@ -1 +1,2 @@
DIST lxqt-admin-0.17.0.tar.xz 145620 BLAKE2B 3f1bc0870ef33a85a14dca559951826c56a2ebe81f6cad53917db87ce38b909aed4daed7964d202715dd4d9c7947b23f2aba0fdcb020b6b418c91d9f12c90573 SHA512 5d807b1bbde586130ab03cecf43dc190cbbed5c16842d14779f67f7b514689e7ea330f6c75916c733e4e840242d7feaceb4b6e0932ece1ca70bff208eb5e8072
+DIST lxqt-admin-1.0.0.tar.xz 148732 BLAKE2B 0d3b654f90bd2573629ebb6c61faec621d3c7f547c7690e071d42bab2c062b495043bfa6c2e1d8107b2d2457635dc02ce6d0323906ae25203a4f84a17f0f0fda SHA512 af1cbdd0e04116ad575b652b4eef0fd0a403b37e169961797cc365fe69e5655c6291205165baab4bb3337506785d70149f2b6175758448bd06800fa6f4eb4617
diff --git a/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
new file mode 100644
index 000000000000..f98a17eedd2d
--- /dev/null
+++ b/lxqt-base/lxqt-admin/lxqt-admin-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt system administration tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.10.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ kde-frameworks/kwindowsystem:5
+ >=sys-auth/polkit-qt-0.113.0
+"
+RDEPEND="${DEPEND}"