summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-25 22:07:33 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-02-25 22:07:51 +0100
commitfa2669694266947a8d0aa75664ac5ad389058974 (patch)
tree2ee9144b47fe5ff01e36c5236c870a63c18c6306
parentdev-java/failureaccess: Stabilize 30.1.1 arm64, #833758 (diff)
downloadgentoo-fa2669694266947a8d0aa75664ac5ad389058974.tar.gz
gentoo-fa2669694266947a8d0aa75664ac5ad389058974.tar.bz2
gentoo-fa2669694266947a8d0aa75664ac5ad389058974.zip
app-text/xournalpp: Version bump 1.1.1
Closes: https://bugs.gentoo.org/833353 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--app-text/xournalpp/Manifest1
-rw-r--r--app-text/xournalpp/xournalpp-1.1.1.ebuild46
-rw-r--r--app-text/xournalpp/xournalpp-9999.ebuild9
3 files changed, 52 insertions, 4 deletions
diff --git a/app-text/xournalpp/Manifest b/app-text/xournalpp/Manifest
index b8173784952a..69801d025fac 100644
--- a/app-text/xournalpp/Manifest
+++ b/app-text/xournalpp/Manifest
@@ -1 +1,2 @@
DIST xournalpp-1.0.20.tgz 14895705 BLAKE2B f1a4721f4f0b2f0e666c7466d7ddbd1f299172576d5f86b4ab8150d3bf05231cc7bb40e750394d892fe8ce32b6106e29456e3e9fa976b1bf07a808bf1bfff953 SHA512 c73783d5e40262b2c6f7f6be372839c73a19ab25fc258a7524660654526a3a35a6ba16ba282f793e7982ff97d006703c103fdd579fc16a3e636bf6daf94fe346
+DIST xournalpp-1.1.1.tgz 15093900 BLAKE2B 87988bc78a0d904f1e3533e393bcdfc7b76517f6cc13343cb63ceaa83de25eca885274238ce45840334ea653964c9cd1834fc22d5b2c89a731ae5616f01f22c8 SHA512 efba97d26f624e3a1b8164ef6333a0f1d2992d0245414bdb51692d845965f6c37071f687520b43a94f713465796a16cbafd8929fd3bf8e6c3face847df92251d
diff --git a/app-text/xournalpp/xournalpp-1.1.1.ebuild b/app-text/xournalpp/xournalpp-1.1.1.ebuild
new file mode 100644
index 000000000000..2c5a3a5f0527
--- /dev/null
+++ b/app-text/xournalpp/xournalpp-1.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
+ unset SRC_URI
+else
+ KEYWORDS="~amd64 ~ppc64"
+ SRC_URI="https://github.com/xournalpp/xournalpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
+fi
+
+DESCRIPTION="Handwriting notetaking software with PDF annotation support"
+HOMEPAGE="https://github.com/xournalpp/xournalpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+COMMONDEPEND="
+ app-text/poppler[cairo]
+ dev-libs/glib
+ dev-libs/libxml2
+ dev-libs/libzip:=
+ gnome-base/librsvg
+ media-libs/portaudio[cxx]
+ media-libs/libsndfile
+ sys-libs/zlib:=
+ x11-libs/gtk+:3
+"
+RDEPEND="${COMMONDEPEND}
+"
+DEPEND="${COMMONDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+ sys-apps/lsb-release
+"
+
+src_prepare() {
+ cmake_src_prepare
+}
diff --git a/app-text/xournalpp/xournalpp-9999.ebuild b/app-text/xournalpp/xournalpp-9999.ebuild
index a2510c4f8952..2c5a3a5f0527 100644
--- a/app-text/xournalpp/xournalpp-9999.ebuild
+++ b/app-text/xournalpp/xournalpp-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg
@@ -10,8 +10,8 @@ if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/xournalpp/xournalpp.git"
unset SRC_URI
else
- KEYWORDS="~amd64"
- SRC_URI="https://github.com/xournalpp/xournalpp/archive/${PV}.tar.gz -> ${P}.tgz"
+ KEYWORDS="~amd64 ~ppc64"
+ SRC_URI="https://github.com/xournalpp/xournalpp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tgz"
fi
DESCRIPTION="Handwriting notetaking software with PDF annotation support"
@@ -26,6 +26,7 @@ COMMONDEPEND="
dev-libs/glib
dev-libs/libxml2
dev-libs/libzip:=
+ gnome-base/librsvg
media-libs/portaudio[cxx]
media-libs/libsndfile
sys-libs/zlib:=