summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-21 20:39:07 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-21 20:43:23 +0100
commitfa7891a09a3f4798acee244620a98d81bb730592 (patch)
tree9ebce83e157573c1f0b0ccd96fb4ddbac45c86e7
parentnet-fs/samba: stable 4.5.15 for sparc, bug #639024 (diff)
downloadgentoo-fa7891a09a3f4798acee244620a98d81bb730592.tar.gz
gentoo-fa7891a09a3f4798acee244620a98d81bb730592.tar.bz2
gentoo-fa7891a09a3f4798acee244620a98d81bb730592.zip
dev-python/asn1crypto: Bump to 0.24.0, use gh tarball for tests
-rw-r--r--dev-python/asn1crypto/Manifest1
-rw-r--r--dev-python/asn1crypto/asn1crypto-0.24.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index 17e8c6fd5711..dbe0d997b39e 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1 +1,2 @@
DIST asn1crypto-0.22.0.tar.gz 84508 BLAKE2B 5f21e13e6af0f5edf6f79454654e677182e2ae06a36d3f86a641e76e5043f8818fd17dbce40a8b0c4070a254fdd169a3eada99434f3b9e4097d4c106a774c30c SHA512 fdc98f71ec3b744e69a75909b5b0a8381fb82d448941a6e1059823af47ca107218e1dbe6ff192e2173f11fc2454be1afcd387d801dc8e716451179857d71f8b8
+DIST asn1crypto-0.24.0.gh.tar.gz 641322 BLAKE2B eb30afd0d2579f44ee4f556139357dc7622691bdc2067df913a4412cd3dca8372b85d84e3a3cbef6ba83648bf4ef55d7e8614992e2abb019301c92d24b15a926 SHA512 426cc380903b4dd7aadd7b831e3a11ee3442c961a33b856d4aa8d9060e829f2e0ad905a60c4d6504569718fe2cee01d9be31628c89ef030bc34281e381c898e8
diff --git a/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
new file mode 100644
index 000000000000..b84c9f3f19d3
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-0.24.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.python.org/pypi/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x64-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}