summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:38:07 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:38:07 +0100
commitfab779f57996de19dbe3b846408972aded436c8e (patch)
tree2a52e2be8e97836702f096c492eb3a5547633d13
parentmedia-plugins/gmpc-last-fm: Port to EAPI 6 (diff)
downloadgentoo-fab779f57996de19dbe3b846408972aded436c8e.tar.gz
gentoo-fab779f57996de19dbe3b846408972aded436c8e.tar.bz2
gentoo-fab779f57996de19dbe3b846408972aded436c8e.zip
media-plugins/gmpc-mdcover: Port to EAPI 6
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--media-plugins/gmpc-mdcover/gmpc-mdcover-0.20.0.ebuild30
1 files changed, 17 insertions, 13 deletions
diff --git a/media-plugins/gmpc-mdcover/gmpc-mdcover-0.20.0.ebuild b/media-plugins/gmpc-mdcover/gmpc-mdcover-0.20.0.ebuild
index cd59cfee0f9c..148b866d37b1 100644
--- a/media-plugins/gmpc-mdcover/gmpc-mdcover-0.20.0.ebuild
+++ b/media-plugins/gmpc-mdcover/gmpc-mdcover-0.20.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
-DESCRIPTION="This plugin fetches cover art, artist art, album and artist information from the file system"
+DESCRIPTION="Plugin for fetching cover art, artist art, album and artist information"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_MDCOVER"
SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
@@ -12,21 +12,25 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="nls"
-RDEPEND=">=media-sound/gmpc-${PV}
- dev-libs/libxml2
- || ( x11-libs/gdk-pixbuf:2[jpeg] x11-libs/gtk+:2[jpeg] )"
+RDEPEND="
+ >=media-sound/gmpc-${PV}
+ dev-libs/libxml2:=
+ || (
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:2[jpeg]
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig
- nls? ( dev-util/intltool
- sys-devel/gettext )"
+ nls? (
+ dev-util/intltool
+ sys-devel/gettext
+ )"
src_configure() {
- econf \
- $(use_enable nls) \
- --disable-dependency-tracking
+ econf $(use_enable nls)
}
src_install() {
- emake DESTDIR="${D}" install || die
- find "${ED}" -name "*.la" -delete || die
+ default
+ find "${D}" -name '*.la' -delete || die
}