summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-19 18:50:49 +0000
committerSam James <sam@gentoo.org>2022-11-19 19:04:25 +0000
commitfae22e479e6d00dc913bd8cd75739fbc94a042ba (patch)
tree0d4b70fc6401eab5b8cdcaab2bfcea887a954338
parentnet-analyzer/yersinia: further Clang 16 fixes (diff)
downloadgentoo-fae22e479e6d00dc913bd8cd75739fbc94a042ba.tar.gz
gentoo-fae22e479e6d00dc913bd8cd75739fbc94a042ba.tar.bz2
gentoo-fae22e479e6d00dc913bd8cd75739fbc94a042ba.zip
dev-db/kyotocabinet: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/879653 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/kyotocabinet/files/kyotocabinet-1.2.79-configure-clang16.patch12
-rw-r--r--dev-db/kyotocabinet/kyotocabinet-1.2.79-r1.ebuild (renamed from dev-db/kyotocabinet/kyotocabinet-1.2.79.ebuild)1
2 files changed, 13 insertions, 0 deletions
diff --git a/dev-db/kyotocabinet/files/kyotocabinet-1.2.79-configure-clang16.patch b/dev-db/kyotocabinet/files/kyotocabinet-1.2.79-configure-clang16.patch
new file mode 100644
index 000000000000..f066cd59bb3e
--- /dev/null
+++ b/dev-db/kyotocabinet/files/kyotocabinet-1.2.79-configure-clang16.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/879653
+--- a/configure.in
++++ b/configure.in
+@@ -194,7 +194,7 @@ test -n "$LDFLAGS" && MYLDFLAGS="$LDFLAGS $MYLDFLAGS"
+ AC_C_BIGENDIAN(MYCPPFLAGS="$MYCPPFLAGS -D_MYBIGEND")
+
+ printf 'checking for useless warnings... '
+-if printf 'main() {}' | $CC -xc \
++if printf 'int main(void) {}' | $CC -xc \
+ -Wno-unused-but-set-variable -Wno-unused-but-set-parameter -o config.tmp - >config.tmp 2>&1
+ then
+ MYCFLAGS="$MYCFLAGS -Wno-unused-but-set-variable -Wno-unused-but-set-parameter"
diff --git a/dev-db/kyotocabinet/kyotocabinet-1.2.79.ebuild b/dev-db/kyotocabinet/kyotocabinet-1.2.79-r1.ebuild
index 4d737ac5ad0b..4f78f7efd8c4 100644
--- a/dev-db/kyotocabinet/kyotocabinet-1.2.79.ebuild
+++ b/dev-db/kyotocabinet/kyotocabinet-1.2.79-r1.ebuild
@@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}"/fix_configure-1.2.62.patch
"${FILESDIR}"/${PN}-1.2.76-configure-8-byte-atomics.patch
"${FILESDIR}"/${PN}-1.2.76-flags.patch
+ "${FILESDIR}"/${PN}-1.2.79-configure-clang16.patch
)
src_prepare() {