summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-04-25 19:52:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-04-26 18:53:09 +0200
commitfb3b75d775473324156569085acdd5efe77fe079 (patch)
tree58fa34ba8a27ca422b1324a4b818eb4f3dbb8f98
parentdev-perl/AnyEvent-CacheDNS: Add licensing note for potential future use (diff)
downloadgentoo-fb3b75d775473324156569085acdd5efe77fe079.tar.gz
gentoo-fb3b75d775473324156569085acdd5efe77fe079.tar.bz2
gentoo-fb3b75d775473324156569085acdd5efe77fe079.zip
dev-python/peewee: Bump to 3.13.2, py3.{7,8}
Closes: https://bugs.gentoo.org/707370 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15346 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/peewee/Manifest1
-rw-r--r--dev-python/peewee/peewee-3.13.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/peewee/Manifest b/dev-python/peewee/Manifest
index 9f6ee255c26f..f0be807095a6 100644
--- a/dev-python/peewee/Manifest
+++ b/dev-python/peewee/Manifest
@@ -1 +1,2 @@
DIST peewee-3.1.0.tar.gz 705099 BLAKE2B 1dc528082337ae509fc9f91c521d7bf036179ad6b1a5a93e113d594ce819d3a9cdbb7e687b51acacdaf242d542dad138ce2a21f9dcc19483c7361788329a53ed SHA512 628eea27d51017a6ab87aae9ae851d749b0f437fe1806957b23408ad3c97bbb93e5b84c66c5e70bfb7b55c9f29a0c517b84e65adc0f979da450987d670661e84
+DIST peewee-3.13.2.tar.gz 871323 BLAKE2B 18fd9729ddd6ce3fe4a6963b697815d44e91b5078ba0b868e6b4f24f4cec9c5b01239d7f414f4f8c0871d3dc6bd5e0e37e218c9438cf1f7461bf729cb74049e4 SHA512 7304473f8e64df7cb2205900cfbdd52346d89e9639dc79ed6e13d5c4c11cc856e39e366772039097dc5ca86b4768fa4670dccd96a85cabfb522c463b31c40a8b
diff --git a/dev-python/peewee/peewee-3.13.2.ebuild b/dev-python/peewee/peewee-3.13.2.ebuild
new file mode 100644
index 000000000000..36f6047511b1
--- /dev/null
+++ b/dev-python/peewee/peewee-3.13.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}