summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-12-24 03:45:46 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-12-24 03:47:21 +0100
commitfb75aa659ac9fd8c44cb96b3c45441cca6ff58a0 (patch)
tree72bd6158db1a97fb1de8a53481cf9a34df642839
parentsci-mathematics/lean: drop old 3.49.1 (diff)
downloadgentoo-fb75aa659ac9fd8c44cb96b3c45441cca6ff58a0.tar.gz
gentoo-fb75aa659ac9fd8c44cb96b3c45441cca6ff58a0.tar.bz2
gentoo-fb75aa659ac9fd8c44cb96b3c45441cca6ff58a0.zip
sci-mathematics/lean: bump to 3.50.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.50.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 92f7b6631413..02c8c71ff07b 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,3 +1,4 @@
DIST lean-3.49.0.tar.gz 1918154 BLAKE2B 9f9973d00d2d5d5b7d26d50117c27754feb5132e88decd55859432a384dac2897184dcf8d841ad0034854657ac25e462dc69cdbe1cf2040787d108bb7e1370f4 SHA512 b4672843c2e923da8d56b91c14966fc2ec66c573564d68db9c52f9b40f2c97d82497f2ef6424b023c4ae50f6f0c11674e2d79053844ea669d226d0fe24077ade
DIST lean-3.50.0.tar.gz 1918549 BLAKE2B 79827ffb9f825dff040e41e9bcbd8306e2f3a116b74fc6e0831450765d5b896fad2a86ec5dd9e63bf0f8777b575d4ab7ae8d158c233364fad6d4437bc0767452 SHA512 2b8d730ef9d808a24a9708f2b33409510bd6b7350f515679ba0395a45fc2dea2125639cdeb867bec4ac9c8114e448fb9777a69f8859e172f6e694ecacbb07f56
DIST lean-3.50.1.tar.gz 1918323 BLAKE2B 3a26a6481a8472941a928a7b33b24231239e553cd4a4af5671f6a05f1fa68a54657518c4775b641239aa55401100e44c2797d7ae572405225657f1f7da8e193c SHA512 df2e5915e8a7f7e278e2d3472afe6cc23fec5de808b0cc1b20365ad41cfd03b1efda80523059a96c6b3d9b8b0ccab311700ee6a5d6c9751454ebe3b2f168cf77
+DIST lean-3.50.2.tar.gz 1918353 BLAKE2B 2a8c41eef0cc3c2d3e1b45ccd2383279a1a91c0de772c5fe3f1ffafc808db4b6e7342f2f72bd4c4120ed4248d60359c6e331f4adc1d26c6328b284549861c4de SHA512 58d085deb0354db0067e86e6097dad7f1543f356d4e50607b8cc049a19d867aa7ea03553bab3799c6ad18d0ef4fa468b0f966512d8bf0076526f90e93195a407
diff --git a/sci-mathematics/lean/lean-3.50.2.ebuild b/sci-mathematics/lean/lean-3.50.2.ebuild
new file mode 100644
index 000000000000..e008b81cf582
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.50.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit flag-o-matic cmake readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${S}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-CMakeLists-fix_flags.patch )
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ filter-lto
+
+ local mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=ON # bug 833900
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}