summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-01-14 14:16:44 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-01-14 18:36:03 +0100
commitfbd3af9cd1ddf39dbc1e9ecff66ac67795f7ad47 (patch)
tree01b154fe6de187fe9a33968abb61021e38403aad
parentsys-block/fio: Switch to rdma-core for rdma support (diff)
downloadgentoo-fbd3af9c.tar.gz
gentoo-fbd3af9c.tar.bz2
gentoo-fbd3af9c.zip
net-libs/ntirpc: Switch to rdma-core for rdma support
Closes: https://bugs.gentoo.org/831008 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--net-libs/ntirpc/ntirpc-3.4-r1.ebuild (renamed from net-libs/ntirpc/ntirpc-4.0.ebuild)4
-rw-r--r--net-libs/ntirpc/ntirpc-4.0-r1.ebuild (renamed from net-libs/ntirpc/ntirpc-3.4.ebuild)6
2 files changed, 5 insertions, 5 deletions
diff --git a/net-libs/ntirpc/ntirpc-4.0.ebuild b/net-libs/ntirpc/ntirpc-3.4-r1.ebuild
index 8688e4cc9382..e7d899f9943f 100644
--- a/net-libs/ntirpc/ntirpc-4.0.ebuild
+++ b/net-libs/ntirpc/ntirpc-3.4-r1.ebuild
@@ -17,8 +17,8 @@ IUSE="gssapi rdma"
# Since the GSS option only controls some extra files to be enabled,
# there's nothing to list in the depend string for it.
RDEPEND="
- dev-libs/userspace-rcu
- rdma? ( sys-fabric/librdmacm )
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
"
DEPEND="
${RDEPEND}
diff --git a/net-libs/ntirpc/ntirpc-3.4.ebuild b/net-libs/ntirpc/ntirpc-4.0-r1.ebuild
index 6e63e824706b..e7d899f9943f 100644
--- a/net-libs/ntirpc/ntirpc-3.4.ebuild
+++ b/net-libs/ntirpc/ntirpc-4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,8 +17,8 @@ IUSE="gssapi rdma"
# Since the GSS option only controls some extra files to be enabled,
# there's nothing to list in the depend string for it.
RDEPEND="
- dev-libs/userspace-rcu
- rdma? ( sys-fabric/librdmacm )
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
"
DEPEND="
${RDEPEND}