summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:55:05 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:37 +0100
commitfc16bd5500e86175b4a20212c3d4dde1feac3127 (patch)
tree68cc56ec4fd0041033ded2f35fcdd868b2b6990f
parentdev-python/wcag-contrast-ratio: Switch to PEP 517 build (diff)
downloadgentoo-fc16bd55.tar.gz
gentoo-fc16bd55.tar.bz2
gentoo-fc16bd55.zip
dev-python/wrapt: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/wrapt/wrapt-1.13.2-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/wrapt/wrapt-1.13.2-r1.ebuild b/dev-python/wrapt/wrapt-1.13.2-r1.ebuild
new file mode 100644
index 000000000000..5a6bf40b15a8
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.13.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}