summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-09-16 10:28:38 +0200
committerMarek Szuba <marecki@gentoo.org>2020-09-16 10:28:38 +0200
commitfc5d9f44a72f322fe371b20c4ba830a41b7ed93d (patch)
tree1d469155b885a9e075e3610e641a7a7ecb9b71c6
parentlicenses: Correct the "crosswire" licence (diff)
downloadgentoo-fc5d9f44a72f322fe371b20c4ba830a41b7ed93d.tar.gz
gentoo-fc5d9f44a72f322fe371b20c4ba830a41b7ed93d.tar.bz2
gentoo-fc5d9f44a72f322fe371b20c4ba830a41b7ed93d.zip
app-admin/ansible: drop 2.10.0
This is in fact ansible-base, which has got its own ebuilds now [1]. There is no upstream release of 'ansible' yet but there WILL be one, upstream has explicitly stated they will continue to provide this package and the latest pre-release, 2.10.0rc1, came out only yesterday [2, 3]. In the meantime "upgrading" from ansible-2.9 to ansible-base-2.10 removes all core modules/plug-ins, breaking all playbooks which do not explicitly fetch *all* the required modules through other means. As explained on gentoo-dev. [1] app-admin/ansible-base [2] https://github.com/ansible-collections/overview/blob/main/README.rst#q-once-the-next-version-of-ansible-is-released-will-my-playbooks-still-work [3] https://pypi.org/project/ansible/ Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-2.10.0.ebuild75
2 files changed, 0 insertions, 76 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 312a4365afc5..ccdb31c5f7de 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,3 +1,2 @@
DIST ansible-2.9.12.tar.gz 14260349 BLAKE2B 6d7fdc82489df755196b890b39c166e9639c94e4238b4bf33686a3ab17fcc92c6b3a05f80e1276795b966aaa318ec7d9003099950102c014adb1a5d730928633 SHA512 6c05c49e363d4d68516dfea448cead3e2c281d1288c9467a0b6dd083504f303df694ed1c5957ae6582b28acc937d12d13333254328e13bac430b9b7fa4354f23
DIST ansible-2.9.13.tar.gz 14261322 BLAKE2B 5de939a99cd703eaf240f536a9a4b707e3931364647782dde2bbebd5b755253594cbb1cf8c4e9f22a14fca85c9f018ee6ea26bce1cbe2145ba72e5f5ec313670 SHA512 cb08adf62df0f3650425a5d960baadd7439c7c1e95b8f9df3d08e7504f9622b9e5f7104b8700b0f1e9fe318d349a6a5728e9178f0193fb4a190456e30a2f1eb2
-DIST ansible-base-2.10.0.tar.gz 5775091 BLAKE2B 2a087b1a9d675c5218e8700f5b455ff280a5dc6e66b575a47755b9936c54594300e3c22acadbe14acfd335c3be788e3d63f6ad3c5c51650cbc036c77ceec41ef SHA512 f9e9631f9ce77e55b06d01814422cbc0ca170e3fbbbd5886e4f87065b68b4d7eefe1c782f6dce14241cc548192c7b06ef778446636be02a342d4bd112000126e
diff --git a/app-admin/ansible/ansible-2.10.0.ebuild b/app-admin/ansible/ansible-2.10.0.ebuild
deleted file mode 100644
index 1477fa51b693..000000000000
--- a/app-admin/ansible/ansible-2.10.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Model-driven deployment, config management, and command execution framework"
-HOMEPAGE="https://ansible.com/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}-base/${PN}-base-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-base-${PV}"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86 ~x64-macos"
-IUSE="doc test"
-RESTRICT="test"
-
-RDEPEND="
- dev-python/paramiko[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/netaddr[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- net-misc/sshpass
- virtual/ssh
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- dev-python/passlib[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-
-python_compile() {
- # disable version checks on upgrade
- export ANSIBLE_SKIP_CONFLICT_CHECK=1
- distutils-r1_python_compile
-}
-
-python_compile_all() {
- if use doc; then
- cd docs/docsite || die
- export CPUS=4
- emake -f Makefile.sphinx html
- fi
-}
-
-python_test() {
- nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
- distutils-r1_python_install_all
-
- dodoc -r examples
-}