summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2019-04-21 22:39:14 -0500
committerErik Mackdanz <stasibear@gentoo.org>2019-04-21 22:39:30 -0500
commitfd44a0db16ed57168769353d29d1b501732c6e9b (patch)
treed816c95de141121729d555d58c5286a896fe57aa
parentmedia-sound/upmpdcli: stabilize 1.14.0 (diff)
downloadgentoo-fd44a0db16ed57168769353d29d1b501732c6e9b.tar.gz
gentoo-fd44a0db16ed57168769353d29d1b501732c6e9b.tar.bz2
gentoo-fd44a0db16ed57168769353d29d1b501732c6e9b.zip
media-sound/upmpdcli: bump to 1.4.2
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Closes: https://bugs.gentoo.org/683272 Package-Manager: Portage-2.3.62, Repoman-2.3.12
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.4.2.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index c879d05a9cf7..7f9f693cfa63 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1,2 +1,3 @@
DIST upmpdcli-1.3.6.tar.gz 515712 BLAKE2B 6de6a3af2e474a3f8d12865e3cdd420f31955e88a0eb1c8ffd019809666c4c613631d642b34bb5fa473fceb7207613d90584fdf856b6a49899f9c2aa31b2b471 SHA512 280b02116786c86fd5f1e472fa9070b3a6d846acd670e36d476b150d4a3e91e5a6d1546b7053b1f35a2e0de553c8517640934af010d371d3cbed248592be502d
DIST upmpdcli-1.4.0.tar.gz 469357 BLAKE2B edd46e86f367ff2f88346cfb4cb249dae4463095553bb220fbd9a4078315044ec7591f58c30a0f20840a9f217230e46bc3b3569989a0ae2c05a44aa140c234c4 SHA512 1ed1f0a89a02610d70fb9e380dcbdbd8d636bc4a0964a16d27bd7c04126674f7f14e50e5fe521a430a06ea04ecef1275c7ad5f1c276daae1c285b73cceba9dec
+DIST upmpdcli-1.4.2.tar.gz 477650 BLAKE2B 8bc2f86e8821aaee29f969e6031553f29e3224fdaf4b9c7d443f55bda5f321f36607dbb7dc0af15f0d1e7b006e93595cd1d668f9d1975e8673a80b218ea7f570 SHA512 be855214b55686422689ce786103ff50748a9f9e7e556c8dbeaa7e39e0229a3e0b56502bdbeb7071771706416cd2ff36592cb5245b505d8438f0ba75c200e9c2
diff --git a/media-sound/upmpdcli/upmpdcli-1.4.2.ebuild b/media-sound/upmpdcli/upmpdcli-1.4.2.ebuild
new file mode 100644
index 000000000000..9d24547be31e
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.4.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd user
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+LICENSE="GPL-2"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd
+ >=net-libs/libupnpp-0.17.0
+"
+RDEPEND="
+ ${DEPEND}
+ thirdparty? ( dev-python/requests )
+"
+
+pkg_setup() {
+ enewuser "${PN}"
+ enewgroup "${PN}"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package no longer assumes that upmpdcli is driving an"
+ einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
+ einfo "Probably it is though, so be sure your mpd is built with"
+ einfo "USE=curl."
+ einfo
+ einfo "Consider installing media-sound/sc2mpd. If upmpdcli"
+ einfo "detects sc2mpd at run-time, capabilities are added"
+ einfo "including internet radio support. See upstream docs"
+ einfo "for more information."
+}