summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2019-05-28 21:59:30 +0200
committerJohannes Huber <johu@gentoo.org>2019-05-28 22:05:47 +0200
commitfd51a6358515998e2573d7c84619d41ff4a39578 (patch)
tree0cf3e46ac528fcf83323f37e67a3854a610e089a
parentx11-misc/polybar: EAPI 7 (diff)
downloadgentoo-fd51a6358515998e2573d7c84619d41ff4a39578.tar.gz
gentoo-fd51a6358515998e2573d7c84619d41ff4a39578.tar.bz2
gentoo-fd51a6358515998e2573d7c84619d41ff4a39578.zip
x11-misc/polybar: Release switch
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Johannes Huber <johu@gentoo.org>
-rw-r--r--x11-misc/polybar/polybar-9999.ebuild33
1 files changed, 29 insertions, 4 deletions
diff --git a/x11-misc/polybar/polybar-9999.ebuild b/x11-misc/polybar/polybar-9999.ebuild
index 1c6fc7d12183..70e8d426aaf5 100644
--- a/x11-misc/polybar/polybar-9999.ebuild
+++ b/x11-misc/polybar/polybar-9999.ebuild
@@ -4,16 +4,26 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils git-r3 python-single-r1
+inherit cmake-utils python-single-r1
DESCRIPTION="A fast and easy-to-use tool for creating status bars"
HOMEPAGE="https://github.com/jaagr/polybar"
-EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
-EGIT_CLONE_TYPE="shallow"
+
+if [[ ${PV} != *9999* ]]; then
+ XPP_VERSION="1.4.0"
+ I3IPCPP_VERSION="0.7.1"
+ SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
+ https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
+ EGIT_CLONE_TYPE="shallow"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="alsa curl i3wm ipc mpd network pulseaudio"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -36,6 +46,20 @@ DEPEND="
RDEPEND="${DEPEND}"
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if [[ ${PV} != *9999* ]]; then
+ rmdir "${S}"/lib/xpp || die
+ mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
+
+ rmdir "${S}"/lib/i3ipcpp || die
+ mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
+
+ sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
+ fi
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_ALSA="$(usex alsa)"
@@ -46,5 +70,6 @@ src_configure() {
-DENABLE_NETWORK="$(usex network)"
-DENABLE_PULSEAUDIO="$(usex pulseaudio)"
)
+
cmake-utils_src_configure
}