summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2022-04-07 22:39:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-04-17 12:49:53 +0300
commitfd6f085dfd91fe5cc314fb56b57d85a1b69c49c1 (patch)
treeb594fab7bc86bad4a71634a94c127593444ee8a9
parentapp-emacs/ruby-mode: Remove old (diff)
downloadgentoo-fd6f085dfd91fe5cc314fb56b57d85a1b69c49c1.tar.gz
gentoo-fd6f085dfd91fe5cc314fb56b57d85a1b69c49c1.tar.bz2
gentoo-fd6f085dfd91fe5cc314fb56b57d85a1b69c49c1.zip
sci-libs/pdal: bump to 2.4.0
Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/24948 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sci-libs/pdal/Manifest1
-rw-r--r--sci-libs/pdal/pdal-2.4.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
index 87d5e450ed54..0819a558369b 100644
--- a/sci-libs/pdal/Manifest
+++ b/sci-libs/pdal/Manifest
@@ -1 +1,2 @@
DIST PDAL-2.3.0-src.tar.gz 110530128 BLAKE2B 435997e7ae7fe84ff77d8546e68ce6d32e54a221b5a4bbea45543554355506d7900f65ebb47a4f5333d0f3a44192ffe548178b6b3e8b3b7575d3c104618e288b SHA512 9de87de7370175e76b95d3ec08667eb28b90a63eed8133f144427ff931e575d1f37aa13496f12054577539ee552458475dd054bcbdedfabe52eb0e32c4483d05
+DIST PDAL-2.4.0-src.tar.gz 113449697 BLAKE2B 8f774555d32ad4f0afe6dd850e6dcaf33b58c02934207ee2224230af762a7d3062a48909e267abf790a97a1d11788bb7543971c99239e5ae742d7945db09bda5 SHA512 655fadd2b435ed1cb801ba542028bcc15156da9266eedde93b2210dbadbc50d36b0b6a151062113f2adfb68a2938e2b867438a5a94952a7b3e46f59a53b47623
diff --git a/sci-libs/pdal/pdal-2.4.0.ebuild b/sci-libs/pdal/pdal-2.4.0.ebuild
new file mode 100644
index 000000000000..3992dc03610f
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/13"
+KEYWORDS="~amd64 ~x86"
+IUSE="postgres test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ net-misc/curl
+ app-arch/zstd:=
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ sci-libs/gdal:=
+ sci-libs/libgeotiff:=
+ sys-libs/libunwind:=
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+DEPEND="
+ test? ( sci-libs/gdal[geos,jpeg,png] )
+ ${RDEPEND}
+"
+
+S="${WORKDIR}/PDAL-${PV}-src"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_COMPLETION=ON
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ --exclude-regex '(pgpointcloudtest|pdal_io_bpf_base_test|pdal_io_bpf_zlib_test|pdal_filters_overlay_test|pdal_filters_stats_test|pdal_app_plugin_test|pdal_merge_test)'
+ --output-on-failure
+ )
+
+ cmake_src_test
+}