summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-06 09:46:54 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-08-06 09:47:28 +0200
commitfd8ca37cb73af8160048d4dd245c65a8c5366c6f (patch)
tree3a04efc403902c1ed9043777ca120990bb23e338
parentros-meta/qt_gui_core: Bump to 0.3.6. (diff)
downloadgentoo-fd8ca37c.tar.gz
gentoo-fd8ca37c.tar.bz2
gentoo-fd8ca37c.zip
sci-electronics/klayout: Version bump, using Ruby 2.2
Package-Manager: Portage-2.3.6, Repoman-2.3.3
-rw-r--r--sci-electronics/klayout/Manifest1
-rw-r--r--sci-electronics/klayout/klayout-0.24.10.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/sci-electronics/klayout/Manifest b/sci-electronics/klayout/Manifest
index fb024c05a71e..789027f3953c 100644
--- a/sci-electronics/klayout/Manifest
+++ b/sci-electronics/klayout/Manifest
@@ -1,2 +1,3 @@
DIST klayout-0.23.10.tar.gz 9561035 SHA256 f215a70ec78ac58c775527c4194c972d6588afd23a8f24f292626fb4f70028a1 SHA512 628a260d1b4f44b7eb02d166e7af47ef6c303019824ef0b9681509e53fda58576654188097e8791bb7acce635e671d016d5199c7b8777377ce6d9256756957c6 WHIRLPOOL 228bd2b76c1feb29e86740ee2efe16fc3380df6ec67cd9caff8c862097c372823f8d1a2b1c07b4b8534673161a9e538a73f78f2de85676eed42fa8ef65f53308
+DIST klayout-0.24.10.tar.gz 11262007 SHA256 b1462ec68add037a5d9d040599b2bd96cc399e57dfd9fd46bbf3e8f54c07418d SHA512 0043b91e2dae9321299c217697c93af27bc7d795209bdf95248eee3690b97728854f9f82cc95f77f05a2cfbcae6a716ae594fe2485e04ed0a3f5d950abc0a31b WHIRLPOOL fe1d4079fbc3aa9fec1da8fb48595fa6edd65060f7081f80592dc86b371c4428934629a5c7838212577416fc66f194e6677f595992734c922c2ee89c6029cbd7
DIST klayout-0.24.9.tar.gz 11262298 SHA256 475420a7858aa9d9a0f7312c0da827f1f350340a30abcaf1589a41d35946dccd SHA512 2b14f9c10968f3c69e0585a6d83756395697ebefb5ab97d37e790e180be2f17073bc488135868be8f61308388dd3b5fac0819765c5e5487bbaae8679a8863574 WHIRLPOOL 48a49d9a13e6950a8fac48965da7fe8c6dce4c239c51e21e9f3774f5a6c0ff995a86a3be0ce967ca2b4f96e780b86639b0af64f4039ec1220bc7bfae6fbb29bf
diff --git a/sci-electronics/klayout/klayout-0.24.10.ebuild b/sci-electronics/klayout/klayout-0.24.10.ebuild
new file mode 100644
index 000000000000..b4e090a89093
--- /dev/null
+++ b/sci-electronics/klayout/klayout-0.24.10.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22"
+# note: define maximally ONE implementation here
+
+RUBY_OPTIONAL=no
+inherit eutils multilib toolchain-funcs ruby-ng
+
+DESCRIPTION="Viewer and editor for GDS and OASIS integrated circuit layouts"
+HOMEPAGE="http://www.klayout.de/"
+SRC_URI="http://www.klayout.org/downloads/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/designer:4
+ dev-qt/qtgui:4[qt3support]
+ sys-libs/zlib
+ $(ruby_implementations_depend)
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.24.9-c++11-no-throw-in-destuctor.patch
+)
+
+all_ruby_prepare() {
+ # now we generate the stub build configuration file for the home-brew build system
+ cp "${FILESDIR}/${PN}-0.23.10-Makefile.conf.linux-gentoo" "${S}/config/Makefile.conf.linux-gentoo" || die
+}
+
+each_ruby_configure() {
+ ./build.sh \
+ -dry-run \
+ -platform linux-gentoo \
+ -bin bin \
+ -ruby ${RUBY} \
+ -qtbin /usr/lib64/qt4/bin \
+ -qtinc /usr/include/qt4 \
+ -qtlib /usr/$(get_libdir)/qt4 || die "Configuration failed"
+}
+
+each_ruby_compile() {
+ cd build.linux-gentoo
+ tc-export CC CXX AR LD RANLIB
+ export AR="${AR} -r"
+ emake all
+}
+
+each_ruby_install() {
+ cd build.linux-gentoo
+ emake install
+
+ cd ..
+ dobin bin/klayout
+
+ insinto /usr/share/${PN}/testdata/gds
+ doins testdata/gds/*.gds
+ insinto /usr/share/${PN}/testdata/oasis
+ doins testdata/oasis/*.oas testdata/oasis/*.ot
+
+ insinto /usr/share/${PN}
+ doins -r testdata/ruby
+}