summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-21 18:58:08 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-21 19:33:11 +0100
commitfdd3f5eb1948b4962f53216630c8dfefa58f4c68 (patch)
tree989a2192242edbfc81eacbeecdf8e2354195d73b
parentapp-admin/ansible-lint: add 6.6.1, drop 6.6.0 (diff)
downloadgentoo-fdd3f5eb1948b4962f53216630c8dfefa58f4c68.tar.gz
gentoo-fdd3f5eb1948b4962f53216630c8dfefa58f4c68.tar.bz2
gentoo-fdd3f5eb1948b4962f53216630c8dfefa58f4c68.zip
app-admin/ansible-lint: drop 6.4.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.4.0.ebuild75
-rw-r--r--app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch23
3 files changed, 0 insertions, 99 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index a2e63a13be00..9021b8b0133c 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,2 @@
-DIST ansible-lint-6.4.0.gh.tar.gz 235346 BLAKE2B a2f55e6f4df739dccb011225f0a660978a9dfdbcc6e45cee2eef12467482c471d8700bb1bfad87e03eb1c4f21291307db5dc174e2440370ca11368f6ad6d195d SHA512 75e30a325a5c62f64066925b99e691886e299e029adc78fdceaa5eb23a74a46408793479e7c54c312d93e0a62d190b34f1e7614dec31a94822d39a231796e9df
DIST ansible-lint-6.5.2.gh.tar.gz 248425 BLAKE2B 02fe3f0cb410831ee7913c5f5ae434678ff183f9c60f0355988d69b516324513fd417439f9ceee4a38192c1e593d7bc00c8fd1aafdff6ba904cdb4ba56257657 SHA512 36a8d7b746bbb0c0f4d85a63180432b9165b1e59ff9da07f6b9477aa02d8998c5c682a317a04c4971a08f0691a10f420d9fd0e7d396d7d1b7f49979c7faf41f5
DIST ansible-lint-6.6.1.gh.tar.gz 272235 BLAKE2B 50d014a919b7e915aff541b7be401f287ac990ec3dc435af2356143434fb27619e2e9ebad4a6b0ed57d9b0c1972137c34d08b603eda7f8dba49359d209da2e0a SHA512 bd6c2b695ba65e808f7773deef11bd51693b0343dc356788a87761810295fad32114bfb6f8df8eef69a13702b136f1c1d02b1a9f41c43c6e64174842ec67124f
diff --git a/app-admin/ansible-lint/ansible-lint-6.4.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.4.0.ebuild
deleted file mode 100644
index bc3e252daa8c..000000000000
--- a/app-admin/ansible-lint/ansible-lint-6.4.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
-HOMEPAGE="https://github.com/ansible/ansible-lint"
-# PyPI tarballs do not contain all the data files needed by the tests
-SRC_URI="https://github.com/ansible/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv"
-
-RDEPEND="
- >=app-admin/ansible-core-2.12.0[${PYTHON_USEDEP}]
- >=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.6[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.8.0[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-python/ruamel-yaml-0.15.37[${PYTHON_USEDEP}]
- >=dev-python/wcmatch-7.0[${PYTHON_USEDEP}]
- >=dev-util/yamllint-1.25.0[${PYTHON_USEDEP}]"
-BDEPEND="
- >=dev-python/setuptools_scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/flaky-3.7.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
-)
-
-# Skip problematic tests:
-# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all the others require Internet access, mostly in order to access Ansible Galaxy
-EPYTEST_DESELECT=(
- test/test_cli_role_paths.py::test_run_playbook_github
- test/test_eco.py
- test/test_examples.py::test_custom_kinds
- test/test_import_playbook.py::test_task_hook_import_playbook
- test/test_list_rules.py::test_list_rules_includes_opt_in_rules
- test/test_list_rules.py::test_list_rules_with_format_option
- test/test_list_rules.py::test_list_tags_includes_opt_in_rules
- test/test_main.py::test_call_from_outside_venv
- test/test_prerun.py::test_install_collection
- test/test_prerun.py::test_prerun_reqs_v1
- test/test_prerun.py::test_prerun_reqs_v2
- test/test_prerun.py::test_require_collection_wrong_version
- test/test_profiles.py::test_profile_listing
- test/test_rules_collection.py::test_rich_rule_listing
- test/test_utils.py::test_cli_auto_detect
- test/test_utils.py::test_template_lookup
- test/test_verbosity.py::test_default_verbosity
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- # As of 6.2.1, without this the test suite still gets confused by the presence of ansible-lint modules
- # in both ${ED} and ${S}.
- cd "${S}" || die
-
- epytest test
-}
diff --git a/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch b/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch
deleted file mode 100644
index 4288bb897c1e..000000000000
--- a/app-admin/ansible-lint/files/ansible-lint-6.0.2_test-module-check.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-Let the package managers handle dependencies, m'kay?
-
---- a/conftest.py
-+++ b/conftest.py
-@@ -3,18 +3,6 @@
- import os
- import sys
-
--# checking if user is running pytest without installing test dependencies:
--missing = []
--for module in ["ansible", "black", "flake8", "flaky", "mypy", "pylint", "pytest_cov"]:
-- if not importlib.util.find_spec(module):
-- missing.append(module)
--if missing:
-- print(
-- f"FATAL: Missing modules: {', '.join(missing)} -- probably you missed installing test requirements with: pip install -e '.[test]'",
-- file=sys.stderr,
-- )
-- sys.exit(1)
--
-
- os.environ["NO_COLOR"] = "1"
- pytest_plugins = ["ansiblelint.testing.fixtures"]