summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2021-03-13 19:18:22 -0500
committerAaron Bauman <bman@gentoo.org>2021-03-13 19:19:08 -0500
commitfe197a5e3a8e68c1eb55ea0ad333a205fc59aade (patch)
tree281a7f285b5cea0377b7abc2e788471225ab45a7
parentgnome-extra/gnome-tweaks: Version bump to 3.34.1 (diff)
downloadgentoo-fe197a5e3a8e68c1eb55ea0ad333a205fc59aade.tar.gz
gentoo-fe197a5e3a8e68c1eb55ea0ad333a205fc59aade.tar.bz2
gentoo-fe197a5e3a8e68c1eb55ea0ad333a205fc59aade.zip
app-editors/neovim: fix build on Darwin
* We don't need no damned automagic here Suggested-by: Sam James <sam@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch61
-rw-r--r--app-editors/neovim/neovim-0.4.4-r100.ebuild1
2 files changed, 62 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
new file mode 100644
index 000000000000..4fa8bf45bcbd
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.4.4-cmake-darwin.patch
@@ -0,0 +1,61 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 07928e3..08881ee 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -58,23 +58,6 @@ endif()
+ # used for check_c_compiler_flag
+ include(CheckCCompilerFlag)
+
+-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+- # CMake tries to treat /sw and /opt/local as extension of the system path, but
+- # that doesn't really work out very well. Once you have a dependency that
+- # resides there and have to add it as an include directory, then any other
+- # dependency that could be satisfied from there must be--otherwise you can end
+- # up with conflicting versions. So, let's make them more of a priority having
+- # them be included as one of the first places to look for dependencies.
+- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
+-
+- # Work around some old, broken detection by CMake for knowing when to use the
+- # isystem flag. Apple's compilers have supported this for quite some time
+- # now.
+- if(CMAKE_COMPILER_IS_GNUCC)
+- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
+- endif()
+-endif()
+-
+ if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ # Enable fixing case-insensitive filenames for Windows and Mac.
+ set(USE_FNAME_CASE TRUE)
+diff --git a/src/nvim/CMakeLists.txt b/src/nvim/CMakeLists.txt
+index aa81008..0570dc7 100644
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -192,10 +192,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
+ foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
+ list(APPEND gen_cflags "-I${gen_include}")
+ endforeach()
+-if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot")
+- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+-endif()
+ string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
+ separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
+ separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
+diff --git a/third-party/CMakeLists.txt b/third-party/CMakeLists.txt
+index edd5882..e503434 100644
+--- a/third-party/CMakeLists.txt
++++ b/third-party/CMakeLists.txt
+@@ -105,13 +105,6 @@ if(CMAKE_CXX_COMPILER)
+ set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
+ endif()
+
+-if(CMAKE_OSX_SYSROOT)
+- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- if(DEPS_CXX_COMPILER)
+- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
+- endif()
+-endif()
+-
+ # Cross compiling: use these for dependencies built for the
+ # HOST system, when not crosscompiling these should be the
+ # same as DEPS_*. Except when targeting Unix in which case \ No newline at end of file
diff --git a/app-editors/neovim/neovim-0.4.4-r100.ebuild b/app-editors/neovim/neovim-0.4.4-r100.ebuild
index 987745e5962e..f501db09c7e3 100644
--- a/app-editors/neovim/neovim-0.4.4-r100.ebuild
+++ b/app-editors/neovim/neovim-0.4.4-r100.ebuild
@@ -63,6 +63,7 @@ RDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-0.4.4-cmake_lua_version.patch"
"${FILESDIR}/${PN}-0.4.4-cmake-release-type.patch"
+ "${FILESDIR}/${PN}-0.4.4-cmake-darwin.patch"
)
src_prepare() {