summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Beddek <telans@posteo.de>2021-10-24 20:15:28 +1300
committerSam James <sam@gentoo.org>2021-10-24 08:21:42 +0000
commitfe3d914b623aa403e90098a23968b394b2f0e6c3 (patch)
tree79a1cf4af854e97acd6331b96dcd647134cae462
parentmedia-video/handbrake: rebase remove-faac patch (diff)
downloadgentoo-fe3d914b623aa403e90098a23968b394b2f0e6c3.tar.gz
gentoo-fe3d914b623aa403e90098a23968b394b2f0e6c3.tar.bz2
gentoo-fe3d914b623aa403e90098a23968b394b2f0e6c3.zip
media-video/handbrake: add 1.4.2
Closes: https://bugs.gentoo.org/806392 Closes: https://bugs.gentoo.org/738110 Closes: https://bugs.gentoo.org/804891 Signed-off-by: James Beddek <telans@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-video/handbrake/files/handbrake-9999-system-tools.patch24
-rw-r--r--media-video/handbrake/handbrake-1.4.2.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/media-video/handbrake/files/handbrake-9999-system-tools.patch b/media-video/handbrake/files/handbrake-9999-system-tools.patch
new file mode 100644
index 000000000000..9d76e628ccbb
--- /dev/null
+++ b/media-video/handbrake/files/handbrake-9999-system-tools.patch
@@ -0,0 +1,24 @@
+# https://bugs.gentoo.org/738110
+
+diff --git a/make/configure.py b/make/configure.py
+index 87118fcbe..df869856d 100644
+--- a/make/configure.py
++++ b/make/configure.py
+@@ -1626,14 +1626,14 @@ try:
+
+ ## create tools in a scope
+ class Tools:
+- ar = ToolProbe( 'AR.exe', 'ar', 'ar', abort=True )
++ ar = ToolProbe( 'AR.exe', 'ar', os.environ.get('AR', 'ar'), abort=True )
+ cp = ToolProbe( 'CP.exe', 'cp', 'cp', abort=True )
+ m4 = ToolProbe( 'M4.exe', 'm4', 'gm4', 'm4', abort=True )
+ mkdir = ToolProbe( 'MKDIR.exe', 'mkdir', 'mkdir', abort=True )
+ patch = ToolProbe( 'PATCH.exe', 'patch', 'gpatch', 'patch', abort=True )
+ rm = ToolProbe( 'RM.exe', 'rm', 'rm', abort=True )
+- ranlib = ToolProbe( 'RANLIB.exe', 'ranlib', 'ranlib', abort=True )
+- strip = ToolProbe( 'STRIP.exe', 'strip', 'strip', abort=True )
++ ranlib = ToolProbe( 'RANLIB.exe', 'ranlib', os.environ.get('RANLIB', 'ranlib'), abort=True )
++ strip = ToolProbe( 'STRIP.exe', 'strip', os.environ.get('STRIP', 'strip'), abort=True )
+ tar = ToolProbe( 'TAR.exe', 'tar', 'gtar', 'tar', abort=True )
+ python = ToolProbe( 'PYTHON.exe', 'python', os.path.basename(sys.executable), abort=True )
+
diff --git a/media-video/handbrake/handbrake-1.4.2.ebuild b/media-video/handbrake/handbrake-1.4.2.ebuild
index 80d947f27773..2978319d46f4 100644
--- a/media-video/handbrake/handbrake-1.4.2.ebuild
+++ b/media-video/handbrake/handbrake-1.4.2.ebuild
@@ -44,6 +44,7 @@ RDEPEND="
nvenc? ( media-libs/nv-codec-headers )
media-libs/opus
media-libs/x264:=
+ media-libs/zimg
media-sound/lame
sys-libs/zlib
>=media-video/ffmpeg-4.2.1:0=[postproc,fdk?]
@@ -86,6 +87,9 @@ PATCHES=(
# Remove faac dependency; TODO: figure out if we need to do this at all.
"${FILESDIR}/${PN}-9999-remove-faac-dependency.patch"
+ # Detect system tools - bug 738110
+ "${FILESDIR}/${PN}-9999-system-tools.patch"
+
# Use whichever python is set by portage
"${FILESDIR}/${PN}-1.3.0-dont-search-for-python.patch"