summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-19 22:41:22 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-21 12:51:03 -0700
commitfe9c9d98029f7cc7f7a4bb6c587a957f223449fe (patch)
tree3198bc05fe16eb1ad048745c42e17e6964e0fd56
parentapp-accessibility/at-spi2-core: Version bump to 2.34.0 (diff)
downloadgentoo-fe9c9d98029f7cc7f7a4bb6c587a957f223449fe.tar.gz
gentoo-fe9c9d98029f7cc7f7a4bb6c587a957f223449fe.tar.bz2
gentoo-fe9c9d98029f7cc7f7a4bb6c587a957f223449fe.zip
app-accessibility/at-spi2-atk: Version bump to 2.34.0
atk and at-spi2-core required versions have been raised to 2.33.3 and 2.33.2 respectively. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-accessibility/at-spi2-atk/Manifest1
-rw-r--r--app-accessibility/at-spi2-atk/at-spi2-atk-2.34.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-atk/Manifest b/app-accessibility/at-spi2-atk/Manifest
index 3c805bafc170..66ab578f4d3f 100644
--- a/app-accessibility/at-spi2-atk/Manifest
+++ b/app-accessibility/at-spi2-atk/Manifest
@@ -1,3 +1,4 @@
DIST at-spi2-atk-2.26.2.tar.xz 322800 BLAKE2B 108a01fd8c16816d9953ad42721080dd6dcb9f75c95c412387d7f54920998c66eb5855eb859e8e00096a47b387d05779691887a7717d31f4c70681d69a9c8266 SHA512 f938b8e2b999fcdfa13e9433bd13c39430bae2ceae0c664a24caccc6af522947bf73de02de3c359807f5370a85961193df2ba24b193b60b915c61828ea747bb2
DIST at-spi2-atk-2.30.1.tar.xz 94812 BLAKE2B fe3ef77e749bef2300219fe32586ac0b871d06dce708ce8b7b57356a1fa17041c3f7b788e3e6d6b5f89dc97c3e8d43a9d1eb897ed8fbaac954f042421aef68b6 SHA512 862cccb65d2a8a7df4e899e4f53742535389a0efa0a75c936b52e68690c07e206b19d8308f0910cddb71bda0d803012d613f6959329ae43c411d1314062b7018
DIST at-spi2-atk-2.32.0.tar.xz 94952 BLAKE2B 972bb32590a51549eb8b0b3c46a068e95cc43783f0f0e31ca3663ff1669196a88def63342c01d056d45d6f4fb4bcc2127b50a49be37fd45d33aa1daeadca5172 SHA512 095ceaa33d5b35f1f4f81a31bea00487c054493cb29d4fdbcf74331ec8d1b9570dc7cb93e1cc06da9ea3f5805e7a3a9e7bf80cfdbce86a1822c2a46327109393
+DIST at-spi2-atk-2.34.0.tar.xz 96116 BLAKE2B 242b29b988d97b06ca85495be77f9c4cf1c621d9ff977cd73ea37f97b42fc636474df34429e7397fb3f91d3d11b14ce1b3de5d68c0b30f85877f444c78389564 SHA512 515ad4d0a000fa47a7848f3ea9f95f8e0c582f9d9876725deb8e521c60e290f73655445456e6c238f382cb8773b56db2795c221029ec931bad68395326b6bb04
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.34.0.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.34.0.ebuild
new file mode 100644
index 000000000000..25c5bab4a1d7
--- /dev/null
+++ b/app-accessibility/at-spi2-atk/at-spi2-atk-2.34.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal virtualx xdg
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+ >=dev-libs/atk-2.33.3[${MULTILIB_USEDEP}]
+ >=app-accessibility/at-spi2-core-2.33.2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+multilib_src_install() {
+ meson_src_install
+}