summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 20:23:20 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 20:32:37 +0200
commitfeb6cfa246e3a138f2a3b662b2aba4315281cd95 (patch)
tree933a6cbcaf154d14847584b2434e010d0e18ce76
parentnet-analyzer/zabbix: Bump to 2.2.13 for #574858 (diff)
downloadgentoo-feb6cfa246e3a138f2a3b662b2aba4315281cd95.tar.gz
gentoo-feb6cfa246e3a138f2a3b662b2aba4315281cd95.tar.bz2
gentoo-feb6cfa246e3a138f2a3b662b2aba4315281cd95.zip
net-analyzer/zabbix: Bump 2.4
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-analyzer/zabbix/Manifest1
-rw-r--r--net-analyzer/zabbix/zabbix-2.4.8.ebuild342
2 files changed, 343 insertions, 0 deletions
diff --git a/net-analyzer/zabbix/Manifest b/net-analyzer/zabbix/Manifest
index 279622747218..3af962d05520 100644
--- a/net-analyzer/zabbix/Manifest
+++ b/net-analyzer/zabbix/Manifest
@@ -4,3 +4,4 @@ DIST zabbix-2.2.5.tar.gz 14960556 SHA256 1e33f54d4accc5b6a0dccf4a308d27dc82de245
DIST zabbix-2.2.9.tar.gz 15032149 SHA256 7c8c319b34beb978e4b7be8c93e084485f93fe028dd9dbc6b674a7498d324439 SHA512 8400f875546140a7393ac6598a02e95645ac63ece1d958e7752737d0c0fff25e70923f2dd1ea29a9e73640b159da8a5286d9b1c31fbb3f090acbd07606c6113d WHIRLPOOL cb68a2c1467c83e8c2e2662af3995d7d90a00408009df2d9fe0b0d0d81191521b3f6e1624240150f68419252324e0d6e5653a3f19ed3b88adeb2719277172fb6
DIST zabbix-2.4.5.tar.gz 14851092 SHA256 4e2cf1e4893a45d83379a05e2debabddf16beab324c93e84adc0bb57716fb957 SHA512 bdcba684b3d1cdb9eb5e1f9b370ef450201de8dbd9fe1619ef2b2437de6c34762dc041fa873976c4af0a2af229eec450aa58b1663feb75b6345d303484d35ead WHIRLPOOL 775e98b85152268b19cde553ff8bc7e86c0f6c5b873e85a0faca3edb5b51fe7d02267e52b3dccb0f08847bf11c6d0ba6b2d9f1e6bd472c882a2fac4326a83e10
DIST zabbix-2.4.7.tar.gz 15012768 SHA256 d2c47b8f5b9b91f18010d54c45de55845d979014a8b3fe4bef64e0b08f8b00da SHA512 81860dfab38241e939a5cced50527fd16d35ec7b82232b2e0a4f17c90c1fc8ffb9bb95891ec27bb87445e5f81fba066dccc6b1a8833a4af4f483532f83d6172a WHIRLPOOL 03525fa3113f258af7fbd9cf3f501846b466afa48dca2874f2e28562f63cf5824df51c89349f0c10830bb7b5650f70a32443ba9af2d826d99d02cf7bb2a01e21
+DIST zabbix-2.4.8.tar.gz 15474481 SHA256 073f7498ff7c07e51f3395dbd850b375144d6a41388409d898bb2826b0a3e1f0 SHA512 bf0816279f771448076bd8d8f1efe65651e24964b402ba128aace3d5afc0333f808a9d48b5763e334a05bc9f53fa934d81cc1b90072a0e9ba74b29205ab2b300 WHIRLPOOL 3e9da427680c3686820f3fb59bcac11614dea77ab577fd34fa339283b886306e94e4a3b73d5c966a8610e8d24992158b5f0ee3e3c2428152c1b7b92eb529d729
diff --git a/net-analyzer/zabbix/zabbix-2.4.8.ebuild b/net-analyzer/zabbix/zabbix-2.4.8.ebuild
new file mode 100644
index 000000000000..85599b2dc40f
--- /dev/null
+++ b/net-analyzer/zabbix/zabbix-2.4.8.ebuild
@@ -0,0 +1,342 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+# needed to make webapp-config dep optional
+WEBAPP_OPTIONAL="yes"
+inherit flag-o-matic webapp java-pkg-opt-2 user systemd toolchain-funcs
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
+HOMEPAGE="http://www.zabbix.com/"
+MY_P=${P/_/}
+MY_PV=${PV/_/}
+SRC_URI="http://prdownloads.sourceforge.net/zabbix/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="~amd64 ~x86"
+IUSE="+agent java curl frontend ipv6 xmpp ldap libxml2 mysql openipmi oracle postgres proxy server ssh snmp sqlite odbc static"
+REQUIRED_USE="|| ( agent frontend proxy server )
+ proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+ server? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+ static? ( !oracle !snmp )"
+
+COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
+ ldap? (
+ net-nds/openldap
+ =dev-libs/cyrus-sasl-2*
+ net-libs/gnutls
+ )
+ mysql? ( >=virtual/mysql-5.0.3 )
+ sqlite? ( >=dev-db/sqlite-3.3.5 )
+ postgres? ( dev-db/postgresql:* )
+ oracle? ( >=dev-db/oracle-instantclient-basic-10.0.0.0 )
+ xmpp? ( dev-libs/iksemel )
+ libxml2? ( dev-libs/libxml2 )
+ curl? ( net-misc/curl )
+ openipmi? ( sys-libs/openipmi )
+ ssh? ( net-libs/libssh2 )
+ java? ( virtual/jdk:* )
+ odbc? ( dev-db/unixODBC )"
+
+RDEPEND="${COMMON_DEPEND}
+ proxy? ( net-analyzer/fping )
+ server? ( net-analyzer/fping
+ app-admin/webapp-config )
+ java? (
+ >=virtual/jre-1.4
+ dev-java/slf4j-api
+ )
+ frontend? (
+ >=dev-lang/php-5.3.0[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
+ || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )
+ mysql? ( dev-lang/php[mysqli] )
+ odbc? ( dev-lang/php[odbc] )
+ oracle? ( dev-lang/php[oci8-instant-client] )
+ postgres? ( dev-lang/php[postgres] )
+ sqlite? ( dev-lang/php[sqlite] )
+ media-libs/gd[png]
+ app-admin/webapp-config )"
+DEPEND="${COMMON_DEPEND}
+ static? (
+ ldap? (
+ net-nds/openldap[static-libs]
+ =dev-libs/cyrus-sasl-2*[static-libs]
+ net-libs/gnutls[static-libs]
+ )
+ mysql? ( >=virtual/mysql-5.0.3[static-libs] )
+ sqlite? ( >=dev-db/sqlite-3.3.5[static-libs] )
+ postgres? ( dev-db/postgresql:*[static-libs] )
+ libxml2? ( dev-libs/libxml2[static-libs] )
+ curl? ( net-misc/curl[static-libs] )
+ ssh? ( net-libs/libssh2[static-libs] )
+ odbc? ( dev-db/unixODBC[static-libs] )
+ )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+ZABBIXJAVA_BASE="opt/zabbix_java"
+
+pkg_setup() {
+ if use oracle; then
+ if [ -z "${ORACLE_HOME}" ]; then
+ eerror
+ eerror "The environment variable ORACLE_HOME must be set"
+ eerror "and point to the correct location."
+ eerror "It looks like you don't have Oracle installed."
+ eerror
+ die "Environment variable ORACLE_HOME is not set"
+ fi
+ if has_version 'dev-db/oracle-instantclient-basic'; then
+ ewarn
+ ewarn "Please ensure you have a full install of the Oracle client."
+ ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+ ewarn
+ fi
+ fi
+
+ if use frontend; then
+ webapp_pkg_setup
+ fi
+
+ enewgroup zabbix
+ enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+java_prepare() {
+ cd "${S}/src/zabbix_java/lib"
+ rm -v *.jar || die
+
+ java-pkg_jar-from slf4j-api
+}
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable server) \
+ $(use_enable proxy) \
+ $(use_enable agent) \
+ $(use_enable ipv6) \
+ $(use_enable static) \
+ $(use_enable java) \
+ $(use_with ldap) \
+ $(use_with snmp net-snmp) \
+ $(use_with mysql) \
+ $(use_with postgres postgresql) \
+ $(use_with oracle) \
+ $(use_with sqlite sqlite3) \
+ $(use_with xmpp jabber) \
+ $(use_with curl libcurl) \
+ $(use_with openipmi openipmi) \
+ $(use_with ssh ssh2) \
+ $(use_with libxml2) \
+ $(use_with odbc unixodbc) \
+ || die "econf failed"
+}
+
+src_compile() {
+ if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ fi
+}
+
+src_install() {
+ dodir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/lib/zabbix/alertscripts \
+ /var/lib/zabbix/externalscripts \
+ /var/log/zabbix
+
+ keepdir \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/lib/zabbix/alertscripts \
+ /var/lib/zabbix/externalscripts \
+ /var/log/zabbix
+
+ if use server; then
+ insinto /etc/zabbix
+ doins "${FILESDIR}/2.4"/zabbix_server.conf
+ doinitd "${FILESDIR}/2.4"/init.d/zabbix-server
+ dosbin src/zabbix_server/zabbix_server
+ fowners zabbix:zabbix /etc/zabbix/zabbix_server.conf
+ fperms 0640 /etc/zabbix/zabbix_server.conf
+ dodir /usr/share/zabbix
+ /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+ systemd_dounit "${FILESDIR}/zabbix-server.service"
+ systemd_newtmpfilesd "${FILESDIR}/zabbix-server.tmpfiles" zabbix-server.conf
+ fi
+
+ if use proxy; then
+ doinitd \
+ "${FILESDIR}/2.4"/init.d/zabbix-proxy
+ dosbin \
+ src/zabbix_proxy/zabbix_proxy
+ insinto /etc/zabbix
+ doins \
+ "${FILESDIR}/2.4"/zabbix_proxy.conf
+ dodir /usr/share/zabbix
+ /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+ systemd_dounit "${FILESDIR}/zabbix-proxy.service"
+ systemd_newtmpfilesd "${FILESDIR}/zabbix-proxy.tmpfiles" zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ insinto /etc/zabbix
+ doins \
+ "${FILESDIR}/2.4"/zabbix_agent.conf \
+ "${FILESDIR}/2.4"/zabbix_agentd.conf
+ doinitd "${FILESDIR}/2.4"/init.d/zabbix-agentd
+ dosbin \
+ src/zabbix_agent/zabbix_agent \
+ src/zabbix_agent/zabbix_agentd
+ dobin \
+ src/zabbix_sender/zabbix_sender \
+ src/zabbix_get/zabbix_get
+ fowners zabbix:zabbix \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ fperms 0640 \
+ /etc/zabbix/zabbix_agent.conf \
+ /etc/zabbix/zabbix_agentd.conf
+ systemd_dounit "${FILESDIR}/zabbix-agentd.service"
+ systemd_newtmpfilesd "${FILESDIR}/zabbix-agentd.tmpfiles" zabbix-agentd.conf
+ fi
+
+ fowners zabbix:zabbix \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/lib/zabbix/alertscripts \
+ /var/lib/zabbix/externalscripts \
+ /var/log/zabbix
+ fperms 0750 \
+ /etc/zabbix \
+ /var/lib/zabbix \
+ /var/lib/zabbix/home \
+ /var/lib/zabbix/scripts \
+ /var/lib/zabbix/alertscripts \
+ /var/lib/zabbix/externalscripts \
+ /var/log/zabbix
+
+ dodoc README INSTALL NEWS ChangeLog \
+ conf/zabbix_agent.conf \
+ conf/zabbix_agentd.conf \
+ conf/zabbix_proxy.conf \
+ conf/zabbix_agentd/userparameter_examples.conf \
+ conf/zabbix_agentd/userparameter_mysql.conf \
+ conf/zabbix_server.conf
+
+ if use frontend; then
+ webapp_src_preinst
+ cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+ webapp_configfile \
+ "${MY_HTDOCSDIR}"/include/db.inc.php \
+ "${MY_HTDOCSDIR}"/include/config.inc.php
+ webapp_src_install
+ fi
+
+ if use java; then
+ dodir \
+ /${ZABBIXJAVA_BASE} \
+ /${ZABBIXJAVA_BASE}/bin \
+ /${ZABBIXJAVA_BASE}/lib
+ keepdir /${ZABBIXJAVA_BASE}
+ exeinto /${ZABBIXJAVA_BASE}/bin
+ doexe src/zabbix_java/bin/zabbix-java-gateway-${MY_PV}.jar
+ exeinto /${ZABBIXJAVA_BASE}/lib
+ doexe \
+ src/zabbix_java/lib/logback-classic-0.9.27.jar \
+ src/zabbix_java/lib/logback-console.xml \
+ src/zabbix_java/lib/logback-core-0.9.27.jar \
+ src/zabbix_java/lib/logback.xml \
+ src/zabbix_java/lib/android-json-4.3_r3.1.jar \
+ src/zabbix_java/lib/slf4j-api-1.6.1.jar
+ exeinto /${ZABBIXJAVA_BASE}/
+ doexe \
+ src/zabbix_java/settings.sh \
+ src/zabbix_java/startup.sh \
+ src/zabbix_java/shutdown.sh
+ fowners -R zabbix:zabbix /${ZABBIXJAVA_BASE}
+ fi
+}
+
+pkg_postinst() {
+ if use server || use proxy ; then
+ elog
+ elog "You may need to configure your database for Zabbix,"
+ elog "if you have not already done so. "
+ elog
+
+ zabbix_homedir=$(egethome zabbix)
+ if [ -n "${zabbix_homedir}" ] && \
+ [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+ ewarn
+ ewarn "The user 'zabbix' should have his homedir changed"
+ ewarn "to /var/lib/zabbix/home if you want to use"
+ ewarn "custom alert scripts."
+ ewarn
+ ewarn "A real homedir might be needed for configfiles"
+ ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+ ewarn "using sendxmpp for Jabber alerts)."
+ ewarn
+ ewarn "To change the homedir use:"
+ ewarn " usermod -d /var/lib/zabbix/home zabbix"
+ ewarn
+ fi
+ fi
+
+ if use server; then
+ elog
+ elog "For distributed monitoring you have to run:"
+ elog
+ elog "zabbix_server -n <nodeid>"
+ elog
+ elog "This will convert database data for use with Node ID"
+ elog "and also adds a local node."
+ elog
+ fi
+
+ elog "--"
+ elog
+ elog "You may need to add these lines to /etc/services:"
+ elog
+ elog "zabbix-agent 10050/tcp Zabbix Agent"
+ elog "zabbix-agent 10050/udp Zabbix Agent"
+ elog "zabbix-trapper 10051/tcp Zabbix Trapper"
+ elog "zabbix-trapper 10051/udp Zabbix Trapper"
+ elog
+
+ if use server || use proxy ; then
+ # check for fping
+ fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+ case "${fping_perms}" in
+ 4[157][157][157])
+ ;;
+ *)
+ ewarn
+ ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+ ewarn "you have to make /usr/sbin/fping setuid root and executable"
+ ewarn "by everyone. Run the following command to fix it:"
+ ewarn
+ ewarn " chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+ ewarn
+ ewarn "Please be aware that this might impose a security risk,"
+ ewarn "depending on the code quality of fping."
+ ewarn
+ ;;
+ esac
+ fi
+}