summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2022-09-05 00:11:25 +0200
committerPatrice Clement <monsieurp@gentoo.org>2022-09-05 00:12:23 +0200
commitff271ae26f4bb5d5c3bc311212744938114bb8c5 (patch)
treeb09b3ac7cbe440e778f4ca30a8d4c3f8d4f7a407
parentdev-util/meson: add 0.63.2 (diff)
downloadgentoo-ff271ae26f4bb5d5c3bc311212744938114bb8c5.tar.gz
gentoo-ff271ae26f4bb5d5c3bc311212744938114bb8c5.tar.bz2
gentoo-ff271ae26f4bb5d5c3bc311212744938114bb8c5.zip
www-apps/zeppelin-bin: add 0.10.1
Bug: https://bugs.gentoo.org/811447 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--www-apps/zeppelin-bin/Manifest1
-rw-r--r--www-apps/zeppelin-bin/zeppelin-bin-0.10.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/www-apps/zeppelin-bin/Manifest b/www-apps/zeppelin-bin/Manifest
index e0f92eeabd86..5dfdef10c350 100644
--- a/www-apps/zeppelin-bin/Manifest
+++ b/www-apps/zeppelin-bin/Manifest
@@ -1 +1,2 @@
+DIST zeppelin-bin-0.10.1.tgz 1680577910 BLAKE2B db33bd78f760211629a9ceb99b80d660a8d9d4da73ff2b187fdcab73c7f59052f952ac2bba2b85619c425b4da8f74a3b38229de034523bb8366d00cfcbf56549 SHA512 94cc52d3121afecfd12e1061bb6f4e7e227629236e4374d2fad1e49403a52b31afc3ff888834216e5f3bd9b95324ac6e586da4131712b84aefac0a01839404aa
DIST zeppelin-bin-0.8.2.tgz 998508624 BLAKE2B cccfa95426d8d0407d7a226f5d71c15ca55da8893a7fff9e3a612c63034ab1838f8f7d5a529bb393b825c6c3bd19e197f4e913c2c5b8dd04fb282affc43788ab SHA512 91a785153bc47b087f90fac0f83066fdede041d5193506b231af1b6855b150307873c92cea462c6dd48ef6d38caa37934591a08542199ac4b02d9493298fbd43
diff --git a/www-apps/zeppelin-bin/zeppelin-bin-0.10.1.ebuild b/www-apps/zeppelin-bin/zeppelin-bin-0.10.1.ebuild
new file mode 100644
index 000000000000..f6142e3c74e3
--- /dev/null
+++ b/www-apps/zeppelin-bin/zeppelin-bin-0.10.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2
+
+MY_PN="zeppelin"
+MY_P="${MY_PN}-${PV}-bin-all"
+
+DESCRIPTION="Web-based interactive data analytics notebook launcher"
+HOMEPAGE="https://zeppelin.apache.org"
+SRC_URI="mirror://apache/zeppelin/${MY_PN}-${PV}/${MY_P}.tgz -> ${P}.tgz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ acct-group/zeppelin
+ acct-user/zeppelin
+ >=virtual/jdk-1.8"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+S="${WORKDIR}/${MY_P}"
+
+INSTALL_DIR="/opt/${P}"
+
+src_prepare() {
+ default
+ local SO_TO_DELETE=(
+ interpreter/sh/libpty/freebsd/x86/libpty.so
+ interpreter/sh/libpty/freebsd/x86_64/libpty.so
+ interpreter/sh/libpty/linux/ppc64le/libpty.so
+ )
+
+ for s in "${SO_TO_DELETE[@]}"; do
+ rm -v ${s} || die
+ done
+}
+
+src_install() {
+ keepdir /var/log/zeppelin
+ fowners -R zeppelin:zeppelin /var/log/zeppelin
+
+ newinitd "${FILESDIR}/zeppelin.init.d" zeppelin
+
+ dodir "${INSTALL_DIR}"
+ cp -pRP * "${ED}/${INSTALL_DIR}" || die
+ dosym "${P}" /opt/zeppelin
+ fowners -R zeppelin:zeppelin "${INSTALL_DIR}"
+}