summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 17:56:58 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 17:57:29 +0100
commitffbc9b4d0f08a5e46e071542e2034a0961efd94c (patch)
tree709065b955772c8606d5a5dc4f8009950354e9f1
parentx11-libs/gdk-pixbuf-2.36.11-r0: alpha stable (diff)
downloadgentoo-ffbc9b4d0f08a5e46e071542e2034a0961efd94c.tar.gz
gentoo-ffbc9b4d0f08a5e46e071542e2034a0961efd94c.tar.bz2
gentoo-ffbc9b4d0f08a5e46e071542e2034a0961efd94c.zip
sys-libs/glibc: On second thought, let's not use linux-info.eclass here.
It introduces too much magic and makes too many assumptions. Still, we now do not use any deprecated portage features anymore. Bug: https://bugs.gentoo.org/587320 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index f2132994237e..a215358c1b2c 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=6
inherit prefix eutils versionator toolchain-funcs flag-o-matic gnuconfig \
- multilib systemd multiprocessing linux-info
+ multilib systemd multiprocessing
DESCRIPTION="GNU libc C library"
HOMEPAGE="https://www.gnu.org/software/libc/"
@@ -509,8 +509,15 @@ check_devpts() {
fi
}
-# The following functions are copied from portage source and split a Kernel
-# version into its components.
+# The following Kernel version handling functions are mostly copied from portage
+# source. It's better not to use linux-info.eclass here since a) it adds too
+# much magic, see bug 326693 for some of the arguments, and b) some of the
+# functions are just not provided.
+
+g_get_running_KV() {
+ uname -r
+ return $?
+}
g_KV_major() {
[[ -z $1 ]] && return 1
@@ -573,10 +580,7 @@ check_nptl_support() {
local run_kv build_kv want_kv
- # We get the running kernel version using linux-info.eclass
- get_running_version
- run_kv=${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}
-
+ run_kv=$(g_get_running_KV)
build_kv=$(g_int_to_KV $(get_kheader_version))
want_kv=${MIN_KERN_VER}