summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-07-09 12:58:57 -0400
committerMike Gilbert <floppym@gentoo.org>2023-07-09 13:38:23 -0400
commit124ad96264f65068e5d1a4865d40562b0569266b (patch)
tree9596584690b07822bc8f731dcbaeaf41d85d91a5 /acct-user/strelaysrv/strelaysrv-1-r1.ebuild
parentdev-python/time-machine: Stabilize 2.10.0 x86, #910155 (diff)
downloadgentoo-124ad96264f65068e5d1a4865d40562b0569266b.tar.gz
gentoo-124ad96264f65068e5d1a4865d40562b0569266b.tar.bz2
gentoo-124ad96264f65068e5d1a4865d40562b0569266b.zip
Revbump all acct-group and acct-user packages
user-info.eclass was modified to fix a bug in egetent. Revbump everything to ensure that binpkgs get regenerated. Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'acct-user/strelaysrv/strelaysrv-1-r1.ebuild')
-rw-r--r--acct-user/strelaysrv/strelaysrv-1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/acct-user/strelaysrv/strelaysrv-1-r1.ebuild b/acct-user/strelaysrv/strelaysrv-1-r1.ebuild
new file mode 100644
index 000000000000..57f5a650afb1
--- /dev/null
+++ b/acct-user/strelaysrv/strelaysrv-1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="User for the Syncthing relay server"
+ACCT_USER_ID=496
+ACCT_USER_HOME=/var/lib/syncthing-relaysrv
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( syncthing )
+
+acct-user_add_deps
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local rver
+ for rver in ${REPLACING_VERSIONS} ; do
+ if ver_test "${rver}" -lt 1; then
+ ewarn "The home directory of this user has changed to /var/lib/syncthing-relaysrv"
+ ewarn "If you have any files in /var/lib/${PN}, move them to the new location by hand"
+ break
+ fi
+ done
+ fi
+}