summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/accerciser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/accerciser')
-rw-r--r--app-accessibility/accerciser/Manifest2
-rw-r--r--app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild67
-rw-r--r--app-accessibility/accerciser/accerciser-3.12.0.ebuild67
-rw-r--r--app-accessibility/accerciser/accerciser-3.14.0.ebuild67
-rw-r--r--app-accessibility/accerciser/metadata.xml10
5 files changed, 213 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
new file mode 100644
index 000000000000..eb85a827ecc2
--- /dev/null
+++ b/app-accessibility/accerciser/Manifest
@@ -0,0 +1,2 @@
+DIST accerciser-3.12.0.tar.xz 3212432 SHA256 0d421a59cd294966441fb6591d34f28e4b60340815bdf91c9e8f39c2d826e96b SHA512 d15d301f7579a92e3b3aa65d22fd726d71bee8330b450c7ed232d4a8d7fc312402573073f67a490ab659122ad98651f8a073235770caa9eba8a4b6dc9d68e6d3 WHIRLPOOL 4b753de73afc1c8fda7d71a8b6f8007ebb4627985a6049be887d8e916f4e37c3a5484a481d8e516a1d4cc245e987ed29a2a87c2780b882bced032f5d2d14d5d6
+DIST accerciser-3.14.0.tar.xz 3213916 SHA256 f5a5915d475e9241396414ccd167724c88807e77e69151cf0b40b32bd57d0574 SHA512 bafc30e15fe0121f8abc64239e48834ab06a03fe64fc368a221d167a13079721962441e0343f17934dde57cd012c9132374739297c23c79c567fc36cc60fb07d WHIRLPOOL 4b9679145ad1ad7f8d059dfdfb12d372c1b27780532a7c19cc25b66bbe0a13db5b864548e332b74e0327eebb488622ae471514046737b738c15624969d8df7a8
diff --git a/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild b/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild
new file mode 100644
index 000000000000..9d96f0ff36ab
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/accerciser-3.12.0.ebuild b/app-accessibility/accerciser/accerciser-3.12.0.ebuild
new file mode 100644
index 000000000000..1f3e53c44fb9
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.12.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python3_3 )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="http://live.gnome.org/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/accerciser-3.14.0.ebuild b/app-accessibility/accerciser/accerciser-3.14.0.ebuild
new file mode 100644
index 000000000000..3bbf84471ae2
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.14.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python{3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/metadata.xml b/app-accessibility/accerciser/metadata.xml
new file mode 100644
index 000000000000..de03c27559db
--- /dev/null
+++ b/app-accessibility/accerciser/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome-accessibility</herd>
+ <longdescription lang="en">
+Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.
+
+In essence, Accerciser is a next generation at-poke tool.
+</longdescription>
+</pkgmetadata>