summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/eflite
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/eflite')
-rw-r--r--app-accessibility/eflite/Manifest1
-rw-r--r--app-accessibility/eflite/eflite-0.4.1-r2.ebuild46
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
-rw-r--r--app-accessibility/eflite/files/eflite.rc29
-rw-r--r--app-accessibility/eflite/files/es.conf11
-rw-r--r--app-accessibility/eflite/metadata.xml27
6 files changed, 138 insertions, 0 deletions
diff --git a/app-accessibility/eflite/Manifest b/app-accessibility/eflite/Manifest
new file mode 100644
index 000000000000..9c1520f96243
--- /dev/null
+++ b/app-accessibility/eflite/Manifest
@@ -0,0 +1 @@
+DIST eflite-0.4.1.tar.gz 63192 SHA256 91ad85855e55a3fc3b97a1a525db5fd1d211d54342bbfc88d1026813104f1721 SHA512 0060980fd5bb65ad94f1609f6d87cb89b91e680228b603fa590e6ba70b51e894493dda4271dca4d8c97f38cdefbd456c3be0447e5f88a0be7ae39324baa2c796 WHIRLPOOL 50e5e31bd0e8759fdfae1b5183c3fc4b9d1d03d2aa04dd7102651e2aaebafc9b312b1e20082c20bdcb745b7c7fad47bd64f145e392551e6c1d31fa01af5b7969
diff --git a/app-accessibility/eflite/eflite-0.4.1-r2.ebuild b/app-accessibility/eflite/eflite-0.4.1-r2.ebuild
new file mode 100644
index 000000000000..621a9ba03388
--- /dev/null
+++ b/app-accessibility/eflite/eflite-0.4.1-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools eutils user
+
+DESCRIPTION="A speech server that allows emacspeak and other screen readers to interact with festival lite"
+HOMEPAGE="http://eflite.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+IUSE="+16k_voice"
+
+DEPEND=">=app-accessibility/flite-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i 's:/etc/es.conf:/etc/eflite/es.conf:g' *
+ epatch "${FILESDIR}"/${PN}-0.4.1-flite14.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ if use 16k_voice; then
+ myconf='--with-vox=cmu_us_kal16'
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ einstall
+ dodoc ChangeLog README INSTALL eflite_test.txt
+
+ insinto /etc/eflite
+ doins "${FILESDIR}"/es.conf
+
+ newinitd "${FILESDIR}"/eflite.rc eflite
+}
+
+pkg_postinst() {
+ enewgroup speech
+}
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 000000000000..cb3096d88a43
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,24 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
+diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
+--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
++++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
+@@ -523,7 +523,7 @@
+ int playlen, skip;
+ if (type == SPEECH)
+ {
+- skip = (187 * wptr->sample_rate) / speed;
++ skip = 0;
+ playlen = wptr->num_samples - (skip * 2);
+ if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
+ }
diff --git a/app-accessibility/eflite/files/eflite.rc b/app-accessibility/eflite/files/eflite.rc
new file mode 100644
index 000000000000..ff91540460cc
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite.rc
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use alsasound
+ use modules
+ use hotplug
+}
+
+start() {
+ ebegin "Starting eflite"
+ start-stop-daemon --start --exec /usr/bin/eflite --background \
+ --quiet --pidfile /var/run/eflite.pid --make-pidfile -- -D || eend 1
+
+ SOCKET=`egrep '^sockname=' /etc/eflite/es.conf | sed 's/^sockname=//'`
+ [ ! -S ${SOCKET} ] && SOCKET=/tmp/es.socket
+
+ chown root:speech ${SOCKET}
+ chmod 660 ${SOCKET}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping eflite"
+ start-stop-daemon --stop --quiet --pidfile /var/run/eflite.pid
+ eend $?
+}
diff --git a/app-accessibility/eflite/files/es.conf b/app-accessibility/eflite/files/es.conf
new file mode 100644
index 000000000000..17443d3e42ba
--- /dev/null
+++ b/app-accessibility/eflite/files/es.conf
@@ -0,0 +1,11 @@
+# What socket do we listen on
+sockname=/tmp/es.socket
+
+# What volume do we set?
+tone_volume=8192
+
+# Do we use the PC Speaker? (0/1)
+speaker_tones=0
+
+# Do we use the sound card (via flite)? (0/1)
+soundcard_tones=1
diff --git a/app-accessibility/eflite/metadata.xml b/app-accessibility/eflite/metadata.xml
new file mode 100644
index 000000000000..c4c56fa229f6
--- /dev/null
+++ b/app-accessibility/eflite/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="16k_voice">Use a higher-quality voice.</flag>
+ </use>
+ <longdescription lang="en">
+ EFlite is a speech server for Emacspeak and other screen readers
+ that allows them to interface with Festival Lite, a free
+ text-to-speech engine developed at the CMU Speech Center as an
+ off-shoot of Festival.
+</longdescription>
+ <longdescription lang="ja">
+ EFliteはEmacspeakと他のスクリーン読取り装置のスピーチサーバ。この
+ サーバーで前のプログラムはFestival Lite(CMU Speech Centerで開発した
+ Festivalのようにスピーチにテキストを変わるエンジン。)と
+ インタフェスすることが出来る。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">eflite</remote-id>
+ </upstream>
+</pkgmetadata>