summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-22 07:30:15 -0500
committerAaron Bauman <bman@gentoo.org>2018-03-27 19:35:47 -0400
commit11c05efb7def362bff4e89bb6525a2c6efa846ec (patch)
tree94573214c75dc9c401b38f66f215980fd511fe8b /app-accessibility/emacspeak
parentapp-accessibility/emacspeak-ss: EAPI bump and patch updates (diff)
downloadgentoo-11c05efb7def362bff4e89bb6525a2c6efa846ec.tar.gz
gentoo-11c05efb7def362bff4e89bb6525a2c6efa846ec.tar.bz2
gentoo-11c05efb7def362bff4e89bb6525a2c6efa846ec.zip
app-accessibility/emacspeak: EAPI bump
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-accessibility/emacspeak')
-rw-r--r--app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild23
-rw-r--r--app-accessibility/emacspeak/emacspeak-9999.ebuild19
2 files changed, 18 insertions, 24 deletions
diff --git a/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
index b720e3de787..daa09b1d531 100644
--- a/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-39.0-r2.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
NEED_EMACS=24
FORCE_PRINT_ELOG=1
DISABLE_AUTOFORMATTING=1
-inherit eutils readme.gentoo elisp
+inherit elisp readme.gentoo-r1
if [[ ${PV} == "9999" ]] ; then
- ESVN_REPO_URI="https://${PN}.googlecode.com/svn/trunk"
- inherit subversion
+ EGIT_REPO_URI="https://github.com/tvraman/emacspeak.git"
+ inherit git-r3
else
SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.bz2"
KEYWORDS="amd64 ppc x86"
@@ -22,7 +22,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
IUSE="+espeak"
- DEPEND="espeak? ( app-accessibility/espeak )"
+DEPEND="espeak? ( app-accessibility/espeak )"
RDEPEND="${DEPEND}
>=dev-tcltk/tclx-8.4"
@@ -35,10 +35,7 @@ by adding the following to your ~/.emacs file:
(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
'
-src_prepare() {
- # Allow user patches to be applied without modifying the ebuild
- epatch_user
-}
+HTML_DOCS=( install-guide user-guide )
src_configure() {
emake config
@@ -51,7 +48,7 @@ src_compile() {
if [[ -z $tcl_version ]]; then
die 'Unable to detect the installed version of dev-lang/tcl.'
fi
- cd servers/linux-espeak
+ cd servers/linux-espeak || die
emake TCL_VERSION="${tcl_version}"
fi
}
@@ -72,8 +69,8 @@ src_install() {
popd > /dev/null || die
fi
dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
- dohtml -r install-guide user-guide
- cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ einstalldocs
+ cd "${D}/usr/share/emacs/site-lisp/${PN}" || die
rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
user-guide || die
readme.gentoo_create_doc
diff --git a/app-accessibility/emacspeak/emacspeak-9999.ebuild b/app-accessibility/emacspeak/emacspeak-9999.ebuild
index 203cdea8432..67a6062698b 100644
--- a/app-accessibility/emacspeak/emacspeak-9999.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
NEED_EMACS=24
FORCE_PRINT_ELOG=1
DISABLE_AUTOFORMATTING=1
-inherit eutils readme.gentoo elisp
+inherit elisp readme.gentoo-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/tvraman/emacspeak.git"
@@ -22,7 +22,7 @@ LICENSE="BSD GPL-2"
SLOT="0"
IUSE="+espeak"
- DEPEND="espeak? ( app-accessibility/espeak )"
+DEPEND="espeak? ( app-accessibility/espeak )"
RDEPEND="${DEPEND}
>=dev-tcltk/tclx-8.4"
@@ -35,10 +35,7 @@ by adding the following to your ~/.emacs file:
(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
'
-src_prepare() {
- # Allow user patches to be applied without modifying the ebuild
- epatch_user
-}
+HTML_DOCS=( install-guide user-guide )
src_configure() {
emake config
@@ -51,7 +48,7 @@ src_compile() {
if [[ -z $tcl_version ]]; then
die 'Unable to detect the installed version of dev-lang/tcl.'
fi
- cd servers/linux-espeak
+ cd servers/linux-espeak || die
emake TCL_VERSION="${tcl_version}"
fi
}
@@ -72,8 +69,8 @@ src_install() {
popd > /dev/null || die
fi
dodoc README etc/NEWS* etc/FAQ etc/COPYRIGHT
- dohtml -r install-guide user-guide
- cd "${D}/usr/share/emacs/site-lisp/${PN}"
+ einstalldocs
+ cd "${D}/usr/share/emacs/site-lisp/${PN}" || die
rm -rf README etc/NEWS* etc/FAQ etc/COPYRIGHT install-guide \
user-guide || die
readme.gentoo_create_doc