summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2017-06-13 11:35:05 -0500
committerWilliam Hubbs <williamh@gentoo.org>2017-06-13 11:37:04 -0500
commitedc9fec4b7cfd3d8c0095b33e3a32f2bcbb54586 (patch)
tree2e9b05f529a33cac2e073c83f516b2820cd19c67 /app-accessibility/nfbtrans
parentapp-admin/vault: version bump to 0.7.3 (diff)
downloadgentoo-edc9fec4b7cfd3d8c0095b33e3a32f2bcbb54586.tar.gz
gentoo-edc9fec4b7cfd3d8c0095b33e3a32f2bcbb54586.tar.bz2
gentoo-edc9fec4b7cfd3d8c0095b33e3a32f2bcbb54586.zip
app-accessibility/nfbtrans: 7.74-r2 revbump for #621510 and #395281
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'app-accessibility/nfbtrans')
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch4
-rw-r--r--app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch24
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild46
3 files changed, 72 insertions, 2 deletions
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
index b44f5bc207ce..7040de343db0 100644
--- a/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-gentoo-fix.patch
@@ -1,5 +1,5 @@
---- nfbtrans.c.orig 2004-09-21 19:52:34.341784094 -0500
-+++ nfbtrans.c 2004-09-21 19:54:07.005727168 -0500
+--- a/nfbtrans.c 2004-09-21 19:52:34.341784094 -0500
++++ b/nfbtrans.c 2004-09-21 19:54:07.005727168 -0500
@@ -6,7 +6,7 @@
#define LINT_ARGS
#define DOS
diff --git a/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
new file mode 100644
index 000000000000..61c991c8a368
--- /dev/null
+++ b/app-accessibility/nfbtrans/files/nfbtrans-7.74-respect-ldflags.patch
@@ -0,0 +1,24 @@
+--- a/Makefile 2017-06-13 11:08:23.428114301 -0500
++++ b/Makefile 2017-06-13 11:09:01.084376256 -0500
+@@ -28,10 +28,10 @@
+ djgppall: nfbtrans.exe
+
+ nfbtrans: $(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ nfbtrans.exe:$(OBJFILES)
+- $(CC) $(CFLAGS) $(OBJFILES) -o nfbtrans.exe
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJFILES) -o nfbtrans.exe
+
+ ultrix:
+ $(MAKE) CFLAGS=-O
+@@ -44,7 +44,7 @@
+
+ insight:
+ insight -fno-builtin -fwritable-strings \
+- $(CFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
++ $(CFLAGS) $(LDFLAGS) $(OBJFILES) $(LIBS) -o nfbtrans
+
+ aix:
+ $(MAKE) all CC=cc CFLAGS="-o -Dunix -Daix"
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
new file mode 100644
index 000000000000..57efe93d0423
--- /dev/null
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="braille translator from the National Federation of the Blind"
+HOMEPAGE="http://www.nfb.org/nfbtrans"
+SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=" >=app-arch/unzip-5.50-r2"
+RDEPEND=""
+
+S=${WORKDIR}
+
+PATCHES=(
+"${FILESDIR}"/${P}-gentoo-fix.patch
+"${FILESDIR}"/${P}-getline-fix.patch
+"${FILESDIR}"/${P}-respect-ldflags.patch
+)
+
+src_prepare() {
+ mv MAKEFILE Makefile || die
+ mv SPANISH.ZIP spanish.zip || die
+ emake lowercase
+ default
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) \
+ LIBS= \
+ CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all
+}
+
+src_install() {
+ dobin nfbtrans
+ dodoc *fmt readme.txt makedoc
+ insinto /etc/nfbtrans
+ doins *cnf *tab *dic spell.dat *zip
+}