summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-01-27 08:57:25 +0200
committerMart Raudsepp <leio@gentoo.org>2018-01-27 11:37:21 +0200
commit59977e998e96c4a50f2d49cd6cc0b1ca7c06ca97 (patch)
tree1932e4eecdb3b253218ccf1a8cbf7f0aabb44405 /app-accessibility/orca
parentxfce-base/thunar: depend on exo-0.11+ for exo-2 (diff)
downloadgentoo-59977e998e96c4a50f2d49cd6cc0b1ca7c06ca97.tar.gz
gentoo-59977e998e96c4a50f2d49cd6cc0b1ca7c06ca97.tar.bz2
gentoo-59977e998e96c4a50f2d49cd6cc0b1ca7c06ca97.zip
app-accessibility/orca: remove old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-3.22.2.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index fda6b2a4023..403bf5cfaaf 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,2 +1 @@
-DIST orca-3.22.2.tar.xz 2345292 BLAKE2B 86a0d0ab6d7ea7e0d25100e9a3eb525ca8981270648849594ce53257b098dcfec49eaccc4922fcc701418e57a91603796a20f1727b0020b359500662bdadc860 SHA512 0c4f3055509fd983da1081c4e33a4675ca498e75a8f2701318c000810cf691758eaded01969a6b56a2c25cf507bc4cb7e099f8498d1a0f6fa739d074a23528c5
DIST orca-3.24.0.tar.xz 2391740 BLAKE2B 1f294bc8e1c593690c511f0d7d660230c420b33de59c8b1e78ee8d7b16f973b9fff9ce4d656de7202ffd5789ae3604d030c442e8c35eecfd5c5dca058031e996 SHA512 9aa65b534f69bb4a1b800e715776416843ac3756ec1267feca3c66476e34e54f6744f70c0f8ac8868a009d38b6cc165267268491a9ad29ebbd3601dba09d424c
diff --git a/app-accessibility/orca/orca-3.22.2.ebuild b/app-accessibility/orca/orca-3.22.2.ebuild
deleted file mode 100644
index 5fef8aef7e1..00000000000
--- a/app-accessibility/orca/orca-3.22.2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python3_{4,5} )
-PYTHON_REQ_USE="threads"
-
-inherit gnome2 python-r1
-
-DESCRIPTION="Extensible screen reader that provides access to the desktop"
-HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
-
-LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
-
-IUSE="+braille"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPEND="${PYTHON_DEPS}
- >=app-accessibility/at-spi2-atk-2.12:2
- >=app-accessibility/at-spi2-core-2.12:2[introspection]
- >=dev-libs/atk-2.10
- >=dev-libs/glib-2.28:2
- dev-python/gst-python:1.0[${PYTHON_USEDEP}]
- >=dev-python/pygobject-3.10:3[${PYTHON_USEDEP}]
- media-libs/gstreamer:1.0[introspection]
- >=x11-libs/gtk+-3.6.2:3[introspection]
- braille? (
- >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
- dev-libs/liblouis[python,${PYTHON_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
- >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
- dev-libs/atk[introspection]
- dev-python/pyatspi[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- x11-libs/libwnck:3[introspection]
- x11-libs/pango[introspection]
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.50
- dev-util/itstool
- virtual/pkgconfig
-"
-# app-text/yelp-tools
-
-src_prepare() {
- gnome2_src_prepare
- python_copy_sources
-}
-
-src_configure() {
- python_foreach_impl run_in_build_dir gnome2_src_configure \
- $(use_with braille liblouis)
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir gnome2_src_compile
-}
-
-src_install() {
- installing() {
- gnome2_src_install
- # Massage shebang to make python_doscript happy
- sed -e 's:#!'"${PYTHON}:#!/usr/bin/python:" \
- -i src/orca/orca || die
- python_doscript src/orca/orca
- }
- python_foreach_impl run_in_build_dir installing
-}