summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/speechd-el
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/speechd-el')
-rw-r--r--app-accessibility/speechd-el/Manifest1
-rw-r--r--app-accessibility/speechd-el/metadata.xml12
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.5.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/app-accessibility/speechd-el/Manifest b/app-accessibility/speechd-el/Manifest
new file mode 100644
index 000000000000..35e398d63358
--- /dev/null
+++ b/app-accessibility/speechd-el/Manifest
@@ -0,0 +1 @@
+DIST speechd-el-2.5.tar.gz 183278 SHA256 1ec52b27248e1c68d3ac37bee78842f3e124dc78e63891a1b706519349e4824e SHA512 b4e5d00d3a86be9c42172ab48c5b0c0f5f25817cb542302f04e29f594422247e4b008428dfaaa1bb2e208a71f126b9c86d25186974606bf5764212a0d6a1a09f WHIRLPOOL 3063e34e19e239653455ebe51bbc0e2e8630c21d5bd2342a24e39c1c8d6a831bb595165611cfa9b441fb6e9ccab50d956b81e63bb4235a86a03464812ffbe4ac
diff --git a/app-accessibility/speechd-el/metadata.xml b/app-accessibility/speechd-el/metadata.xml
new file mode 100644
index 000000000000..dc145bb72d02
--- /dev/null
+++ b/app-accessibility/speechd-el/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<herd>emacs</herd>
+<maintainer>
+<email>williamh@gentoo.org</email>
+</maintainer>
+ <use>
+ <flag name="brltty">brltty support</flag>
+</use>
+</pkgmetadata>
diff --git a/app-accessibility/speechd-el/speechd-el-2.5.ebuild b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
new file mode 100644
index 000000000000..0936ee27567b
--- /dev/null
+++ b/app-accessibility/speechd-el/speechd-el-2.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit elisp
+
+DESCRIPTION="Emacs speech support"
+HOMEPAGE="http://www.freebsoft.org/speechd-el"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd-el/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="brltty"
+
+DEPEND=""
+RDEPEND=">=app-accessibility/speech-dispatcher-0.7
+ brltty? ( app-accessibility/brltty )"
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ dobin speechd-log-extractor
+ dodoc ANNOUNCE NEWS README speechd-speak.pdf
+ doinfo speechd-el.info
+}
+
+pkg_postinst() {
+ elog "Execute the following commands from within emacs to get it to speak:"
+ elog " M-x load-library RET speechd-speak RET"
+ elog " M-x speechd-speak RET"
+ elog
+ elog "or add the following to your ~/.emacs file:"
+ elog
+ elog "(autoload 'speechd-speak \"speechd-speak\" nil t)"
+ elog '(speechd-speak)'
+}