summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-19 21:13:14 +0000
committerSam James <sam@gentoo.org>2021-12-19 21:16:17 +0000
commit2ebe3d962d7f083ec7726f5d239d153f272bbdf9 (patch)
treeed3d7d4199ced383b5014de34fa3db34d09976c0 /app-accessibility
parentdev-python/flit_core: Stabilize 3.5.1 ALLARCHES, #829649 (diff)
downloadgentoo-2ebe3d962d7f083ec7726f5d239d153f272bbdf9.tar.gz
gentoo-2ebe3d962d7f083ec7726f5d239d153f272bbdf9.tar.bz2
gentoo-2ebe3d962d7f083ec7726f5d239d153f272bbdf9.zip
app-accessibility/at-spi2-core: fix build with USE=-X
Closes: https://bugs.gentoo.org/829591 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.42.0.ebuild2
-rw-r--r--app-accessibility/at-spi2-core/files/at-spi2-core-2.42.0-fix-disabling-x11.patch36
2 files changed, 38 insertions, 0 deletions
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.42.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.42.0.ebuild
index 015d93ad1499..bc190c2de667 100644
--- a/app-accessibility/at-spi2-core/at-spi2-core-2.42.0.ebuild
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.42.0.ebuild
@@ -38,6 +38,8 @@ BDEPEND="
PATCHES=(
# disable teamspaces test since that requires Novell.ICEDesktop.Daemon
"${FILESDIR}/${PN}-2.0.2-disable-teamspaces-test.patch"
+
+ "${FILESDIR}/${PN}-2.42.0-fix-disabling-x11.patch"
)
multilib_src_configure() {
diff --git a/app-accessibility/at-spi2-core/files/at-spi2-core-2.42.0-fix-disabling-x11.patch b/app-accessibility/at-spi2-core/files/at-spi2-core-2.42.0-fix-disabling-x11.patch
new file mode 100644
index 000000000000..3bf32724e691
--- /dev/null
+++ b/app-accessibility/at-spi2-core/files/at-spi2-core-2.42.0-fix-disabling-x11.patch
@@ -0,0 +1,36 @@
+https://bugs.gentoo.org/829591
+https://gitlab.gnome.org/GNOME/at-spi2-core/-/commit/2175d89198440d948075f3268aec5f45430afb3d
+
+From 2175d89198440d948075f3268aec5f45430afb3d Mon Sep 17 00:00:00 2001
+From: Tim Orling <ticotimo@gmail.com>
+Date: Fri, 15 Oct 2021 12:44:39 -0700
+Subject: [PATCH] Ensure x11_dep is defined
+
+bus/meson.build checks if x11_dep.found(), but this fails when
+-Dx11=no
+
+References:
+ https://gitlab.gnome.org/GNOME/at-spi2-core/-/issues/42
+ https://mesonbuild.com/howtox.html#get-a-default-notfound-dependency
+
+Signed-off-by: Tim Orling <ticotimo@gmail.com>
+---
+ meson.build | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index b5104c8c..cfd2e091 100644
+--- a/meson.build
++++ b/meson.build
+@@ -62,6 +62,8 @@ endif
+
+ x11_deps = []
+ x11_option = get_option('x11')
++# ensure x11_dep is defined for use elsewhere, such as bus/meson.build
++x11_dep = dependency('', required: false)
+ if x11_option != 'no'
+ x11_dep = dependency('x11', required: false)
+
+--
+GitLab
+