summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/analog/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/analog/files')
-rw-r--r--app-admin/analog/files/analog-5.1-gentoo.diff20
-rw-r--r--app-admin/analog/files/analog-6.0-bzip2.patch64
-rw-r--r--app-admin/analog/files/analog-6.0-undefined-macro.patch38
-rw-r--r--app-admin/analog/files/analog.cfg101
4 files changed, 223 insertions, 0 deletions
diff --git a/app-admin/analog/files/analog-5.1-gentoo.diff b/app-admin/analog/files/analog-5.1-gentoo.diff
new file mode 100644
index 000000000000..b604c254c572
--- /dev/null
+++ b/app-admin/analog/files/analog-5.1-gentoo.diff
@@ -0,0 +1,20 @@
+--- a/src/anlghead.h Wed Nov 7 06:06:46 2001
++++ b/src/anlghead.h Mon Dec 31 16:47:43 2001
+@@ -81,15 +81,11 @@
+ and use that directory; or the current directory if it couldn't deduce a
+ directory. This may or may not work, so it's better to specify a location
+ explicitly here if you know where the files will be kept. */
+-#ifndef LANGDIR
+-#define LANGDIR NULL
+-#endif
++#define LANGDIR "/usr/share/analog/lang/"
+ /* Directory where the language files live. Actually, if this one is defined
+ to be NULL, they will be looked for inside the "lang" subdirectory of the
+ directory containing the analog binary. */
+-#ifndef CONFIGDIR
+-#define CONFIGDIR NULL
+-#endif
++#define CONFIGDIR "/etc/analog/"
+ /* Directory containing configuration files. */
+ #ifndef LOGSDIR
+ #define LOGSDIR NULL
diff --git a/app-admin/analog/files/analog-6.0-bzip2.patch b/app-admin/analog/files/analog-6.0-bzip2.patch
new file mode 100644
index 000000000000..f950a30ef470
--- /dev/null
+++ b/app-admin/analog/files/analog-6.0-bzip2.patch
@@ -0,0 +1,64 @@
+Use system bzip2 library. Get CC and CFLAGS from environment.
+ -jer (bug #249140)
+
+
+--- a/src/Makefile 2004-12-19 14:51:30.000000000 +0100
++++ b/src/Makefile 2008-12-15 22:50:04.000000000 +0100
+@@ -2,16 +2,16 @@
+ # Please read docs/Readme.html, or http://www.analog.cx/
+ # This is a general Unix-like Makefile: Makefiles for other OS's can be found
+ # in the "build" directory.
+-CC = gcc # which compiler to use: eg cc, acc, gcc. NB Different
++# CC is set in the environment.
+ # compilers need different CFLAGS, e.g., -O instead of -O2.
+ MAKE = make # which "make" to use
+-CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
++# CFLAGS is set in the environment.
+ # Some OS's need -D_FILE_OFFSET_BITS=64 to support files > 2MB.
+ # HP/UX cc needs CFLAGS = -Aa (HP/UX 9) or -Ae (HP/UX 10)
+ # BeOS needs CFLAGS = -O2 -Wl,-L/boot/home/config/lib
+ # BS2000/OSD needs CFLAGS = -XLLML -XLLMK
+ # NeXTSTEP needs CFLAGS = -O2 -pipe -no-precomp
+-DEFS = # any combination of -DNOPIPES -DNODNS -DNODIRENT -DNOGLOB ...
++DEFS = -DHAVE_GD -DHAVE_PCRE -DHAVE_ZLIB -DHAVE_BZLIB
+ # ... -DNOOPEN -DNOFOLLOW -DNOALARM -DNOGRAPHICS -DNOGMTIME ...
+ # ... -DEBCDIC -DUSE_PLAIN_SETJMP ...
+ # ... -DHAVE_GD -DHAVE_ZLIB -DHAVE_BZLIB -DHAVE_PCRE ...
+@@ -30,7 +30,7 @@
+ #
+ OS = UNIX # Operating system: UNIX, DOS, WIN32, MAC, OS2, OSX, VMS
+ # RISCOS, BEOS, NEXTSTEP, MPEIX, BS2000, AS400, OS390
+-LIBS = -lm # extra libraries needed; most platforms (but not OS X or BeOS)
++LIBS = -lgd -lz -lbz2 -lpcre -lm -lpng -ljpeg
+ # need -lm LAST
+ # if you defined HAVE_GD above you also need -lgd -lpng -ljpeg -lz
+ # if you defined HAVE_ZLIB above you also need -lz
+@@ -54,7 +54,7 @@
+ input.o macinput.o macstuff.o output.o output2.o outcro.o outhtml.o \
+ outlatex.o outplain.o outxhtml.o outxml.o process.o settings.o sort.o \
+ tree.o utils.o win32.o
+-SUBDIRS = bzip2 libgd libpng pcre unzip zlib
++SUBDIRS = libgd libpng pcre unzip zlib
+ SUBDIROBJS = libgd/gd.o libgd/gd_io.o libgd/gd_io_file.o libgd/gd_png.o \
+ libgd/gdfontf.o libgd/gdfonts.o libgd/gdtables.o \
+ libpng/png.o libpng/pngerror.o libpng/pngmem.o libpng/pngset.o \
+@@ -63,9 +63,7 @@
+ zlib/adler32.o zlib/compress.o zlib/crc32.o zlib/deflate.o \
+ zlib/gzio.o zlib/infblock.o zlib/infcodes.o zlib/inffast.o \
+ zlib/inflate.o zlib/inftrees.o zlib/infutil.o zlib/trees.o \
+- zlib/uncompr.o zlib/zutil.o unzip/ioapi.o unzip/unzip.o \
+- bzip2/bzlib.o bzip2/blocksort.o bzip2/compress.o bzip2/crctable.o \
+- bzip2/decompress.o bzip2/huffman.o bzip2/randtable.o
++ zlib/uncompr.o zlib/zutil.o unzip/ioapi.o unzip/unzip.o
+ HEADERS = anlghead.h anlghea2.h anlghea3.h anlghea4.h macdir.h \
+ pcre/pcre.h libgd/gd.h libgd/gdfontf.h libgd/gdfonts.h unzip/unzip.h \
+ zlib/zlib.h bzip2/bzlib.h
+@@ -77,8 +75,6 @@
+
+ # There doesn't seem to be a good way to write all these rules in a generic
+ # form that works for all "make" programs
+-bzip2: ALWAYS
+- cd bzip2 && $(MAKE) 'CC=$(CC)' 'ALLCFLAGS=$(ALLCFLAGS)'
+
+ libgd: ALWAYS
+ cd libgd && $(MAKE) 'CC=$(CC)' 'ALLCFLAGS=$(ALLCFLAGS)'
diff --git a/app-admin/analog/files/analog-6.0-undefined-macro.patch b/app-admin/analog/files/analog-6.0-undefined-macro.patch
new file mode 100644
index 000000000000..5a98541c465c
--- /dev/null
+++ b/app-admin/analog/files/analog-6.0-undefined-macro.patch
@@ -0,0 +1,38 @@
+--- a/src/unzip/ioapi.h 2004-12-19 14:51:32.000000000 +0100
++++ b/src/unzip/ioapi.h 2012-01-11 18:07:59.570768250 +0100
+@@ -35,6 +35,16 @@
+ extern "C" {
+ #endif
+
++/* Work-around for NetBSD. Its zconf.h doesn't define OF(x) */
++#ifndef OF
++#ifdef __STDC__
++#define OF(x) x
++#else
++#define OF(x) ()
++#endif
++#endif
++
++
+ typedef voidpf (ZCALLBACK *open_file_func) OF((voidpf opaque, const char* filename, int mode));
+ typedef uLong (ZCALLBACK *read_file_func) OF((voidpf opaque, voidpf stream, void* buf, uLong size));
+ typedef uLong (ZCALLBACK *write_file_func) OF((voidpf opaque, voidpf stream, const void* buf, uLong size));
+--- a/src/unzip/unzip.h 2004-12-19 14:51:32.000000000 +0100
++++ b/src/unzip/unzip.h 2012-01-11 18:00:25.988120225 +0100
+@@ -47,6 +47,15 @@
+ extern "C" {
+ #endif
+
++/* Work-around for NetBSD. Its zconf.h doesn't define OF(x) */
++#ifndef OF
++#ifdef __STDC__
++#define OF(x) x
++#else
++#define OF(x) ()
++#endif
++#endif
++
+ #ifndef _ZLIB_H
+ #include "../zlib/zlib.h"
+ #endif
+
diff --git a/app-admin/analog/files/analog.cfg b/app-admin/analog/files/analog.cfg
new file mode 100644
index 000000000000..99e452b36e3d
--- /dev/null
+++ b/app-admin/analog/files/analog.cfg
@@ -0,0 +1,101 @@
+# Configuration file for analog 5.1
+# See http://www.analog.cx/
+#
+# This is a simple default configuration file which works when you run
+# analog with no command line parameters. There are much more extensive
+# configuration examples included with the documentation.
+# See the big.cfg example file.
+#
+# If you need a LOGFORMAT command (most people don't -- try it without first!),
+# it must go here, above the LOGFILE commands.
+LOGFILE /var/log/apache/access_log
+OUTFILE /var/log/analog/index.html
+LANGUAGE ENGLISH
+IMAGEDIR images/
+# HOSTNAME "[my organisation]"
+REQLINKINCLUDE pages
+REFLINKINCLUDE *
+REDIRREFLINKINCLUDE *
+FAILREFLINKINCLUDE *
+UNCOMPRESS *.gz,*.Z "gzip -cd"
+BROWOUTPUTALIAS IWENG AOL
+SUBBROW */*
+SUBTYPE *.gz,*.Z
+# Add whichever of these types of pages you have on your server, or others.
+# PAGEINCLUDE *.shtml
+# PAGEINCLUDE *.asp
+# PAGEINCLUDE *.jsp
+# PAGEINCLUDE *.cfm
+# PAGEINCLUDE *.pl
+# PAGEINCLUDE *.php
+SEARCHENGINE http://*altavista.*/* q
+SEARCHENGINE http://*yahoo.*/* p
+SEARCHENGINE http://*google.*/* q
+SEARCHENGINE http://*lycos.*/* query
+SEARCHENGINE http://*aol.*/* query
+SEARCHENGINE http://*excite.*/* search
+SEARCHENGINE http://*go2net.*/* general
+SEARCHENGINE http://*metacrawler.*/* general
+SEARCHENGINE http://*msn.*/* MT
+SEARCHENGINE http://*hotbot.com/* MT
+SEARCHENGINE http://*netscape.*/* search
+SEARCHENGINE http://*looksmart.*/* key
+SEARCHENGINE http://*infoseek.*/* qt
+SEARCHENGINE http://*webcrawler.*/* search,searchText
+SEARCHENGINE http://*goto.*/* Keywords
+SEARCHENGINE http://*snap.*/* keyword
+SEARCHENGINE http://*dogpile.*/* q
+SEARCHENGINE http://*askjeeves.*/* ask
+SEARCHENGINE http://*ask.*/* ask
+SEARCHENGINE http://*aj.*/* ask
+SEARCHENGINE http://*directhit.*/* qry
+SEARCHENGINE http://*alltheweb.*/* query
+SEARCHENGINE http://*northernlight.*/* qr
+SEARCHENGINE http://*nlsearch.*/* qr
+SEARCHENGINE http://*dmoz.*/* search
+SEARCHENGINE http://*newhoo.*/* search
+SEARCHENGINE http://*netfind.*/* query,search,s
+SEARCHENGINE http://*/netfind* query
+SEARCHENGINE http://*/pursuit query
+ROBOTINCLUDE REGEXPI:robot
+ROBOTINCLUDE REGEXPI:spider
+ROBOTINCLUDE REGEXPI:crawler
+ROBOTINCLUDE Googlebot*
+ROBOTINCLUDE Infoseek*
+ROBOTINCLUDE Scooter*
+ROBOTINCLUDE Slurp*
+ROBOTINCLUDE Ultraseek*
+TYPEOUTPUTALIAS .html ".html [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .htm ".htm [Hypertext Markup Language]"
+TYPEOUTPUTALIAS .shtml ".shtml [Server-parsed HTML]"
+TYPEOUTPUTALIAS .ps ".ps [PostScript]"
+TYPEOUTPUTALIAS .gz ".gz [Gzip compressed files]"
+TYPEOUTPUTALIAS .tar.gz ".tar.gz [Compressed archives]"
+TYPEOUTPUTALIAS .jpg ".jpg [JPEG graphics]"
+TYPEOUTPUTALIAS .jpeg ".jpeg [JPEG graphics]"
+TYPEOUTPUTALIAS .gif ".gif [GIF graphics]"
+TYPEOUTPUTALIAS .png ".png [PNG graphics]"
+TYPEOUTPUTALIAS .txt ".txt [Plain text]"
+TYPEOUTPUTALIAS .cgi ".cgi [CGI scripts]"
+TYPEOUTPUTALIAS .pl ".pl [Perl scripts]"
+TYPEOUTPUTALIAS .css ".css [Cascading Style Sheets]"
+TYPEOUTPUTALIAS .class ".class [Java class files]"
+TYPEOUTPUTALIAS .pdf ".pdf [Adobe Portable Document Format]"
+TYPEOUTPUTALIAS .zip ".zip [Zip archives]"
+TYPEOUTPUTALIAS .hqx ".hqx [Macintosh archives]"
+TYPEOUTPUTALIAS .exe ".exe [Executables]"
+TYPEOUTPUTALIAS .wav ".wav [WAV sound files]"
+TYPEOUTPUTALIAS .avi ".avi [AVI movies]"
+TYPEOUTPUTALIAS .arc ".arc [Compressed archives]"
+TYPEOUTPUTALIAS .mid ".mid [MIDI sound files]"
+TYPEOUTPUTALIAS .mp3 ".mp3 [MP3 sound files]"
+TYPEOUTPUTALIAS .doc ".doc [Microsoft Word document]"
+TYPEOUTPUTALIAS .rtf ".rtf [Rich Text Format]"
+TYPEOUTPUTALIAS .mov ".mov [Quick Time movie]"
+TYPEOUTPUTALIAS .mpg ".mpg [MPEG movie]"
+TYPEOUTPUTALIAS .mpeg ".mpeg [MPEG movie]"
+TYPEOUTPUTALIAS .asp ".asp [Active Server Pages]"
+TYPEOUTPUTALIAS .jsp ".jsp [Java Server Pages]"
+TYPEOUTPUTALIAS .cfm ".cfm [Cold Fusion]"
+TYPEOUTPUTALIAS .php ".php [PHP]"
+TYPEOUTPUTALIAS .js ".js [JavaScript code]"