summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/ccze
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/ccze')
-rw-r--r--app-admin/ccze/Manifest1
-rw-r--r--app-admin/ccze/ccze-0.2.1-r3.ebuild45
-rw-r--r--app-admin/ccze/files/ccze-0.2.1-tinfo.patch10
-rw-r--r--app-admin/ccze/files/ccze-fbsd.patch25
-rw-r--r--app-admin/ccze/files/ccze-ldflags.patch11
-rw-r--r--app-admin/ccze/files/ccze-segfault.patch29
-rw-r--r--app-admin/ccze/metadata.xml15
7 files changed, 136 insertions, 0 deletions
diff --git a/app-admin/ccze/Manifest b/app-admin/ccze/Manifest
new file mode 100644
index 000000000000..71616016a9fc
--- /dev/null
+++ b/app-admin/ccze/Manifest
@@ -0,0 +1 @@
+DIST ccze-0.2.1.tar.gz 139795 SHA256 8263a11183fd356a033b6572958d5a6bb56bfd2dba801ed0bff276cfae528aa3 SHA512 1704da8d4c97a3403a57d7841db8a6e4ba6116e401f91d9ecf1b1371cc18b40641e5665c9414740d6a523874be6b6527f5c0d4f3a3796c7b96ed83192146b2b7 WHIRLPOOL 93f8891c3a7885ca264f7269493893e6555865c89dee5cf5c890754f55db0ac60dce26d76318c8f838d7ee6ff6fe8e2454e9b4490ab607e496a5fdc0ef4f7685
diff --git a/app-admin/ccze/ccze-0.2.1-r3.ebuild b/app-admin/ccze/ccze-0.2.1-r3.ebuild
new file mode 100644
index 000000000000..9150eed38e6b
--- /dev/null
+++ b/app-admin/ccze/ccze-0.2.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit fixheadtails autotools eutils toolchain-funcs
+
+DESCRIPTION="A flexible and fast logfile colorizer"
+HOMEPAGE="http://dev.gentoo.org/~joker/ccze/ccze.txt"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+RESTRICT="test"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/libpcre
+ sys-libs/ncurses"
+
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/ccze-fbsd.patch
+ epatch "${FILESDIR}"/ccze-segfault.patch
+ epatch "${FILESDIR}"/ccze-ldflags.patch
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+
+ # GCC 4.x fixes
+ sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
+ -i src/Makefile.in || die
+ sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
+ -i configure.ac || die
+
+ eautoreconf
+
+ ht_fix_file Rules.mk.in
+
+ tc-export CC
+}
diff --git a/app-admin/ccze/files/ccze-0.2.1-tinfo.patch b/app-admin/ccze/files/ccze-0.2.1-tinfo.patch
new file mode 100644
index 000000000000..d0d7550e3337
--- /dev/null
+++ b/app-admin/ccze/files/ccze-0.2.1-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -100,6 +100,7 @@
+ strndup strstr])
+
+ AC_CHECK_LIB(ncurses, initscr, [], [AC_ERROR(NCurses library not found)])
++AC_SEARCH_LIBS(stdscr, tinfo,,[AC_ERROR([Cannot find a library providing stdscr])])
+ AC_CHECK_FUNC(dlopen, [], [AC_CHECK_LIB(dl, dlopen)])
+ AC_CHECK_FUNC(getopt_long, [], [AC_CHECK_LIB(gnugetopt, getopt_long)])
+
diff --git a/app-admin/ccze/files/ccze-fbsd.patch b/app-admin/ccze/files/ccze-fbsd.patch
new file mode 100644
index 000000000000..ae694e0e4423
--- /dev/null
+++ b/app-admin/ccze/files/ccze-fbsd.patch
@@ -0,0 +1,25 @@
+--- a/src/ccze-compat.h
++++ b/src/ccze-compat.h
+@@ -29,6 +29,11 @@
+ #include <stddef.h>
+ #include <stdio.h>
+
++# ifndef __error_t_defined
++typedef int error_t;
++# define __error_t_defined 1
++# endif
++
+ #ifndef HAVE_STRNDUP
+ char *strndup (const char *s, size_t size);
+ #endif
+--- a/src/ccze-compat.c
++++ b/src/ccze-compat.c
+@@ -275,7 +275,7 @@
+ char **valuep)
+ {
+ int i = getsubopt (optionp, tokens, valuep);
+-#if HAVE_SUBOPTARg
++#if HAVE_SUBOPTARG
+ if (!*valuep && suboptarg)
+ *valuep = strdup (suboptarg);
+ #endif
diff --git a/app-admin/ccze/files/ccze-ldflags.patch b/app-admin/ccze/files/ccze-ldflags.patch
new file mode 100644
index 000000000000..4f8c8f207209
--- /dev/null
+++ b/app-admin/ccze/files/ccze-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -75,7 +75,7 @@
+ ${PROGRAM}: ${OBJECTS} ${PLUGIN_SOBJS}
+ ${CC} -rdynamic ${ALL_CFLAGS} -o $@ $^ ${ALL_LDFLAGS}
+ ccze-dump ccze-cssdump: %: %.o ccze-compat.o ccze-color.c
+- ${CC} ${ALL_CFLAGS} -o $@ $@.o ccze-compat.o
++ ${CC} ${ALL_CFLAGS} ${ALL_LDFLAGS} -o $@ $@.o ccze-compat.o
+ ccze-builtins.c: Makefile
+ echo '#include <ccze.h>' >$@
+ echo '#include "ccze-private.h"' >>$@
diff --git a/app-admin/ccze/files/ccze-segfault.patch b/app-admin/ccze/files/ccze-segfault.patch
new file mode 100644
index 000000000000..5bdd823e4120
--- /dev/null
+++ b/app-admin/ccze/files/ccze-segfault.patch
@@ -0,0 +1,29 @@
+--- a/src/ccze.c
++++ b/src/ccze.c
+@@ -209,7 +209,7 @@
+ }
+ break;
+ case 'a':
+- plugin = strtok (optarg, "=");
++ plugin = strtok (arg, "=");
+ value = strtok (NULL, "\n");
+ ccze_plugin_argv_set (plugin, value);
+ break;
+@@ -249,7 +249,7 @@
+ ccze_config.remfac = 1;
+ break;
+ case 'm':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, m_subopts, &value))
+@@ -273,7 +273,7 @@
+ }
+ break;
+ case 'o':
+- subopts = optarg;
++ subopts = arg;
+ while (*subopts != '\0')
+ {
+ switch (getsubopt (&subopts, o_subopts, &value))
diff --git a/app-admin/ccze/metadata.xml b/app-admin/ccze/metadata.xml
new file mode 100644
index 000000000000..2c85fc4869de
--- /dev/null
+++ b/app-admin/ccze/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>joker@gentoo.org</email>
+ <name>Christian Birchinger</name>
+ <description>Please take over if you want it</description>
+</maintainer>
+<longdescription>
+ CCZE is my C port of RASZi's colorize, with a set of bug fixes and enhancements.
+ It uses PCRE to do the matching, and NCurses for the output. The goal was to
+ create a log coloriser, that is fast and light on resources. Also, being extensible
+ via plug-ins is an important feature too.
+</longdescription>
+</pkgmetadata>