summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-03-26 21:55:40 +0800
committerJason Zaman <perfinion@gentoo.org>2019-03-27 18:36:21 +0800
commitc331ef08681f503d237142fd2cf687e9bd99e024 (patch)
tree5f629d62c7b051ac100df71837787c34bf2e02cc /app-admin/cgmanager
parentnet-analyzer/fail2ban: Drop various optional runtime dependencies (diff)
downloadgentoo-c331ef08681f503d237142fd2cf687e9bd99e024.tar.gz
gentoo-c331ef08681f503d237142fd2cf687e9bd99e024.tar.bz2
gentoo-c331ef08681f503d237142fd2cf687e9bd99e024.zip
app-admin/cgmanager: bump 0.42
Signed-off-by: Jason Zaman <perfinion@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'app-admin/cgmanager')
-rw-r--r--app-admin/cgmanager/Manifest1
-rw-r--r--app-admin/cgmanager/cgmanager-0.42.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/cgmanager/Manifest b/app-admin/cgmanager/Manifest
index dbee2bb05d06..e4950e788797 100644
--- a/app-admin/cgmanager/Manifest
+++ b/app-admin/cgmanager/Manifest
@@ -1 +1,2 @@
DIST cgmanager-0.41.tar.gz 461805 BLAKE2B 22c779953d637012694c19490da9d3707b9e2a935f910d192fd1e6a44c27e933e93b6ae516399991924175a9e8e05fd650cf3117d3e7bde034a20bc083ebaa09 SHA512 e8ba64665a21d987cd835580c2b6bafbcb05e22ce7f6216762d04840957c2cd21fb571360e0206ae9143656beed88ff3396eb1f644052c05189093a665a705fd
+DIST cgmanager-0.42.tar.gz 467980 BLAKE2B 70df5ebda230773f3a2a4ed6f784e591126769122533182821b0fe2c157f9bd7b9fd58a3bb104b0ef089320b167d3136c379d760ea6c65dab0c88f46d41596cb SHA512 d92113a6748084f1c0708f75c8bdf5de484d534bf00f664a5288902be887c2a1c7cf3d91afaab3331f0d573a86fbc6edb2fa1d37c070250cf53e0621213d7d74
diff --git a/app-admin/cgmanager/cgmanager-0.42.ebuild b/app-admin/cgmanager/cgmanager-0.42.ebuild
new file mode 100644
index 000000000000..ec194ccee43a
--- /dev/null
+++ b/app-admin/cgmanager/cgmanager-0.42.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools pam
+
+DESCRIPTION="Control Group manager daemon"
+HOMEPAGE="https://linuxcontainers.org/cgmanager/introduction/"
+SRC_URI="https://linuxcontainers.org/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="pam selinux"
+
+RDEPEND="sys-libs/libnih[dbus]
+ sys-apps/dbus
+ selinux? ( sec-policy/selinux-cgmanager )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ # systemd expects files in /sbin but we will have them in /usr/sbin
+ pushd config/init/systemd > /dev/null || die
+ sed -i -e "s@sbin@usr/&@" {${PN},cgproxy}.service || \
+ die "Failed to fix paths in systemd service files"
+ popd > /dev/null || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-distro=gentoo \
+ --with-pamdir="$(usex pam $(getpam_mod_dir) none)" \
+ --with-init-script=systemd
+}
+
+src_install () {
+ default
+
+ # I see no reason to have the tests in the filesystem. Drop them
+ rm -r "${D}"/usr/share/${PN}/tests || die "Failed to remove ${PN} tests"
+
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newinitd "${FILESDIR}"/cgproxy.initd-r1 cgproxy
+}