summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2018-03-11 13:45:00 +0100
committerDaniel Pielmeier <billie@gentoo.org>2018-03-11 13:45:30 +0100
commit90fd8959023db84ccf85a639c45a2b03b67c5d6e (patch)
tree2c41c9d583d125d060bd445b83c31abaa13c2339 /app-admin/conky
parentkde-frameworks/extra-cmake-modules: stabilise 5.43.0 for arm/ppc/ppc64 using ... (diff)
downloadgentoo-90fd8959023db84ccf85a639c45a2b03b67c5d6e.tar.gz
gentoo-90fd8959023db84ccf85a639c45a2b03b67c5d6e.tar.bz2
gentoo-90fd8959023db84ccf85a639c45a2b03b67c5d6e.zip
app-admin/conky: Fix bug #648090.
This adds a patch to switch back to using pkg-config for the detection of ncurses instead of FindCurses provided by cmake as it does not handle cases with separate tinfo. Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/conky-1.10.8.ebuild2
-rw-r--r--app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch34
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/conky/conky-1.10.8.ebuild b/app-admin/conky/conky-1.10.8.ebuild
index 2679d6611621..e46eaaa3096c 100644
--- a/app-admin/conky/conky-1.10.8.ebuild
+++ b/app-admin/conky/conky-1.10.8.ebuild
@@ -73,6 +73,8 @@ CONFIG_CHECK=~IPV6
DOCS=( README.md TODO ChangeLog NEWS AUTHORS )
+PATCHES=( "${FILESDIR}"/${P}-use-pkgconfig.patch )
+
DISABLE_AUTOFORMATTING="yes"
DOC_CONTENTS="You can find sample configurations at ${ROOT%/}/usr/share/doc/${PF}.
To customize, copy to ${XDG_CONFIG_HOME}/conky/conky.conf
diff --git a/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch b/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch
new file mode 100644
index 000000000000..97e6bd02323f
--- /dev/null
+++ b/app-admin/conky/files/conky-1.10.8-use-pkgconfig.patch
@@ -0,0 +1,34 @@
+Reversed patch
+
+From abd0be51a00444d3be6b213e0926675e5a4e5ed3 Mon Sep 17 00:00:00 2001
+From: Brenden Matthews <brenden@diddyinc.com>
+Date: Tue, 23 Jan 2018 12:56:06 -0500
+Subject: [PATCH] Use FindCurses instead of pkg_check_modules.
+
+This should resolve #217.
+---
+ cmake/ConkyPlatformChecks.cmake | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/cmake/ConkyPlatformChecks.cmake b/cmake/ConkyPlatformChecks.cmake
+index c5b39b2f..19ec7b9b 100644
+--- a/cmake/ConkyPlatformChecks.cmake
++++ b/cmake/ConkyPlatformChecks.cmake
+@@ -129,12 +129,12 @@ if(BUILD_HTTP)
+ endif(BUILD_HTTP)
+
+ if(BUILD_NCURSES)
++ pkg_check_modules(NCURSES ncurses)
++ if(NOT NCURSES_FOUND)
+- include(FindCurses)
+- if(NOT CURSES_FOUND)
+ message(FATAL_ERROR "Unable to find ncurses library")
++ endif(NOT NCURSES_FOUND)
++ set(conky_libs ${conky_libs} ${NCURSES_LIBRARIES})
++ set(conky_includes ${conky_includes} ${NCURSES_INCLUDE_DIRS})
+- endif(NOT CURSES_FOUND)
+- set(conky_libs ${conky_libs} ${CURSES_LIBRARIES})
+- set(conky_includes ${conky_includes} ${CURSES_INCLUDE_DIR})
+ endif(BUILD_NCURSES)
+
+ if(BUILD_MYSQL)