summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <tmozes@sygic.com>2019-03-05 05:22:47 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-03-05 15:57:47 +0100
commit300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d (patch)
tree7031c060b72fb0e1b987720f7b09497ddb475f7b /app-admin/filebeat
parentmedia-sound/pragha: Bump to 1.3.4 (stable branch) (diff)
downloadgentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.tar.gz
gentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.tar.bz2
gentoo-300ff8928116d3b1d53b5abd70b37c1e1ca3aa5d.zip
app-admin/filebeat: revert stable version drop
This reverts commit 75f6acc429f35dfd5f9bc60711a399020ee0fea1. Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11262 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-admin/filebeat')
-rw-r--r--app-admin/filebeat/Manifest3
-rw-r--r--app-admin/filebeat/filebeat-6.3.2.ebuild66
-rw-r--r--app-admin/filebeat/filebeat-6.4.3.ebuild66
-rw-r--r--app-admin/filebeat/filebeat-6.5.4.ebuild66
4 files changed, 201 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 81d5c75e0828..9b1b56ee9515 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -1,2 +1,5 @@
DIST filebeat-5.6.13.tar.gz 18212575 BLAKE2B a0b8810523cecd1c6c87a69832c92b39fdc4cbe199eeae3c837f60b5057915e4d1ffb0fd371b3296cea398a11135b9d8da147451997514c85447722d086b8739 SHA512 fd572666858f1aeeede9e1b2074668d0bd691f58d51acd7955a3203b27d3ee850784a39e47941a570a833926a4109645eb98c24b49263276d1df475578c17efa
+DIST filebeat-6.3.2.tar.gz 20923316 BLAKE2B 70ac7e574f94a6141a7c6a1bd0af45ddbda3d01d6ea006c90ea341d2df03cac320d53496833cace3b394b9433251ea68a248dafdc8e28a85a6014314d5a2f3c4 SHA512 3d6ed03c9286bc7784444ad979b1398fcd70d870be184f912202ee5fab7c0ff23df639f445ec14cfcfd4d41ef648f33e88c2959f3c5f966fd3986884a223623a
+DIST filebeat-6.4.3.tar.gz 22085261 BLAKE2B 466580ba371d02bd0b51bd80f0e8d9766f2af1d371f88cd01144a648cd8d5488ca54447e925e9014790a836009d76be9eec9ef9b14a102287d3f4a71b852d20d SHA512 c28d9939c2082b586ddf744b4e18427096290987efd74f7ea03d2632a1cdcbc5dd2b043ee7ceeb0457098faeb52abbac57652077c518112fb65858954ee27f34
+DIST filebeat-6.5.4.tar.gz 25286147 BLAKE2B c3eca03c8e8e2b863918f3fe65bdea46b351739569f5570daac3e321963e98190331c5bf99c2451db5faa615620e023d2fd9c73060d4d775392a86a2f5578d80 SHA512 a48b9ae267ec80c1b45e4e07644f8080f8ba280da5c3543022b73472eb70de9d836cfffd387e576298becf9313d2cfa67d835158442f163b1a1bd0e72df31297
DIST filebeat-6.6.1.tar.gz 29108620 BLAKE2B 21dbe189dcf91efe6170574e3cff858cca4094936fbda54a343f66e61a5f0cd7d29e71d547c34ddd78776283d13e48926dd84925eed58ca07cc7bedf216c9064 SHA512 9c7646efa8aa44c2ae1cbcf85204749bc57491aad075d3ca283cd75a1b3a93d922169603407b2ea111e7e3abe0a43ce26fabccfe93d56a4232bd63e2b2e8b24a
diff --git a/app-admin/filebeat/filebeat-6.3.2.ebuild b/app-admin/filebeat/filebeat-6.3.2.ebuild
new file mode 100644
index 000000000000..1c9264bf6ec4
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.3.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.10.3"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}
diff --git a/app-admin/filebeat/filebeat-6.4.3.ebuild b/app-admin/filebeat/filebeat-6.4.3.ebuild
new file mode 100644
index 000000000000..8a81429845c7
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.4.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.10.3"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}
diff --git a/app-admin/filebeat/filebeat-6.5.4.ebuild b/app-admin/filebeat/filebeat-6.5.4.ebuild
new file mode 100644
index 000000000000..9c0c5d215f46
--- /dev/null
+++ b/app-admin/filebeat/filebeat-6.5.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.11.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+# Do not complain about CFLAGS etc since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_prepare() {
+ default
+
+ # avoid Elastic license
+ rm -r x-pack || die
+
+ # use ${PV} instead of git commit id
+ sed -i "s/\(COMMIT_ID=\).*/\1${PV}/g" "${S}/libbeat/scripts/Makefile" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT}/usr/share/doc/${PF}/examples"
+}