summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-10-22 16:15:42 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-10-22 16:15:42 +0200
commit774a00f0670ddee272754e864db2a4ee7acb3596 (patch)
treeeb2a59b6cc608623d22bfcecc9bba1d69cd8a5cc /app-admin/gkrellm
parentgames-rpg/arx-fatalis-demo: distfiles not DISTFILES (diff)
downloadgentoo-774a00f0670ddee272754e864db2a4ee7acb3596.tar.gz
gentoo-774a00f0670ddee272754e864db2a4ee7acb3596.tar.bz2
gentoo-774a00f0670ddee272754e864db2a4ee7acb3596.zip
app-admin/gkrellm: Fixed "gnutls" and "ssl" USE flag logic.
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-admin/gkrellm')
-rw-r--r--app-admin/gkrellm/gkrellm-2.3.10-r1.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/app-admin/gkrellm/gkrellm-2.3.10-r1.ebuild b/app-admin/gkrellm/gkrellm-2.3.10-r1.ebuild
index 0dea33e32b53..4b9dfe899015 100644
--- a/app-admin/gkrellm/gkrellm-2.3.10-r1.ebuild
+++ b/app-admin/gkrellm/gkrellm-2.3.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,9 +20,9 @@ IUSE="gnutls hddtemp libressl lm_sensors nls ntlm ssl kernel_FreeBSD X"
RDEPEND="
dev-libs/glib:2
hddtemp? ( app-admin/hddtemp )
- gnutls? ( net-libs/gnutls )
- !gnutls? (
- ssl? (
+ ssl? (
+ gnutls? ( net-libs/gnutls )
+ !gnutls? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
@@ -75,15 +75,6 @@ src_prepare() {
src_compile() {
if use X ; then
- local sslopt=""
- if use gnutls; then
- sslopt="without-ssl=yes"
- elif use ssl; then
- sslopt="without-gnutls=yes"
- else
- sslopt="without-ssl=yes without-gnutls=yes"
- fi
-
emake \
${TARGET} \
CC="$(tc-getCC)" \
@@ -94,7 +85,7 @@ src_compile() {
$(usex nls "" "enable_nls=0") \
$(usex lm_sensors "" "without-libsensors=yes") \
$(usex ntlm "" "without-ntlm=yes") \
- ${sslopt}
+ $(usex ssl $(usex gnutls 'without-ssl=yes' 'without-gnutls=yes') 'without-ssl=yes without-gnutls=yes')
else
cd server || die
emake \