summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/hardinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/hardinfo')
-rw-r--r--app-admin/hardinfo/Manifest1
-rw-r--r--app-admin/hardinfo/files/hardinfo-0.5.1-makefile.patch64
-rw-r--r--app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-build.patch53
-rw-r--r--app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-clang.patch24
-rw-r--r--app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-underlinking.patch16
-rw-r--r--app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild24
-rw-r--r--app-admin/hardinfo/metadata.xml7
7 files changed, 189 insertions, 0 deletions
diff --git a/app-admin/hardinfo/Manifest b/app-admin/hardinfo/Manifest
new file mode 100644
index 000000000000..89929f858ebd
--- /dev/null
+++ b/app-admin/hardinfo/Manifest
@@ -0,0 +1 @@
+DIST hardinfo-0.5.2_pre20130823.tar.xz 280472 SHA256 afebba2f2ff666577f5871bb34f43f8613163b264d3805b42d38bca59905b542 SHA512 e36bd4eec0090461de5fdb6c17dccf76937ee8fa9cb3411068fc568847f519023037999278bbb8b9a24608ed5b1d7fd2bebfe7115c631ccca1c35fa259cb20b1 WHIRLPOOL 416ef939f3747983f0736efb8cf317f19b4eee7489dea7caeff77782922b09b53442a6b08ec44357dfbe39cc552c7757b99365924b7b48ee92d780feffd3242f
diff --git a/app-admin/hardinfo/files/hardinfo-0.5.1-makefile.patch b/app-admin/hardinfo/files/hardinfo-0.5.1-makefile.patch
new file mode 100644
index 000000000000..d195c358d99b
--- /dev/null
+++ b/app-admin/hardinfo/files/hardinfo-0.5.1-makefile.patch
@@ -0,0 +1,64 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat May 26 01:30:39 UTC 2012
+Subject: build system
+
+respect CC and LDFLAGS
+
+--- Makefile.in
++++ Makefile.in
+@@ -1,8 +1,6 @@
+
+-CCFLAGS = -fPIC -pipe -Wall -g
+-CFLAGS = $(GTK_CFLAGS) $(SOUP_CFLAGS) -I.
+-CC = gcc $(ARCHOPTS) -g
+-CCSLOW = gcc -O0 -g
++CFLAGS+=-fPIC $(GTK_CFLAGS) $(SOUP_CFLAGS) -I.
++CC?=gcc
+
+ # ----------------------------------------------------------------------------
+
+@@ -14,35 +12,35 @@
+ MODULES = computer.so devices.so benchmark.so network.so
+
+ all: $(OBJECTS) $(MODULES)
+- $(CC) $(CCFLAGS) -o hardinfo -Wl,-export-dynamic $(OBJECTS) $(GTK_LIBS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o hardinfo -Wl,-export-dynamic $(OBJECTS) $(GTK_LIBS) \
+ $(SOUP_LIBS)
+
+ md5.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c md5.c -o $@
++ $(CC) $(CFLAGS) -c md5.c -o $@
+
+ blowfish.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c blowfish.c -o $@
++ $(CC) $(CFLAGS) -c blowfish.c -o $@
+
+ sha1.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c sha1.c -o $@
++ $(CC) $(CFLAGS) -c sha1.c -o $@
+
+ fbench.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c fbench.c -o $@
++ $(CC) $(CFLAGS) -c fbench.c -o $@
+
+ fftbench.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c fftbench.c -o $@
++ $(CC) $(CFLAGS) -c fftbench.c -o $@
+
+ nqueens.o:
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -c nqueens.c -o $@
++ $(CC) $(CFLAGS) -c nqueens.c -o $@
+
+ benchmark.so: benchmark.c
+ make $(BENCHMARK_OBJECTS)
+- $(CCSLOW) $(CCFLAGS) $(CFLAGS) -o $@ -shared $< $(BENCHMARK_OBJECTS) \
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -shared $< $(BENCHMARK_OBJECTS) \
+ $(GTK_FLAGS) $(GTK_LIBS)
+ ln -sf ../$@ modules
+
+ %.so: %.c
+- $(CC) $(CCFLAGS) $(CFLAGS) -o $@ -shared $< $(GTK_FLAGS) $(GTK_LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ -shared $< $(GTK_FLAGS) $(GTK_LIBS)
+ ln -sf ../$@ modules
+
+ clean:
diff --git a/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-build.patch b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-build.patch
new file mode 100644
index 000000000000..76718a38ebd8
--- /dev/null
+++ b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-build.patch
@@ -0,0 +1,53 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat May 26 01:30:39 UTC 2012
+Subject: build system
+
+use GNUInstallDirs and respect lib suffix
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -3,6 +3,8 @@
+
+ set(HARDINFO_VERSION "0.5.2pre")
+
++include(GNUInstallDirs)
++
+ if(${CMAKE_BUILD_TYPE} MATCHES "Debug")
+ set(HARDINFO_DEBUG 1)
+ endif()
+@@ -179,8 +181,8 @@
+ configure_file(hardinfo.desktop.cmake ${CMAKE_BINARY_DIR}/hardinfo.desktop @ONLY)
+
+ install(TARGETS hardinfo ${HARDINFO_MODULES}
+- RUNTIME DESTINATION bin
+- LIBRARY DESTINATION lib/hardinfo/modules
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/hardinfo/modules
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+ install(FILES ${CMAKE_BINARY_DIR}/hardinfo.desktop
+@@ -201,4 +203,4 @@
+ PATTERN "*.{hlp,png}"
+ PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ
+ )
+-
+\ No newline at end of file
++
+--- config.h.cmake
++++ config.h.cmake
+@@ -10,7 +10,7 @@
+ #define HOSTNAME ""
+ #define ARCH_@HARDINFO_ARCH@
+
+-#define LIBPREFIX "@CMAKE_INSTALL_PREFIX@/lib/hardinfo"
++#define LIBPREFIX "@CMAKE_INSTALL_PREFIX@/@CMAKE_INSTALL_LIBDIR@/hardinfo"
+ #define PREFIX "@CMAKE_INSTALL_PREFIX@/share/hardinfo"
+
+ #cmakedefine LIBSOUP_FOUND
+@@ -32,4 +32,4 @@
+ #define ENABLE_BINRELOC 1
+ #define HAS_LINUX_WE 1
+
+-#endif /* __CONFIG_H__ */
+\ No newline at end of file
++#endif /* __CONFIG_H__ */
diff --git a/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-clang.patch b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-clang.patch
new file mode 100644
index 000000000000..bc81290b2279
--- /dev/null
+++ b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-clang.patch
@@ -0,0 +1,24 @@
+https://github.com/lpereira/hardinfo/pull/6
+
+--- hardinfo-0.5.2_pre20120527/hardinfo/util.c
++++ hardinfo-0.5.2_pre20120527/hardinfo/util.c
+@@ -1368,7 +1368,7 @@
+ {
+ if (G_UNLIKELY(!_moreinfo)) {
+ DEBUG("moreinfo not initialized");
+- return;
++ return 0;
+ }
+
+ if (prefix) {
+--- hardinfo-0.5.2_pre20120527/CMakeLists.txt
++++ hardinfo-0.5.2_pre20120527/CMakeLists.txt
+@@ -43,6 +43,8 @@
+
+ message(STATUS "Building HardInfo for architecture: ${HARDINFO_OS}-${HARDINFO_ARCH}")
+
++add_definitions("-std=gnu89")
++
+ include(FindPkgConfig)
+ pkg_check_modules(GTK REQUIRED gtk+-2.0>=2.10 glib-2.0>=2.10 gthread-2.0>=2.10 gmodule-export-2.0>=2.10)
+ pkg_check_modules(LIBSOUP libsoup-2.4>=2.24)
diff --git a/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-underlinking.patch b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-underlinking.patch
new file mode 100644
index 000000000000..b726c5055939
--- /dev/null
+++ b/app-admin/hardinfo/files/hardinfo-0.5.2_pre20120527-underlinking.patch
@@ -0,0 +1,16 @@
+From: Slawomir Nizio <slawomir.nizio@sabayon.org>
+Date: Tue May 29 11:52:00 UTC 2012
+Subject: build system
+
+fix underlinking wrt https://bugs.gentoo.org/show_bug.cgi?id=418121
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -171,6 +171,7 @@
+ ${GTK_LIBRARIES}
+ ${LIBSOUP_LIBRARIES}
+ hardinfo-shell
++ m
+ )
+ target_link_libraries(hardinfo-shell
+ hardinfo-help-viewer
diff --git a/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild b/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild
new file mode 100644
index 000000000000..988e41a34418
--- /dev/null
+++ b/app-admin/hardinfo/hardinfo-0.5.2_pre20130823.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="A system information and benchmark tool for Linux systems"
+HOMEPAGE="http://hardinfo.berlios.de/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ net-libs/libsoup
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/app-admin/hardinfo/metadata.xml b/app-admin/hardinfo/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/app-admin/hardinfo/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>