summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-10-04 22:48:06 +0200
committerChema Alonso Josa <nimiux@gentoo.org>2017-10-04 22:48:06 +0200
commit23207c9e7edc2e79ba8675c5bfbe891611a785b3 (patch)
tree1c9a97fb5b143e8c3c26a42b7715235d6c8a4557 /app-admin/logrotate
parentdev-python/pychroot: version bump to 0.9.18 (diff)
downloadgentoo-23207c9e7edc2e79ba8675c5bfbe891611a785b3.tar.gz
gentoo-23207c9e7edc2e79ba8675c5bfbe891611a785b3.tar.bz2
gentoo-23207c9e7edc2e79ba8675c5bfbe891611a785b3.zip
app-admin/logrotate: Adds temporary directory for systemd
Gentoo-Bug: 357275 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-admin/logrotate')
-rw-r--r--app-admin/logrotate/files/logrotate.tmpfiles1
-rw-r--r--app-admin/logrotate/logrotate-3.12.3-r2.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/logrotate/files/logrotate.tmpfiles b/app-admin/logrotate/files/logrotate.tmpfiles
new file mode 100644
index 000000000000..dfb4ab66c132
--- /dev/null
+++ b/app-admin/logrotate/files/logrotate.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/misc
diff --git a/app-admin/logrotate/logrotate-3.12.3-r2.ebuild b/app-admin/logrotate/logrotate-3.12.3-r2.ebuild
new file mode 100644
index 000000000000..89ad370fbf17
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.12.3-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd
+
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="https://github.com/logrotate/logrotate"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="acl +cron selinux"
+
+CDEPEND="
+ >=dev-libs/popt-1.5
+ selinux? ( sys-libs/libselinux )
+ acl? ( virtual/acl )"
+
+DEPEND="${CDEPEND}
+ >=sys-apps/sed-4"
+
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-logrotate )
+ cron? ( virtual/cron )"
+
+STATEFILE="/var/lib/misc/logrotate.status"
+OLDSTATEFILE="/var/lib/logrotate.status"
+
+move_old_state_file() {
+ elog "logrotate state file is now located at ${STATEFILE}"
+ elog "See bug #357275"
+ if [[ -e "${OLDSTATEFILE}" ]] ; then
+ elog "Moving your current state file to new location: ${STATEFILE}"
+ mv -n "${OLDSTATEFILE}" "${STATEFILE}"
+ fi
+}
+
+install_cron_file() {
+ exeinto /etc/cron.daily
+ newexe "${S}"/examples/logrotate.cron "${PN}"
+}
+
+PATCHES=(
+ "${FILESDIR}/${P}-ignore-hidden.patch"
+ "${FILESDIR}/${P}-fbsd.patch"
+)
+
+src_prepare() {
+ default
+ sed -i -e 's#/usr/sbin/logrotate#/usr/bin/logrotate#' "${S}"/examples/logrotate.{cron,service} || die
+}
+
+src_configure() {
+ econf $(use_with acl) $(use_with selinux) --with-state-file-path="${STATEFILE}"
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ insinto /usr
+ dobin logrotate
+ doman logrotate.8
+ dodoc ChangeLog.md examples/logrotate-default
+
+ insinto /etc
+ doins "${FILESDIR}"/logrotate.conf
+
+ use cron && install_cron_file
+
+ systemd_dounit examples/logrotate.{service,timer}
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles" "${PN}".conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ elog "The ${PN} binary is now installed under /usr/bin. Please"
+ elog "update your links"
+ elog
+ move_old_state_file
+ elog
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you wish to have logrotate e-mail you updates, please"
+ elog "emerge virtual/mailx and configure logrotate in"
+ elog "/etc/logrotate.conf appropriately"
+ elog
+ elog "Additionally, /etc/logrotate.conf may need to be modified"
+ elog "for your particular needs. See man logrotate for details."
+ fi
+}