summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-16 07:18:19 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-16 07:23:17 +0200
commitd33cbe498e14a89d035543a747a7daabdeafcdeb (patch)
treef5402fa8c421b7cb89bb9b9934b217cd1e0e0500 /app-admin/puppet
parentdev-ruby/crass: add 1.0.5 (diff)
downloadgentoo-d33cbe498e14a89d035543a747a7daabdeafcdeb.tar.gz
gentoo-d33cbe498e14a89d035543a747a7daabdeafcdeb.tar.bz2
gentoo-d33cbe498e14a89d035543a747a7daabdeafcdeb.zip
app-admin/puppet: add 5.5.17
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-admin/puppet')
-rw-r--r--app-admin/puppet/Manifest1
-rw-r--r--app-admin/puppet/puppet-5.5.17.ebuild141
2 files changed, 142 insertions, 0 deletions
diff --git a/app-admin/puppet/Manifest b/app-admin/puppet/Manifest
index b378906c11ab..7f5e07ca1dce 100644
--- a/app-admin/puppet/Manifest
+++ b/app-admin/puppet/Manifest
@@ -1,6 +1,7 @@
DIST puppet-4.10.12.tar.gz 3022218 BLAKE2B 03757857868b1544078ae5e40d6e438631c788f1b01a3e62ba90e477b754601d2c085228e084363ff20ee39728b02ebe8ca83e17f7c79dddae1c3968aef4e320 SHA512 ff7accf70b1d4de7282cf3b41246151c49c4758a41ace56a470e4723749638027011cf170747e66fa5812280e1612e754e12d92dd35fa6c93171f7187bb9cfa2
DIST puppet-5.5.14.tar.gz 3075736 BLAKE2B bfea82d40f9671cdefab0b10c9481e4fbad397dd0a4aa26f5d0fa9ffa94477a5cc59b3724ab9ae3ee2e7e9230881676582c328c804ce9138dc484b9bd92e0ec3 SHA512 861100c02e0b8a5bb232d266bcd5e54b0e32cf26954ea37f276690aa3159ffdb28195ab8691df61ee0098300d226ea1d369dbdff8aae69101c2bbe6068ede8b1
DIST puppet-5.5.16.tar.gz 3084466 BLAKE2B f3e2f12331b4794b90a81a4f80e626fcd3d5252b7cbdacc1d6243faa557540d3a68e5e23b7b5c3e4f4286774e9a9198e59fb15d7d7c41d7193754ed5c80dd624 SHA512 7d9e533e352a22e347ac6467094c4bdbde893c2503f47b4a2d175fd6e759e6662991efdd1a0a83d9495d22f28da4ae7a30cc771c5d90b8252c4618bd8837833a
+DIST puppet-5.5.17.tar.gz 3090402 BLAKE2B 7722ec4196ee766c29eddd7dc73539a4a5a0e4cc781a84af25210488328b5ae01178ca64e8eef14152cbeca06dc8fe145b5e39ce6a120d7689fc32cbbbe16f9f SHA512 95c6cd836a9f732ccfe2d8b83096e79c32428c43390c0826663f896ca1388e1fe3b55d93a5a7548831e95de85247db717866c36786d591e207341c734d70168b
DIST puppet-6.10.0.tar.gz 2803541 BLAKE2B da122259341da54db8e9a6c3261934df5020164304bc493674d5164c0a11da1270746b41edb67c1d7c1f96b2553071c87ab2086f78b8184a1fab4dc3dbcc70fc SHA512 ff58d5898f34baa14363dc5c4f16eaa75b709b09cdb711662f3a74351d0abce85f3aa990057f296e208db8e559ecfa5ba9206ad5737aa64675e60c3e595747f5
DIST puppet-6.7.2.tar.gz 2907345 BLAKE2B bbb0f789ae64b5039e5b1bd2ce985e89ba693d33352baee7a1d11df7f314663aa3606a73d42d6b20042f81ee405a72cd17b9cf8f3c3cb257869e982f84cfd552 SHA512 6ebcaff30bda27fc17870b991287d620d455db8cf9a41c59833efc2a7541d3622228a7278689eb0494d0f6328cd334764f21ffe8700a567696e05398a5c16b7d
DIST puppet-6.8.0.tar.gz 2906582 BLAKE2B 2dd2f9eb203aa951e0ea9639efa20aac3edb063b4bd68dd0b05a07fc2a399c4b59b3b87a1cb573096c5042920080623b9afb9c4d863b6249664edcc291cd1787 SHA512 c8446529e706dab7fd156b5bbca638f1722b07a638f626df2002a4ad218ec5e448f533395a6eed613b31ebbacea56539e903c040998d4110c8a362f2ead7f43b
diff --git a/app-admin/puppet/puppet-5.5.17.ebuild b/app-admin/puppet/puppet-5.5.17.ebuild
new file mode 100644
index 000000000000..83d26aad2806
--- /dev/null
+++ b/app-admin/puppet/puppet-5.5.17.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="doc:all"
+
+RUBY_FAKEGEM_EXTRAINSTALL="locales"
+
+inherit eutils user ruby-fakegem eapi7-ver
+
+DESCRIPTION="A system automation and configuration management software."
+HOMEPAGE="https://puppet.com/"
+SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-ruby/hiera
+ dev-ruby/json:=
+ >=dev-ruby/facter-3.0.0
+ augeas? ( dev-ruby/ruby-augeas )
+ diff? ( dev-ruby/diff-lcs )
+ doc? ( dev-ruby/rdoc )
+ ldap? ( dev-ruby/ruby-ldap )
+ shadow? ( dev-ruby/ruby-shadow )
+ sqlite? ( dev-ruby/sqlite3 )
+ virtual/ruby-ssl
+ dev-ruby/hocon"
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? (
+ dev-ruby/mocha
+ dev-ruby/rack
+ dev-ruby/rspec-its
+ )"
+# this should go in the above lists, but isn't because of test deps not being keyworded
+# dev-ruby/rspec-collection_matchers
+
+RDEPEND+=" ${RDEPEND}
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ vim-syntax? ( >=app-vim/puppet-syntax-3.0.1 )
+ >=app-portage/eix-0.18.0"
+PDEPEND="emacs? ( >=app-emacs/puppet-mode-0.3-r1 )"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+all_ruby_prepare() {
+ # Avoid spec that require unpackaged json-schema.
+ rm spec/lib/matchers/json.rb $( grep -Rl matchers/json spec) || die
+
+ # fix systemd path
+ epatch "${FILESDIR}/puppet-systemd.patch"
+
+ # Avoid specs that can only run in the puppet.git repository. This
+ # should be narrowed down to the specific specs.
+ rm spec/integration/parser/compiler_spec.rb || die
+
+ # Avoid failing spec that need further investigation.
+ rm spec/unit/module_tool/metadata_spec.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+# dosym "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${P}" "/usr/$(get_libdir)/ruby/gems/$(ruby_get_version)/gems/${PN}"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # systemd stuffs
+ insinto /usr/lib/systemd/system
+ doins "${WORKDIR}/all/${P}/ext/systemd/puppet.service"
+
+ # tmpfiles stuff
+ insinto /usr/lib/tmpfiles.d
+ newins "${FILESDIR}/tmpfiles.d" "puppet.conf"
+
+ # openrc init stuff
+ newinitd "${FILESDIR}"/puppet.init-4.x puppet
+ newinitd "${FILESDIR}"/puppetmaster.init-4.x puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster.confd puppetmaster
+
+ keepdir /etc/puppetlabs/puppet/ssl
+
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/lib/puppet
+
+ fperms 0750 /var/lib/puppet
+
+ fperms 0750 /etc/puppetlabs
+ fperms 0750 /etc/puppetlabs/puppet
+ fperms 0750 /etc/puppetlabs/puppet/ssl
+ fowners -R :puppet /etc/puppetlabs
+ fowners -R :puppet /var/lib/puppet
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Portage Puppet module with Gentoo-specific resources:"
+ elog "http://forge.puppetlabs.com/gentoo/portage"
+ elog
+
+ for v in ${REPLACING_VERSIONS}; do
+ if [ "$(ver_cut 1 "$v")" -eq "4" ]; then
+ elog
+ elog "Please see the following url for the release notes for puppet-5"
+ elog "https://docs.puppet.com/puppet/5.0/release_notes.html#if-youre-upgrading-from-puppet-4x"
+ elog
+ fi
+ done
+}