summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2019-11-02 09:09:21 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-02 16:22:30 +0100
commit8829d1fb717f7e00f5166eeb3e6c4be62778e7ef (patch)
treef636a295da9662eb62c22c90f7234916dccd83f9 /app-admin/qtpass
parentdev-libs/liborcus: Add missing USEDEP on dev-libs/boost[zlib] (diff)
downloadgentoo-8829d1fb717f7e00f5166eeb3e6c4be62778e7ef.tar.gz
gentoo-8829d1fb717f7e00f5166eeb3e6c4be62778e7ef.tar.bz2
gentoo-8829d1fb717f7e00f5166eeb3e6c4be62778e7ef.zip
app-admin/qtpass: version bump to 1.3.2
Closes: https://bugs.gentoo.org/693786 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/13164 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-admin/qtpass')
-rw-r--r--app-admin/qtpass/Manifest1
-rw-r--r--app-admin/qtpass/qtpass-1.3.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/qtpass/Manifest b/app-admin/qtpass/Manifest
index c4ccd3f65172..671e5ebd0980 100644
--- a/app-admin/qtpass/Manifest
+++ b/app-admin/qtpass/Manifest
@@ -1 +1,2 @@
DIST qtpass-1.2.3.tar.gz 369412 BLAKE2B 55e8f5e7967b264b20aa044979620631f319e2ff38edcc4e1390ab5d9f35e1e90ff8ff00c94cd35a9b5c05a5ccd8d8fdfc97214e9bd9f564bae1bd80efe0f224 SHA512 d6c3af5b92042a38afecb40689d41c08105dd2a39555f78ebc585a6db6dd65cd8fd6dc637542dd3b5b4ce18f1a852768ffa298b5a461a2d0e4ef4950c58d1649
+DIST qtpass-1.3.2.tar.gz 310316 BLAKE2B ac0f562fd263e9d46980a69183cfd556596750e1050dbc50748cd9be45bc4bf39e4de14cb59f778cfc54f5c32050d567d88d65ec039cba1e9c2e8ef24d7ae99a SHA512 9026f74f6ff75fcef2f6a0862484a2a1eaed1370edd0659e8b4d20039affe846e0da3a0a26a804563813bc678638ab67fa516441208e70c7e9de9b2eda876a10
diff --git a/app-admin/qtpass/qtpass-1.3.2.ebuild b/app-admin/qtpass/qtpass-1.3.2.ebuild
new file mode 100644
index 000000000000..ceb54ec6b63c
--- /dev/null
+++ b/app-admin/qtpass/qtpass-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+SRC_URI="https://github.com/IJHack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="app-admin/pass
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ net-misc/x11-ssh-askpass"
+DEPEND="${RDEPEND}
+ dev-qt/qtsvg:5
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="dev-qt/linguist-tools:5"
+
+S="${WORKDIR}/QtPass-${PV}"
+
+DOCS=( {CHANGELOG,CONTRIBUTING,FAQ,README}.md )
+
+src_prepare() {
+ default
+
+ if ! use test ; then
+ sed -i '/SUBDIRS += src /s/tests //' \
+ qtpass.pro || die "sed for qtpass.pro failed"
+ fi
+}
+
+src_configure() {
+ eqmake5 PREFIX="${D}"/usr
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/"${PN}"/translations
+ doins localization/*.qm
+
+ doman "${PN}".1
+ domenu "${PN}".desktop
+ newicon artwork/icon.png "${PN}"-icon.png
+ insinto /usr/share/appdata
+ doins qtpass.appdata.xml
+}