summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-06-01 16:19:26 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-06-01 16:19:48 +0200
commit7ce43d2ae8bd68ae2c5f6964b26817851ed53cd1 (patch)
tree9f1e5d00550e975f4b39df798ec8ec54458f257e /app-admin/rsyslog
parentapp-misc/colordiff: Removed old. (diff)
downloadgentoo-7ce43d2ae8bd68ae2c5f6964b26817851ed53cd1.tar.gz
gentoo-7ce43d2ae8bd68ae2c5f6964b26817851ed53cd1.tar.bz2
gentoo-7ce43d2ae8bd68ae2c5f6964b26817851ed53cd1.zip
app-admin/rsyslog: Rev bump to fix hostname detection without network
See https://github.com/rsyslog/rsyslog/pull/1595 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'app-admin/rsyslog')
-rw-r--r--app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch27
-rw-r--r--app-admin/rsyslog/rsyslog-8.27.0-r1.ebuild (renamed from app-admin/rsyslog/rsyslog-8.27.0.ebuild)1
2 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch
new file mode 100644
index 000000000000..a9470ccf4b60
--- /dev/null
+++ b/app-admin/rsyslog/files/8-stable/rsyslog-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch
@@ -0,0 +1,27 @@
+From 1a7d3a088969b47798bc1da712ca2772f91a7c02 Mon Sep 17 00:00:00 2001
+From: Jiri Vymazal <jvymazal@redhat.com>
+Date: Wed, 31 May 2017 16:26:56 +0200
+Subject: [PATCH] Ignoring NONAME error from getaddrinfo so we have hostname
+ set even without working network
+
+---
+ runtime/net.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/runtime/net.c b/runtime/net.c
+index 2d8de9429..edffc677a 100644
+--- a/runtime/net.c
++++ b/runtime/net.c
+@@ -1188,7 +1188,11 @@ getLocalHostname(uchar **ppName)
+ memset(&flags, 0, sizeof(flags));
+ flags.ai_flags = AI_CANONNAME;
+ int error = getaddrinfo((char*)hnbuf, NULL, &flags, &res);
+- if (error != 0) {
++ if (error != 0 &&
++ error != EAI_NONAME && error != EAI_AGAIN && error != EAI_FAIL) {
++ /* If we get one of errors above, network is probably
++ * not working yet, so we fall back to local hostname below
++ */
+ dbgprintf("getaddrinfo: %s\n", gai_strerror(error));
+ ABORT_FINALIZE(RS_RET_IO_ERROR);
+ }
diff --git a/app-admin/rsyslog/rsyslog-8.27.0.ebuild b/app-admin/rsyslog/rsyslog-8.27.0-r1.ebuild
index ef11286bd709..c1791672bd3b 100644
--- a/app-admin/rsyslog/rsyslog-8.27.0.ebuild
+++ b/app-admin/rsyslog/rsyslog-8.27.0-r1.ebuild
@@ -56,6 +56,7 @@ else
PATCHES=(
"${FILESDIR}"/8-stable/${PN}-8.26.0-fix-zmq3-format-security.patch
"${FILESDIR}"/8-stable/${PN}-8.27.0-fix-librdkafka-detection.patch
+ "${FILESDIR}"/8-stable/${PN}-8.27.0-fix-hostname-detection-when-getaddrinfo-fails.patch
)
fi