summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-02 14:03:29 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-02 14:03:53 +0100
commite4233701c2ca8f6c4665ee40b41c86028af968e5 (patch)
treee30522e2d33045bc3fbe22d48fca2f9d8f9e5fc9 /app-admin/sshguard
parentapp-admin/sshguard: Version 2.3.1 (diff)
downloadgentoo-e4233701c2ca8f6c4665ee40b41c86028af968e5.tar.gz
gentoo-e4233701c2ca8f6c4665ee40b41c86028af968e5.tar.bz2
gentoo-e4233701c2ca8f6c4665ee40b41c86028af968e5.zip
app-admin/sshguard: Add live ebuild
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-admin/sshguard')
-rw-r--r--app-admin/sshguard/sshguard-99999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/sshguard/sshguard-99999.ebuild b/app-admin/sshguard/sshguard-99999.ebuild
new file mode 100644
index 000000000000..407363556f81
--- /dev/null
+++ b/app-admin/sshguard/sshguard-99999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="https://www.sshguard.net/"
+EGIT_REPO_URI="https://bitbucket.org/${PN}/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ sys-devel/flex
+"
+RDEPEND="
+ virtual/logger
+"
+DOCS=(
+ CHANGELOG.rst
+ CONTRIBUTING.rst
+ README.rst
+ examples/net.sshguard.plist
+ examples/sshguard.service
+ examples/whitelistfile.example
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-conf.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+
+ insinto /etc
+ newins examples/sshguard.conf.sample sshguard.conf
+}