summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-04-18 17:03:52 +0200
committerLouis Sautier <sbraz@gentoo.org>2019-04-19 13:10:10 +0200
commitd61eb76b3d2df3464a64ffd2ffe7e9c11423257f (patch)
treec7f9cb0842043a4dbc062d9daf40100c0e7bc28f /app-admin/supervisor
parentmedia-sound/soundconverter: bump to 3.0.2 (diff)
downloadgentoo-d61eb76b3d2df3464a64ffd2ffe7e9c11423257f.tar.gz
gentoo-d61eb76b3d2df3464a64ffd2ffe7e9c11423257f.tar.bz2
gentoo-d61eb76b3d2df3464a64ffd2ffe7e9c11423257f.zip
app-admin/supervisor: bump to 4.0.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest1
-rw-r--r--app-admin/supervisor/supervisor-4.0.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index 6c0decbd30f1..e2d78cb2b314 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -2,3 +2,4 @@ DIST supervisor-3.1.4.tar.gz 392321 BLAKE2B 316789fae200f02242a90d3a22a3c6486576
DIST supervisor-3.3.5.tar.gz 421220 BLAKE2B 63e9db005596921c4a4426de361fc20992a27b67b67ee1256cd64fe6d385909682a5055e4797512410f36f6855592f53c9c5720c54a2dae967578691d05ff3fc SHA512 66c43d40c216e5c3120e083407c848295fa1e59d6d9da916a4bae5c37d4d13208c3bf7c0c8b8a5d570270eb44fac0b1bbcceddb2e84e4f3fc1b6241b43116af7
DIST supervisor-4.0.0.tar.gz 432825 BLAKE2B 2eca01119f6bfd6bea728ea297424e6e08cc94cc8da78e53fc431013b83b5620a8c88f1a6ef0fcf5f57df46ad43f04215425bede83c02479731795b326dd27c4 SHA512 cca945179aaa16cd7042160b44a2d80e4a6aa388dcabd1572c6ed8610dc6af06cb446a18a5f8fa868a891482032380bf176c1331d9d09702d59fbf8b01651577
DIST supervisor-4.0.1.tar.gz 433742 BLAKE2B dc0683566c9b052c6a832e09eb6eba76890f07f5b67a1c129343ed3de31e5dc88777cfcb1b3c06a6a687160c172c3d83227765678c9c54239fbe57eb9b5ebd0a SHA512 e2e0e92ef1dba74ea4e3e70c2bd56b8a497d22db8123411f4f2019b45626606e90030577ae79aa8b81103c2f337c76d7516f94bb01e97172e2e541ec44d0f1b9
+DIST supervisor-4.0.2.tar.gz 434408 BLAKE2B 567e680c4b350e94c10be28ab25a16392a10f904fbc453c4d59132bb9e284b47e723834d5a34d803f4e54d5d17ce84b3e7e275d7f884c4d0e3ee05d50470008a SHA512 662bc1052276c2f54e0eeae820f9ae53e7f37150db21f0547be74b90455e213c9ca2b21e07079f1bd1740fae6e3d664edd3d27d57a0128828fc1a9c3627b3189
diff --git a/app-admin/supervisor/supervisor-4.0.2.ebuild b/app-admin/supervisor/supervisor-4.0.2.ebuild
new file mode 100644
index 000000000000..2741d256322a
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.0.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd user
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/meld3-1.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/.build/html/. )
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ enewgroup supervisor
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT%/}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT%/}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}