summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-21 14:29:55 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-21 14:29:55 +0200
commitc9e26e4d1925db16a035fac109214084271bf505 (patch)
tree310ce8011714e0e168b7690561ebab75287380ca /app-admin/sysstat
parentnet-libs/mbedtls: Stable for HPPA (bug #583394). (diff)
downloadgentoo-c9e26e4d1925db16a035fac109214084271bf505.tar.gz
gentoo-c9e26e4d1925db16a035fac109214084271bf505.tar.bz2
gentoo-c9e26e4d1925db16a035fac109214084271bf505.zip
app-admin/sysstat: Drop USE=doc as it now only controls man page installation (bug #585702 by latenite).
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-admin/sysstat')
-rw-r--r--app-admin/sysstat/sysstat-11.2.4-r1.ebuild93
-rw-r--r--app-admin/sysstat/sysstat-11.3.4-r1.ebuild93
2 files changed, 186 insertions, 0 deletions
diff --git a/app-admin/sysstat/sysstat-11.2.4-r1.ebuild b/app-admin/sysstat/sysstat-11.2.4-r1.ebuild
new file mode 100644
index 000000000000..a1c286d81563
--- /dev/null
+++ b/app-admin/sysstat/sysstat-11.2.4-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="debug isag nls lm_sensors selinux static"
+
+CDEPEND="
+ isag? (
+ dev-lang/tk:0
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-sysstat )
+"
+
+SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i nls/
+ local lingua pofile
+ for pofile in nls/*.po; do
+ lingua=${pofile/nls\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm "nls/${lingua}.po" || die
+ fi
+ done
+ fi
+ epatch \
+ "${FILESDIR}"/${PN}-10.0.4-flags.patch \
+ "${FILESDIR}"/${PN}-11.0.4-cron.patch
+}
+
+src_configure() {
+ tc-export AR
+ use static && append-ldflags -static
+
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ conf_dir=/etc \
+ rcdir=${SYSSTAT_FAKE_RC_DIR} \
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable isag install-isag) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nls) \
+ --enable-copy-only \
+ --enable-documentation \
+ --enable-install-cron \
+ --with-systemdsystemunitdir=$(systemd_get_unitdir)
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ emake \
+ CHOWN=true \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ MANGRPARG='' \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ systemd_dounit ${PN}.service
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}
diff --git a/app-admin/sysstat/sysstat-11.3.4-r1.ebuild b/app-admin/sysstat/sysstat-11.3.4-r1.ebuild
new file mode 100644
index 000000000000..ed3556368ccd
--- /dev/null
+++ b/app-admin/sysstat/sysstat-11.3.4-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic multilib systemd toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug isag nls lm_sensors selinux static"
+
+CDEPEND="
+ isag? (
+ dev-lang/tk:0
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="
+ ${CDEPEND}
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-sysstat )
+"
+
+SYSSTAT_FAKE_RC_DIR=Gentoo-does-not-use-rc.d
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i nls/
+ local lingua pofile
+ for pofile in nls/*.po; do
+ lingua=${pofile/nls\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm "nls/${lingua}.po" || die
+ fi
+ done
+ fi
+ epatch \
+ "${FILESDIR}"/${PN}-10.0.4-flags.patch \
+ "${FILESDIR}"/${PN}-11.0.4-cron.patch
+}
+
+src_configure() {
+ tc-export AR
+ use static && append-ldflags -static
+
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ conf_dir=/etc \
+ rcdir=${SYSSTAT_FAKE_RC_DIR} \
+ econf \
+ $(use_enable debug debuginfo) \
+ $(use_enable isag install-isag) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nls) \
+ --enable-copy-only \
+ --enable-documentation \
+ --enable-install-cron \
+ --with-systemdsystemunitdir=$(systemd_get_unitdir)
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ emake \
+ CHOWN=true \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ MANGRPARG='' \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ rm -r "${D}/${SYSSTAT_FAKE_RC_DIR}" || die
+ newinitd "${FILESDIR}"/${PN}.init.d ${PN}
+ systemd_dounit ${PN}.service
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}