summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-04 08:41:43 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-04 09:44:29 +0100
commit75ca4770f0093e0474200b575b5e62636d984904 (patch)
tree1b95d28944b0fb349f6f84943add11ebe120a955 /app-admin/systemrescuecd-x86
parentmedia-sound/grip: Removed old. (diff)
downloadgentoo-75ca4770f0093e0474200b575b5e62636d984904.tar.gz
gentoo-75ca4770f0093e0474200b575b5e62636d984904.tar.bz2
gentoo-75ca4770f0093e0474200b575b5e62636d984904.zip
app-admin/systemrescuecd-x86: Bump to 5.2.0
Diffstat (limited to 'app-admin/systemrescuecd-x86')
-rw-r--r--app-admin/systemrescuecd-x86/Manifest1
-rw-r--r--app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/systemrescuecd-x86/Manifest b/app-admin/systemrescuecd-x86/Manifest
index b4379744b417..af6ffa277451 100644
--- a/app-admin/systemrescuecd-x86/Manifest
+++ b/app-admin/systemrescuecd-x86/Manifest
@@ -29,3 +29,4 @@ DIST systemrescuecd-x86-5.0.4.iso 501141504 BLAKE2B 01acafdb8e7ac8343f0e30ed7be7
DIST systemrescuecd-x86-5.1.0.iso 505047040 BLAKE2B 3653bdd2733cfe214275ab8d3a95a1cab142f72a12da7fa7f76af8faa1801a1ab4da74493efeb2e1b759e871b1ddf8a847825a4f37ae6c3b009fd90e4dcfdd4b SHA512 15d019bbb91019f1b6d1847fc786e6c02f3f768826241e0823842bca9745ff1fa48fe7d32828f899b90845b2f4ce948a1f98e093edf8ca4c0c39cc0da72b4aa8
DIST systemrescuecd-x86-5.1.1.iso 517359616 BLAKE2B f139a521076f0345a65bddfd999f7dd4479a9fd26e3621f2c419804228922af53f2e6d99a97919db0041e4199a95ea745d674a7b0a61f86dc5d9e10ff562d314 SHA512 a4063305da50ea8b73fb7157f46bf386b80d3ef777adabdcdd944814c801d078fe63778f166b80788b0851549b35bf6ada5940ca5a40a6c1a3e0f4c66efbea91
DIST systemrescuecd-x86-5.1.2.iso 523479040 BLAKE2B abf6f1e3e05e382b48dcfd4ecde9f70896462418cf36057e3a42dc2366e0b56133deeb6f00363d15d94238c22fb8ac5c88b57ca6c213c9dcc299fa04def5e2cd SHA512 516e60632459dd5408f83035aa265ed4169b13f978a23960a85837c9c8b5bbab70776e22a6e6727184bd9df81cbbeff4a5819d5927ff0ff3a79036bc4c54cfdc
+DIST systemrescuecd-x86-5.2.0.iso 569669632 BLAKE2B fe31a68df650b46bd875b91c643c8f1daaa60042ea6c59ac452bb99a2792dcdcee62f1b60c329a70c95689af22c1a0fc52a966631af347258d665f55d2f6d8c0 SHA512 42da80a419aa27bea891339dc163a62bff8ba34d74c202a7fd0317592e8870a71ddc7fa9e9ded5e9d2f75dc36ec8417673074ffde60ea472815405456e34876c
diff --git a/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild
new file mode 100644
index 000000000000..7bfc35a7dd27
--- /dev/null
+++ b/app-admin/systemrescuecd-x86/systemrescuecd-x86-5.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="The .iso image of SystemRescueCD rescue disk, x86 (+ amd64) variant"
+HOMEPAGE="http://www.sysresccd.org/"
+# Large ISO mirroring explicitly approved by infra in bug #588766
+SRC_URI="mirror://sourceforge/systemrescuecd/sysresccd-${PN#*-}/${PV}/${P}.iso"
+
+LICENSE="GPL-2"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+isohybrid"
+
+DEPEND="isohybrid? ( >=sys-boot/syslinux-4 )"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${P}.iso"
+
+ if use isohybrid; then
+ set -- isohybrid -u "${ED}usr/share/${PN%-*}/${P}.iso"
+ echo "${@}"
+ "${@}" || die "${*} failed"
+ fi
+}
+
+pkg_postinst() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${P}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT%/}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}