summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2017-09-22 09:24:26 +0200
committerUltrabug <ultrabug@gentoo.org>2017-10-13 10:33:04 +0200
commit02300643eca8f1e5c46b28f79006746ac9644ffe (patch)
treeac1ca8f8ec46be848bed010383b61183bd03f12f /app-admin
parentmedia-gfx/exiv2: Add 0.26_p20171013 snapshot (diff)
downloadgentoo-02300643eca8f1e5c46b28f79006746ac9644ffe.tar.gz
gentoo-02300643eca8f1e5c46b28f79006746ac9644ffe.tar.bz2
gentoo-02300643eca8f1e5c46b28f79006746ac9644ffe.zip
app-admin/mongo-tools: bump to 3.4.9
Package-Manager: Portage-2.3.10, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5763
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.4.9.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 2fe3ee553d6c..05c4c4bc3039 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -7,3 +7,4 @@ DIST mongo-tools-3.4.3.tar.gz 4700637 SHA256 70348800ca4cc04a319ca414291d5359e7d
DIST mongo-tools-3.4.4.tar.gz 4700326 SHA256 d14f4ce153aec373459c802e5a159661ccfde4e5df39d8d750586bae54896cdd SHA512 d49243e41bf3144264add3766a6f7016a07509a583a7368a639d85d2305500dd5afcfbc4449f3dcc8bec6e88bfb76ce021c813fe14169e3bd2476ed0db7c2d5d WHIRLPOOL 33cb527ce7df19e92871219aef9b38f16ae292a4d1cbdd7bb3a1c6ccc752687469b9e4309cc4fd540a65e623740e1ebe20f4bdf8629b50aab25d4ea84c2988cc
DIST mongo-tools-3.4.6.tar.gz 4715189 SHA256 0b41ee2cb0a3d656f50ad950cc3853b41d5eb77a67ea0eb288f5ac80711ffc1d SHA512 ad1d3acee1969934e8f679d6407b3b55aba85fb99ea806463b7418494fac491ff68033f3e59b55e17276a4d28932c6b74398fffc89ab7c229cf69e5a4714c4a2 WHIRLPOOL 993be475af7b71a189f2b9f7c98e3f49d7ae8d05f99928b242efbd3dd504415394c7c812c4debed192ca0a856f16f9839dc771be8efb1db48b3359e48ea48280
DIST mongo-tools-3.4.7.tar.gz 4719398 SHA256 8ff8c790108d3b858bb188f4cd45aedf3a1a9eddf3bd3f69627ecb35a0de2fb4 SHA512 974062e934ff2004c2ec1b55398a04dce542542c122577326e6120154e4887dcc772fa90b0ea5e7bc57124526bbb76b8935efa75080fed78da6c252e3e599f3f WHIRLPOOL 67a8e1ece75b1371df8da60780eb71db1f039912baa2f66d7cf0c79e863f5ce74a27131f1978578cebf47c3de66a5c9ef8227ce19d3a23effa40da05136ad3e4
+DIST mongo-tools-3.4.9.tar.gz 4719526 SHA256 4b6f17afa628482c107567a82715b780d1e885125b4862ee07e0ab5080b8e0aa SHA512 546060a65124e722a1c6eb152fd4e086bc523656312888e16238b4a1df5313ab63ece41e638f012676af4be94ed156855b053afa62d778f72cd31f0ccd70f19d WHIRLPOOL 5707db723a3e502749f052d3825d5aba6bdc0ecf0d93f7f156285b2dee1196741baab4c4cabaad01eb156ad15e05b96d1dde23c24e543d17d99a7533ca80dee2
diff --git a/app-admin/mongo-tools/mongo-tools-3.4.9.ebuild b/app-admin/mongo-tools/mongo-tools-3.4.9.ebuild
new file mode 100644
index 000000000000..648cbb9ac1e0
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.4.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl libressl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # do not substitute version because it uses git
+ sed -i '/^sed/,+3d' build.sh || die
+ sed -i '/^mv/d' build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+
+ # ensure we use bash wrt #582906
+ sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+
+ default
+}
+
+src_compile() {
+ declare -a myconf
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}