summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-09-19 10:39:34 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-09-19 11:03:55 -0500
commit04ea965f3d84cd10f2bcdddb8cd9787e2834edcd (patch)
tree4327131c2066c5a3776c7347bb5e3b7160b32158 /app-admin
parentapp-admin/puppetserver: 6.0.0 bump (diff)
downloadgentoo-04ea965f3d84cd10f2bcdddb8cd9787e2834edcd.tar.gz
gentoo-04ea965f3d84cd10f2bcdddb8cd9787e2834edcd.tar.bz2
gentoo-04ea965f3d84cd10f2bcdddb8cd9787e2834edcd.zip
app-admin/puppet-agent: 6.0.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet-agent/Manifest2
-rw-r--r--app-admin/puppet-agent/puppet-agent-6.0.0.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/puppet-agent/Manifest b/app-admin/puppet-agent/Manifest
index e0951a8796ff..2acefe7bf59d 100644
--- a/app-admin/puppet-agent/Manifest
+++ b/app-admin/puppet-agent/Manifest
@@ -6,3 +6,5 @@ DIST puppet-agent_5.5.4-1stretch_amd64.deb 17273314 BLAKE2B e296cda8219deafe9b36
DIST puppet-agent_5.5.4-1stretch_i386.deb 18195740 BLAKE2B aa1e5b7030de4ec58a389a552c0d2c870875244f6a722c9b87d4aca28261f073b347476aaa313edd4f66fa07621a333c777a3a6b04228aa7d2f35391f4f84df8 SHA512 3e7346ccde7d3bc9e99bb38a2958c9ddda3dd4a5124ced21dc048df41566a0d9e6d9e5250f7c93433c02585fd83031292f8197a7c6537a1563dd6ebec464b979
DIST puppet-agent_5.5.6-1stretch_amd64.deb 17279588 BLAKE2B d9614ee1cbec786303ac72fc9b704c90056771c9e3c23a93d6b7cff11f27394fbd277d5ae0d8eca20d9801d31019e7ca381af0cb60b72fc109ce6b2a99ee1124 SHA512 1172d72a1054cf04ab8033ab319313b7da6fd76684738bdb4aa1bc6bd9fa9dc0f2b00d765382023e0e854efbee6adba5b66bd62e2e04a9f153da79bccad427f7
DIST puppet-agent_5.5.6-1stretch_i386.deb 18195950 BLAKE2B 602a8409a6f0b5695f389604f82b8d6401db5d8abdd7148418bab6f09d64b285ff1c43870b144e863f148993b2e02c1abe11827e3e29ad5cf1314d7030cd5988 SHA512 f96bd2f4cbb2cec2405fdf87bb61711f8a750462d15e65507d37cc6cf6fa8f3a5e3a3d66abc74cfc02a109cc17c413e7f32c8d5f179468c84f6a86452ae38c40
+DIST puppet-agent_6.0.0-1stretch_amd64.deb 17853440 BLAKE2B 8d361b7e9412a3410fb0863364db174639d1664c83eae67c188bb0f522c2944f048b9d41e9a5e5e3db281669ebca152fe49f174dda4be29d42b964a7955ccfe4 SHA512 8e6d50b6d3eff9179fcf915cbc483ea679b1edb236aed148aff92ccae4f915caf79459f346e2823fb03372997f10a6585206ea97260577704ede28f82a3761b1
+DIST puppet-agent_6.0.0-1stretch_i386.deb 18591732 BLAKE2B 89cad6275d1ef3cafa4e3794c3104d66dcb9ce450c31694e648aecc8d31d839b96ccc9f83fae4f2ee188387d058996b14961a2c6d9244fb71cfafc3cf1aa841c SHA512 85f9a313a9a1320e5a08d20ffc8e1de0e60336534ad5ffcc34581f34b9a2e68636a8c326001bc25209c2c530feb3ce08a86a1e7cbde143882a97103f09591af4
diff --git a/app-admin/puppet-agent/puppet-agent-6.0.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.0.0.ebuild
new file mode 100644
index 000000000000..1756e5e64ce7
--- /dev/null
+++ b/app-admin/puppet-agent/puppet-agent-6.0.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils systemd unpacker user
+
+DESCRIPTION="general puppet client utils along with hiera and facter"
+HOMEPAGE="https://puppetlabs.com/"
+SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
+SRC_URI="
+ amd64? ( ${SRC_BASE}_amd64.deb )
+ x86? ( ${SRC_BASE}_i386.deb )"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="puppetdb selinux"
+RESTRICT="strip"
+
+CDEPEND="!app-admin/augeas
+ !app-admin/puppet
+ !dev-ruby/hiera
+ !dev-ruby/facter
+ !app-emulation/virt-what"
+
+DEPEND="
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ app-portage/eix
+ sys-apps/dmidecode
+ sys-libs/glibc
+ sys-libs/readline:0/7
+ sys-libs/ncurses:0[tinfo]
+ selinux? (
+ sys-libs/libselinux[ruby]
+ sec-policy/selinux-puppet
+ )
+ puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/run/puppet puppet
+}
+
+src_install() {
+ # conf.d
+ doconfd etc/default/puppet
+ doconfd etc/default/pxp-agent
+ # logrotate.d
+ insinto /etc/logrotate.d
+ doins etc/logrotate.d/pxp-agent
+ # puppet itself
+ insinto /etc/puppetlabs
+ doins -r etc/puppetlabs/*
+ # logdir for systemd
+ dodir var/log/puppetlabs/puppet/
+ fperms 0750 var/log/puppetlabs/puppet/
+ # the rest
+ insinto /opt
+ dodir opt/puppetlabs/puppet/cache
+ doins -r opt/*
+ fperms 0750 /opt/puppetlabs/puppet/cache
+ # init
+ newinitd "${FILESDIR}/puppet.initd" puppet
+ systemd_dounit lib/systemd/system/puppet.service
+ systemd_dounit lib/systemd/system/pxp-agent.service
+ systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
+ # symlinks
+ chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
+ chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
+ dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
+ dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
+ dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
+ dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
+ dosym ../../opt/puppetlabs/puppet/bin/augparse /usr/bin/augparse
+ dosym ../../opt/puppetlabs/puppet/bin/augtool /usr/bin/augtool
+}