summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-07-29 09:39:39 +0100
committerMarek Szuba <marecki@gentoo.org>2022-07-29 09:43:25 +0100
commit2f94817ec93094f0ffb3e406d9560b724bbccae6 (patch)
tree8a73709a4953e0595c75eb28d9c2cffcfd1d0b18 /app-admin
parentapp-admin/chrpath: update EAPI 7 -> 8 (diff)
downloadgentoo-2f94817ec93094f0ffb3e406d9560b724bbccae6.tar.gz
gentoo-2f94817ec93094f0ffb3e406d9560b724bbccae6.tar.bz2
gentoo-2f94817ec93094f0ffb3e406d9560b724bbccae6.zip
app-admin/ansible-lint: update EPYTEST_DESELECT + remove restriction
Was going to do this as part of the 6.4.0 bump but since that one depends on a newer version of dev-python/jsonschema, it will have to wait. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-lint/ansible-lint-6.3.0.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
index 6a378c69fa29..4aea510b329c 100644
--- a/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
+++ b/app-admin/ansible-lint/ansible-lint-6.3.0.ebuild
@@ -17,12 +17,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~riscv"
-# Since 6.2.0 ansible-lint once again does not need access to Ansible Galaxy
-# even to get the test suite started, however quite a large fraction of tests
-# fails without network access. Needs more work.
-PROPERTIES="test_network"
-RESTRICT="test"
-
RDEPEND="
>=app-admin/ansible-base-2.12.0[${PYTHON_USEDEP}]
>=dev-python/ansible-compat-2.1.0[${PYTHON_USEDEP}]
@@ -47,18 +41,26 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.0.2_test-module-check.patch
)
-# Skip problematic tests (TODO: update this list for ansible-lint-6.2.0+):
+# Skip problematic tests:
# - test_call_from_outside_venv doesn't play nicely with the sandbox
-# - all test_eco and some test_prerun tests require Internet access
-# - as of 5.4.0, test_cli_auto_detect fails even when run manually with tox
+# - all the others require Internet access, mostly in order to access Ansible Galaxy
EPYTEST_DESELECT=(
+ test/test_cli_role_paths.py::test_run_playbook_github
test/test_eco.py
+ test/test_examples.py::test_custom_kinds
+ test/test_import_playbook.py::test_task_hook_import_playbook
+ test/test_list_rules.py::test_list_rules_includes_opt_in_rules
+ test/test_list_rules.py::test_list_rules_with_format_option
+ test/test_list_rules.py::test_list_tags_includes_opt_in_rules
test/test_main.py::test_call_from_outside_venv
test/test_prerun.py::test_install_collection
test/test_prerun.py::test_prerun_reqs_v1
test/test_prerun.py::test_prerun_reqs_v2
test/test_prerun.py::test_require_collection_wrong_version
+ test/test_rules_collection.py::test_rich_rule_listing
test/test_utils.py::test_cli_auto_detect
+ test/test_utils.py::test_template_lookup
+ test/test_verbosity.py::test_default_verbosity
)
distutils_enable_tests pytest