summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-02 23:28:29 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-02 23:28:29 -0500
commit34f0deb97c4daa072f0e58345598874c729d3285 (patch)
tree2ae6b1c292d00262c7daf090a1eca13694536ebd /app-admin
parentdev-python/PyQt5: drop 5.15.2 (diff)
downloadgentoo-34f0deb97c4daa072f0e58345598874c729d3285.tar.gz
gentoo-34f0deb97c4daa072f0e58345598874c729d3285.tar.bz2
gentoo-34f0deb97c4daa072f0e58345598874c729d3285.zip
app-admin/cronlocker: 0.5.0 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/cronlocker/Manifest1
-rw-r--r--app-admin/cronlocker/cronlocker-0.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/cronlocker/Manifest b/app-admin/cronlocker/Manifest
index 89950da99365..5329a4e3e802 100644
--- a/app-admin/cronlocker/Manifest
+++ b/app-admin/cronlocker/Manifest
@@ -1 +1,2 @@
DIST cronlocker-0.4.0_p20180710.tar.gz 60256 BLAKE2B 62adf6a935e13d97de9776f40a9349f7b3f1758c9d90c11f66759b87d3d8d9dc20a78ecfe0aa7849319be3c8c557dae3d9cc04c87bc6226af5842c72efac0611 SHA512 fc73b572da4fe485f9ba13340b946db40d7e0224643b5fe0b8f56b24560ce4bc32d0a42e3e0e33b979d3aec2910e96ff847249181e7b69776174e2f28d67797c
+DIST cronlocker-0.5.0.tar.gz 937557 BLAKE2B ef34fd58e6df60cf2f216ea03dd40b139a60e36ae5a0ee6184e4eb8c1134c6afbbf8c83a8547c5d5b1387597df241c2579b047c720146dd259bb9eda80e1deab SHA512 821c200006fd2972bbb8d850a39348872e18b24ec9d68a90d0b3cce0848bd85d3542253260a4bb5bae3a89fe269b3c35151b829dbda5cacf9c7ab44a14a3c0a9
diff --git a/app-admin/cronlocker/cronlocker-0.5.0.ebuild b/app-admin/cronlocker/cronlocker-0.5.0.ebuild
new file mode 100644
index 000000000000..711bc7413ca4
--- /dev/null
+++ b/app-admin/cronlocker/cronlocker-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="synchronize a cron job across multiple hosts using the consul lock feature"
+HOMEPAGE="https://github.com/Barzahlen/cronlocker"
+SRC_URI="https://github.com/Barzahlen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ go build -o cronlocker . || die
+}
+
+src_install() {
+ dobin cronlocker
+ dodoc *.md package/changelog
+}