summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChema Alonso Josa <nimiux@gentoo.org>2017-02-25 11:41:24 +0100
committerChema Alonso Josa <nimiux@gentoo.org>2017-02-25 11:41:48 +0100
commit89aa925bcfe4cdc58fb1a3b7b886940fc25e4973 (patch)
tree50cf7adb49fc208cfcf6a411a1d8bef5bf7528ff /app-admin
parentmedia-sound/timemachine: Remove old (diff)
downloadgentoo-89aa925bcfe4cdc58fb1a3b7b886940fc25e4973.tar.gz
gentoo-89aa925bcfe4cdc58fb1a3b7b886940fc25e4973.tar.bz2
gentoo-89aa925bcfe4cdc58fb1a3b7b886940fc25e4973.zip
app-admin/tripwire: Bumps version to 2.4.3.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/tripwire/Manifest1
-rw-r--r--app-admin/tripwire/tripwire-2.4.3.3.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/app-admin/tripwire/Manifest b/app-admin/tripwire/Manifest
index 155d8db1b326..d036529d1744 100644
--- a/app-admin/tripwire/Manifest
+++ b/app-admin/tripwire/Manifest
@@ -1,2 +1,3 @@
DIST tripwire-2.4.3.1.tar.gz 932665 SHA256 9744af4de7ecb1d643442eb22f08c819556494bb6f56f5879e22c3438f2db896 SHA512 fb5f0ad353da826a0e8381e534e0da1ac9335851e108a23053e378afd3aec6e66931446addbf0ba8d55eaa8d3148c471056e26095aeff7696ed9b6d3633cdf90 WHIRLPOOL b87447869d845be840399389a3e3ed5f9c961f6777c1b463755994876b191e08cca359273826466d34f2f32a26b597f23d130f6cb689224ed3ff58810efceed1
DIST tripwire-2.4.3.2.tar.gz 967679 SHA256 25588c585f1af60958b3dce5bfc28e52c3237b2690dd5f4120e9c2f42d98fd2b SHA512 f3a3d5f12178d0766356d6280b3d993c29c1091357402661f0a4bb7676c640a147b74050c64e910c1210adef11903bde463813446e2c0ee9a34038876928bdfd WHIRLPOOL ac9812f3ec41afed5951e871d0ddad64eef3514a4cae071f414c7fa10d7318393d26107bb7007ca61554c328206b0da4790f0bc400fa7ea2159eb0b4f35e8303
+DIST tripwire-2.4.3.3.tar.gz 967929 SHA256 9db1832c6ea88569b6d7fe3fe896216efeae3046cfd148a5c4102e3bbf9ac749 SHA512 977895aa169a13e786f3428386a094a56d52bf0fdc4853ac8664f0d6110774f0ff2ce4db9d5f76c52299744faa680dc03201567a458c033b2cd01df1191b96cb WHIRLPOOL 888d8676b17537895ef3c6ee2313761f78511cb092485920024595fa5dd4b61263a0125a274f52220f6f98d147a3d8122017a39965610b809d016a8ae23b4987
diff --git a/app-admin/tripwire/tripwire-2.4.3.3.ebuild b/app-admin/tripwire/tripwire-2.4.3.3.ebuild
new file mode 100644
index 000000000000..842387cd9def
--- /dev/null
+++ b/app-admin/tripwire/tripwire-2.4.3.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Open Source File Integrity Checker and IDS"
+HOMEPAGE="http://www.tripwire.org/"
+SRC_URI="https://github.com/Tripwire/tripwire-open-source/archive/${PV}.tar.gz -> ${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libressl ssl static +tools"
+
+DEPEND="sys-devel/automake
+ sys-devel/autoconf
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+RDEPEND="virtual/cron
+ virtual/mta
+ ssl? ( dev-libs/openssl )"
+PDEPEND="tools? ( app-admin/mktwpol )"
+
+S="${WORKDIR}/tripwire-open-source-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # tripwire can be sensitive to compiler optimisation.
+ # see #32613, #45823, and others.
+ # -taviso@gentoo.org
+ strip-flags
+ append-cppflags -DCONFIG_DIR='"\"/etc/tripwire\""' -fno-strict-aliasing
+ econf $(use_enable ssl openssl) $(use_enable static)
+}
+
+src_install() {
+ dosbin "${S}"/bin/{siggen,tripwire,twadmin,twprint}
+ doman "${S}"/man/man{4/*.4,5/*.5,8/*.8}
+ dodir /etc/tripwire /var/lib/tripwire{,/report}
+ keepdir /var/lib/tripwire{,/report}
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/tripwire
+
+ dodoc ChangeLog policy/policyguide.txt TRADEMARK \
+ "${FILESDIR}"/tripwire.txt
+
+ insinto /etc/tripwire
+ doins "${FILESDIR}"/twcfg.txt policy/twpol-GENERIC.txt
+
+ fperms 750 /etc/cron.daily/tripwire
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Tripwire needs to be configured before its first run. You can"
+ elog "do this by manually editing the twpol-GENERIC.txt file shipped with"
+ elog "the package to suit your needs. A quickstart guide is provided"
+ elog "in tripwire.txt file to help you with this."
+ elog "To configure tripwire automatically, you can use the twsetup.sh"
+ elog "script provided by the app-admin/mktwpol package. This package is"
+ elog "installed for you by the \"tools\" USE flag (which is enabled by"
+ elog "default."
+else
+ elog "Maintenance of tripwire policy files as packages are added"
+ elog "and deleted from your system can be automated by the mktwpol.sh"
+ elog "script provided by the app-admin/mktwpol package. This package"
+ elog "is installed for you if you append \"tools\" to your USE flags"
+ fi
+}